version 2.18 is too old...

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

version 2.18 is too old...

Mike Dean
Error message:

Starting lilypond-windows.exe 2.18.2 [May-Jesus-Christ-Be-Praised.ly]...

Processing `C:/Users/Mike/Documents/musicwork/May-Jesus-Christ-Be-Praised.ly'

Parsing...

error: program too old: 2.18.2 (file requires: 2.20.0)


Would version 2.19.82 be a workaround?
Mike Dean

_______________________________________________
lilypond-user mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/lilypond-user
Reply | Threaded
Open this post in threaded view
|

Re: version 2.18 is too old...

Simon Albrecht-2
Whether version 2.18 is ‘too old’ or not, depends entirely on the input file. That's merely the message Lily gives according to the \version statement in the input.
But indeed, the unstable version provide a lot of advantages over the quite old stable one (a new one is due pretty soon-ish) while not being too unstable in fact.

Best, Simon

> On 29.10.2018 - 16:55, Mike Dean wrote:
>
>
> Error message:
>>
>>
>> Starting lilypond-windows.exe 2.18.2 [May-Jesus-Christ-Be-Praised.ly]...
>>
>> Processing `C:/Users/Mike/Documents/musicwork/May-Jesus-Christ-Be-Praised.ly'
>>
>> Parsing...
>>
>> error: program too old: 2.18.2 (file requires: 2.20.0)
>>
>>
>> Would version 2.19.82 be a workaround?
>>
>> Mike Dean
>

_______________________________________________
lilypond-user mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/lilypond-user
Reply | Threaded
Open this post in threaded view
|

Re: version 2.18 is too old...

Sam Bivens
In reply to this post by Mike Dean
Hi Mike,

Does your version statement in the file youre compiling say 2.18.2?

Sam


On Mon, Oct 29, 2018, 11:55 Mike Dean <[hidden email]> wrote:
Error message:

Starting lilypond-windows.exe 2.18.2 [May-Jesus-Christ-Be-Praised.ly]...

Processing `C:/Users/Mike/Documents/musicwork/May-Jesus-Christ-Be-Praised.ly'

Parsing...

error: program too old: 2.18.2 (file requires: 2.20.0)


Would version 2.19.82 be a workaround?
Mike Dean
_______________________________________________
lilypond-user mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/lilypond-user

_______________________________________________
lilypond-user mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/lilypond-user
Reply | Threaded
Open this post in threaded view
|

Re: version 2.18 is too old...

Mike Dean
1. Yes, it did 
Having downloaded LilyPond 2,19.82, the compilation attempt 'crashed and burned' at the start:

Starting lilypond-windows.exe [May-Jesus-Christ-Be-Praised.ly]...

Exited with return code -1073741819.


Mike Dean


On Mon, Oct 29, 2018 at 12:01 PM Sam Bivens <[hidden email]> wrote:
Hi Mike,

Does your version statement in the file youre compiling say 2.18.2?

Sam


On Mon, Oct 29, 2018, 11:55 Mike Dean <[hidden email]> wrote:
Error message:

Starting lilypond-windows.exe 2.18.2 [May-Jesus-Christ-Be-Praised.ly]...

Processing `C:/Users/Mike/Documents/musicwork/May-Jesus-Christ-Be-Praised.ly'

Parsing...

error: program too old: 2.18.2 (file requires: 2.20.0)


Would version 2.19.82 be a workaround?
Mike Dean
_______________________________________________
lilypond-user mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/lilypond-user

_______________________________________________
lilypond-user mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/lilypond-user
Reply | Threaded
Open this post in threaded view
|

Re: version 2.18 is too old...

Mike Dean
For what it's worth, following are two bug reports Frescobaldi auto-emailed...

Traceback (most recent call last):
  File "C:\Program Files (x86)\Frescobaldi\frescobaldi_app\process.py", line 105, in _done
    del self._schedule[0]
IndexError: list assignment index out of range

Traceback (most recent call last):
  File "C:\Program Files (x86)\Frescobaldi\frescobaldi_app\process.py", line 62, in _finished
    self._done(exitCode == 0)
  File "C:\Program Files (x86)\Frescobaldi\frescobaldi_app\process.py", line 69, in _done
    self.cleanup()
  File "C:\Program Files (x86)\Frescobaldi\frescobaldi_app\process.py", line 73, in cleanup
    self.process.deleteLater()
AttributeError: 'Process' object has no attribute 'process'

With respect to the version too old error, the fact that the compilation resulted in a fatal error is rather problematic.
Mike Dean


On Mon, Oct 29, 2018 at 12:05 PM Mike Dean <[hidden email]> wrote:
1. Yes, it did 
Having downloaded LilyPond 2,19.82, the compilation attempt 'crashed and burned' at the start:

Starting lilypond-windows.exe [May-Jesus-Christ-Be-Praised.ly]...

Exited with return code -1073741819.


Mike Dean


On Mon, Oct 29, 2018 at 12:01 PM Sam Bivens <[hidden email]> wrote:
Hi Mike,

Does your version statement in the file youre compiling say 2.18.2?

Sam


On Mon, Oct 29, 2018, 11:55 Mike Dean <[hidden email]> wrote:
Error message:

Starting lilypond-windows.exe 2.18.2 [May-Jesus-Christ-Be-Praised.ly]...

Processing `C:/Users/Mike/Documents/musicwork/May-Jesus-Christ-Be-Praised.ly'

Parsing...

error: program too old: 2.18.2 (file requires: 2.20.0)


Would version 2.19.82 be a workaround?
Mike Dean
_______________________________________________
lilypond-user mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/lilypond-user

_______________________________________________
lilypond-user mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/lilypond-user
Reply | Threaded
Open this post in threaded view
|

Re: version 2.18 is too old...

Malte Meyn-3
In reply to this post by Mike Dean


Am 29.10.18 um 17:05 schrieb Mike Dean:
> 1. Yes, it did
>
[…]

>
>
> On Mon, Oct 29, 2018 at 12:01 PM Sam Bivens <[hidden email]
> <mailto:[hidden email]>> wrote:
>
>     Hi Mike,
>
>     Does your version statement in the file youre compiling say 2.18.2?
>
>     Sam

Then you probably included a file which contains a \version statement
for 2.20.0.

_______________________________________________
lilypond-user mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/lilypond-user
Reply | Threaded
Open this post in threaded view
|

Re: version 2.18 is too old...

Urs Liska-3
In reply to this post by Mike Dean



Am 29.10.2018 um 17:25 schrieb Mike Dean:
For what it's worth, following are two bug reports Frescobaldi auto-emailed...

Traceback (most recent call last):
  File "C:\Program Files (x86)\Frescobaldi\frescobaldi_app\process.py", line 105, in _done
    del self._schedule[0]
IndexError: list assignment index out of range

Traceback (most recent call last):
  File "C:\Program Files (x86)\Frescobaldi\frescobaldi_app\process.py", line 62, in _finished
    self._done(exitCode == 0)
  File "C:\Program Files (x86)\Frescobaldi\frescobaldi_app\process.py", line 69, in _done
    self.cleanup()
  File "C:\Program Files (x86)\Frescobaldi\frescobaldi_app\process.py", line 73, in cleanup
    self.process.deleteLater()
AttributeError: 'Process' object has no attribute 'process'


These two do in fact look like bugs in Frescobaldi, maybe Frescobaldi choking about a LilyPond process terminated abnormally.
However, we won't look into this specific code because the code handling the LilyPond (and other external) processes has been rewritten anyway in the meantime. This means that while I can't guarantee anything like error-free-ness (or whatever a proper English term would be) surely *this* exact error condition won't appear again ...

With respect to the version too old error, the fact that the compilation resulted in a fatal error is rather problematic.

This has been discussed pretty often, and it's the deliberate choice of the core developers that letting the program "fail" in this case is better than not.

Urs

Mike Dean


On Mon, Oct 29, 2018 at 12:05 PM Mike Dean <[hidden email]> wrote:
1. Yes, it did 
Having downloaded LilyPond 2,19.82, the compilation attempt 'crashed and burned' at the start:

Starting lilypond-windows.exe [May-Jesus-Christ-Be-Praised.ly]...

Exited with return code -1073741819.


Mike Dean


On Mon, Oct 29, 2018 at 12:01 PM Sam Bivens <[hidden email]> wrote:
Hi Mike,

Does your version statement in the file youre compiling say 2.18.2?

Sam


On Mon, Oct 29, 2018, 11:55 Mike Dean <[hidden email]> wrote:
Error message:

Starting lilypond-windows.exe 2.18.2 [May-Jesus-Christ-Be-Praised.ly]...

Processing `C:/Users/Mike/Documents/musicwork/May-Jesus-Christ-Be-Praised.ly'

Parsing...

error: program too old: 2.18.2 (file requires: 2.20.0)


Would version 2.19.82 be a workaround?
Mike Dean
_______________________________________________
lilypond-user mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/lilypond-user


_______________________________________________
lilypond-user mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/lilypond-user


_______________________________________________
lilypond-user mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/lilypond-user