test on guile: truncating version number?

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

test on guile: truncating version number?

Jean-Charles Malahieude
Hi all!

Wishing to build on my new machine, I have downloaded the sources, and ran

[jcharles@localhost lilypond-2.10.12]$ ./configure --prefix=$HOME/usr

The problem is as follows:
[...]
config.status: creating config.hh

ERROR: Please install required programs:  guile-config >= 1.6.7
(installed: 1.6)

See INSTALL.txt for more information on how to build LilyPond
[jcharles@localhost lilypond-2.10.12]$ guile-config --version
guile-config - Guile version 1.6.8
[jcharles@localhost lilypond-2.10.12]$ which guile-config
/usr/bin/guile-config
[jcharles@localhost lilypond-2.10.12]$

What does this confusion mean? I have no idea.

Jean-Charles



_______________________________________________
lilypond-devel mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/lilypond-devel
Reply | Threaded
Open this post in threaded view
|

Re: test on guile: truncating version number?

John Mandereau
Hi Jean-Charles

Le samedi 20 janvier 2007 à 19:46 +0100, Jean-Charles a écrit :

> Hi all!
>
> Wishing to build on my new machine, I have downloaded the sources, and ran
>
> [jcharles@localhost lilypond-2.10.12]$ ./configure --prefix=$HOME/usr
>
> The problem is as follows:
> [...]
> config.status: creating config.hh
>
> ERROR: Please install required programs:  guile-config >= 1.6.7
> (installed: 1.6)
>
> See INSTALL.txt for more information on how to build LilyPond
> [jcharles@localhost lilypond-2.10.12]$ guile-config --version
> guile-config - Guile version 1.6.8
> [jcharles@localhost lilypond-2.10.12]$ which guile-config
> /usr/bin/guile-config
> [jcharles@localhost lilypond-2.10.12]$
>
> What does this confusion mean? I have no idea.

IIRC Guile 1.6.8 doesn't work for LilyPond; you should either downgrade
to 1.6.7, or upgrade to latest 1.8 with the rational bugfix patch
available in http://lilypond.org/vc/gub.darcs/patches/

Cheers
--
John Mandereau <[hidden email]>



_______________________________________________
lilypond-devel mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/lilypond-devel