running GUB binaries without installing

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

running GUB binaries without installing

Erik Sandberg-2
hi,

Now GUB works perfectly for me too (thanks a lot!).

Which is the preferred way to run the gub-generated lilypond without
installing the packages? i.e., what is the easiest way to
run 'target/linux-x86/system/usr/bin/lilypond foo.ly' so it uses the right gs
etc?

(Previously, I used LILYPONDPREFIX for this, which doesn't fix the gs
problems; I'm assuming that gub offers a Grand Unified Solution for this)

--
Erik


_______________________________________________
lilypond-devel mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/lilypond-devel
Reply | Threaded
Open this post in threaded view
|

Re: running GUB binaries without installing

Jan Nieuwenhuizen-2
Erik Sandberg <[hidden email]> writes:

> installing the packages? i.e., what is the easiest way to
> run 'target/linux-x86/system/usr/bin/lilypond foo.ly' so it uses the right gs
> etc?

Here's what I do to build web outside of GUB.

#! /bin/sh
# make-web

root=$HOME/vc/gub/target/linux-64/installer-origin
LILYPOND_EXTERNAL_BINARY=$root/usr/bin/lilypond PATH=$root/bin:$PATH LD_LIBRARY_PATH=$root/usr/lib:$LD_LIBRARY_PATH GS_LIB=$root/usr/share/ghostscript/*/lib make web




--
Jan Nieuwenhuizen <[hidden email]> | GNU LilyPond - The music typesetter
http://www.xs4all.nl/~jantien       | http://www.lilypond.org


_______________________________________________
lilypond-devel mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/lilypond-devel
Reply | Threaded
Open this post in threaded view
|

Re: running GUB binaries without installing

Han-Wen Nienhuys-2
In reply to this post by Erik Sandberg-2
Erik Sandberg escreveu:

> hi,
>
> Now GUB works perfectly for me too (thanks a lot!).
>
> Which is the preferred way to run the gub-generated lilypond without
> installing the packages? i.e., what is the easiest way to
> run 'target/linux-x86/system/usr/bin/lilypond foo.ly' so it uses the right gs
> etc?
>
> (Previously, I used LILYPONDPREFIX for this, which doesn't fix the gs
> problems; I'm assuming that gub offers a Grand Unified Solution for this)

Look at how the makefile solves this for building the
docs. Otherwise, you should be able to run from either
target/PLATFORM/installer-BRANCH/usr/bin/ or
target/PLATFORM/build/lilypond-BRANCH/out/bin/


--

Han-Wen Nienhuys - [hidden email] - http://www.xs4all.nl/~hanwen

LilyPond Software Design
 -- Code for Music Notation
http://www.lilypond-design.com



_______________________________________________
lilypond-devel mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/lilypond-devel