pango problem with lilypond 2.7

classic Classic list List threaded Threaded
10 messages Options
Reply | Threaded
Open this post in threaded view
|

pango problem with lilypond 2.7

Michael Porcaro

Hi,

 

I keep getting this error, when installing the latest version of lilypond:

 

Processing `2baaa9906a2a5af12b822767a1c97c36'
Parsing...
Interpreting music... [1]
Preprocessing graphical objects... 
Calculating line breaks... [2]
Interpreting music... 
MIDI output to `2baaa9906a2a5af12b822767a1c97c36.midi'...
Track... 
Calculating page breaks...lilypond: relocation error: lilypond: undefined symbol: pango_fc_font_get_type

 

This is the only version that seems to “almost” work on my server (2.7.16).  I CAN get 2.2.6 to work, however, it is old, and I would like to try to get the newer version to work before resorting to the older version.

 

Any help with the problem I mentioned?  Thanks!


_______________________________________________
lilypond-user mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/lilypond-user
Reply | Threaded
Open this post in threaded view
|

Re: pango problem with lilypond 2.7

Jan Nieuwenhuizen
Michael Porcaro writes:

> I keep getting this error, when installing the latest version of
> lilypond:
>  
> Processing `2baaa9906a2a5af12b822767a1c97c36'

What platform do you use?  How much memory is available?  This looks
quite odd, I would check your python installation.

Jan.

--
Jan Nieuwenhuizen <[hidden email]> | GNU LilyPond - The music typesetter
http://www.xs4all.nl/~jantien       | http://www.lilypond.org


_______________________________________________
lilypond-user mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/lilypond-user
Reply | Threaded
Open this post in threaded view
|

RE: pango problem with lilypond 2.7

Michael Porcaro
I forgot to reply all:

OS: CentOS 3.5 i686
256 megs of ram
1024MB RAM Burstable
python version 2.2.3, working correctly (should I install a newer
version?)

I am using wikitex to process this.  Although, the error I get surely is
this, and to me, doesn't really indicate an error with python, but
something wrong with pango:

Calculating page breaks...lilypond: relocation error: lilypond:
undefined symbol: pango_fc_font_get_type

lilypond 2.2.6 worked well (after about a month of trying to install it,
about to give up)

No other lilypond will install on my server.  2.4 gives me segmentation
faults.  2.5 and 2.6 keeps complaining about a missing pango, when it is
clearly installed.  At least 2.7 recognizes pango, I just get the weird
error I mentioned above.

-----Original Message-----
From: Jan Nieuwenhuizen [mailto:[hidden email]]
Sent: Thursday, November 17, 2005 2:00 AM
To: Michael Porcaro
Cc: [hidden email]
Subject: Re: pango problem with lilypond 2.7

Michael Porcaro writes:

> I keep getting this error, when installing the latest version of
> lilypond:
>  
> Processing `2baaa9906a2a5af12b822767a1c97c36'

What platform do you use?  How much memory is available?  This looks
quite odd, I would check your python installation.

Jan.

--
Jan Nieuwenhuizen <[hidden email]> | GNU LilyPond - The music
typesetter
http://www.xs4all.nl/~jantien       | http://www.lilypond.org




_______________________________________________
lilypond-user mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/lilypond-user
Reply | Threaded
Open this post in threaded view
|

Re: pango problem with lilypond 2.7

Jan Nieuwenhuizen
Michael Porcaro writes:

> I am using wikitex to process this.

You have sucessfully compiled and installed LilyPond, then?

> to me, doesn't really indicate an error with python

The reason I asked about python, is that when building/installing
LilyPond python runs lilypond with generated file names.  I did
not recognize the name

>> I keep getting this error, when installing the latest version of
>> lilypond:
>>  
>> Processing `2baaa9906a2a5af12b822767a1c97c36'

you get while installing.

> but something wrong with pango:

You suspect pango.  Have you checked your pango installation?  What
pango version do you have?  Do other pango programs (eg, gedit) work?

Jan.

--
Jan Nieuwenhuizen <[hidden email]> | GNU LilyPond - The music typesetter
http://www.xs4all.nl/~jantien       | http://www.lilypond.org


_______________________________________________
lilypond-user mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/lilypond-user
Reply | Threaded
Open this post in threaded view
|

Re: pango problem with lilypond 2.7

Han-Wen Nienhuys
In reply to this post by Michael Porcaro
Michael Porcaro wrote:
> I am using wikitex to process this.  Although, the error I get surely is
> this, and to me, doesn't really indicate an error with python, but
> something wrong with pango:
>
> Calculating page breaks...lilypond: relocation error: lilypond:
> undefined symbol: pango_fc_font_get_type

can you verify that you're using pango 1.6 or better?

--
  Han-Wen Nienhuys - [hidden email] - http://www.xs4all.nl/~hanwen


_______________________________________________
lilypond-user mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/lilypond-user
Reply | Threaded
Open this post in threaded view
|

RE: pango problem with lilypond 2.7

Michael Porcaro
In reply to this post by Jan Nieuwenhuizen
"You have sucessfully compiled and installed LilyPond, then?"

Correct, it installs fine, without force.

"The reason I asked about python, is that when building/installing
LilyPond python runs lilypond with generated file names.  I did
not recognize the name"

Yes, I should have mentioned that lilypond installs without a problem.

"You suspect pango.  Have you checked your pango installation?  What
pango version do you have?  Do other pango programs (eg, gedit) work?"

Yes I think pango is the culprit.

Pango 1.2 seems to work the best (I installed it through Yum, and the
highest version it installs is 1.2)  I can't install pango 1.6 or
greater without force, because it complains about me missing glib 2.4.
For instance, when I install pango 1.8 with force, I get this  error:

lilypond: relocation error:

/usr/lib/libpangoft2-1.0.so.0: undefined symbol:
g_type_class_add_private

When I install pango 1.10.1-6, I get this error:

lilypond: /lib/libc.so.6: version `GLIBC_2.4' not found (required by
/usr/lib/libpango-1.0.so.0)

At least pango 1.2 seems to recognize libpango-1.0.so.0 (just has a
confusing variable error).  It also seems to process, somewhat.

Is my only hope of installing a new version of lilypond moving on to
another server who will support glib 2.4?  Do I have to resort to 2.2.6
since it is the only version that seems to work on my server?

--
Jan Nieuwenhuizen <[hidden email]> | GNU LilyPond - The music
typesetter
http://www.xs4all.nl/~jantien       | http://www.lilypond.org




_______________________________________________
lilypond-user mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/lilypond-user
Reply | Threaded
Open this post in threaded view
|

Re: pango problem with lilypond 2.7

Mats Bengtsson-6


Michael Porcaro wrote:

> Pango 1.2 seems to work the best (I installed it through Yum, and the
> highest version it installs is 1.2)  I can't install pango 1.6 or
> greater without force, because it complains about me missing glib 2.4.
> For instance, when I install pango 1.8 with force, I get this  error:
>
> lilypond: relocation error:
>
> /usr/lib/libpangoft2-1.0.so.0: undefined symbol:
> g_type_class_add_private
>
> When I install pango 1.10.1-6, I get this error:
>
> lilypond: /lib/libc.so.6: version `GLIBC_2.4' not found (required by
> /usr/lib/libpango-1.0.so.0)
>
> At least pango 1.2 seems to recognize libpango-1.0.so.0 (just has a
> confusing variable error).  It also seems to process, somewhat.
>
> Is my only hope of installing a new version of lilypond moving on to
> another server who will support glib 2.4?  Do I have to resort to 2.2.6
> since it is the only version that seems to work on my server?

Either you have to find a precompiled package with Pango 1.6 (or newer)
that is compatible with your system or you can compile it yourself
against your version of glibc.

     /Mats


_______________________________________________
lilypond-user mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/lilypond-user
Reply | Threaded
Open this post in threaded view
|

Re: pango problem with lilypond 2.7

Han-Wen Nienhuys
In reply to this post by Michael Porcaro
Michael Porcaro wrote:

> "You have sucessfully compiled and installed LilyPond, then?"
>
> Correct, it installs fine, without force.
>
> "The reason I asked about python, is that when building/installing
> LilyPond python runs lilypond with generated file names.  I did
> not recognize the name"
>
> Yes, I should have mentioned that lilypond installs without a problem.
>
> "You suspect pango.  Have you checked your pango installation?  What
> pango version do you have?  Do other pango programs (eg, gedit) work?"
>
> Yes I think pango is the culprit.
>
> Pango 1.2 seems to work the best (I installed it through Yum, and the
> highest version it installs is 1.2)  I can't install pango 1.6 or
> greater without force, because it complains about me missing glib 2.4.

You can try upgrading to 1.4 or 1.6 by getting a .src.rpm from fedora,
and doing

   rpmbuild --rebuild pango-X.src.rpm

and if that succeeds, installing the newly created RPMs.

--
  Han-Wen Nienhuys - [hidden email] - http://www.xs4all.nl/~hanwen


_______________________________________________
lilypond-user mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/lilypond-user
Reply | Threaded
Open this post in threaded view
|

RE: pango problem with lilypond 2.7

Michael Porcaro
In reply to this post by Mats Bengtsson-6
"Either you have to find a precompiled package with Pango 1.6 (or newer)
that is compatible with your system "

No rpm above 1.2 works on my system, so I guess that is out of the
question.

"or you can compile it yourself against your version of glibc."

You mean a pango.tar.gz file?  Those don't work either, keeps
complaining about glib 2.4

Maybe I am misunderstanding what you mean.  My unix skills are getting
much better, but I am still nowhere near an expert.

Thanks.

-----Original Message-----
From: Mats Bengtsson [mailto:[hidden email]]
Sent: Thursday, November 17, 2005 2:07 PM
To: Michael Porcaro
Cc: 'Jan Nieuwenhuizen'; [hidden email]
Subject: Re: pango problem with lilypond 2.7



Michael Porcaro wrote:

> Pango 1.2 seems to work the best (I installed it through Yum, and the
> highest version it installs is 1.2)  I can't install pango 1.6 or
> greater without force, because it complains about me missing glib 2.4.
> For instance, when I install pango 1.8 with force, I get this  error:
>
> lilypond: relocation error:
>
> /usr/lib/libpangoft2-1.0.so.0: undefined symbol:
> g_type_class_add_private
>
> When I install pango 1.10.1-6, I get this error:
>
> lilypond: /lib/libc.so.6: version `GLIBC_2.4' not found (required by
> /usr/lib/libpango-1.0.so.0)
>
> At least pango 1.2 seems to recognize libpango-1.0.so.0 (just has a
> confusing variable error).  It also seems to process, somewhat.
>
> Is my only hope of installing a new version of lilypond moving on to
> another server who will support glib 2.4?  Do I have to resort to
2.2.6
> since it is the only version that seems to work on my server?

Either you have to find a precompiled package with Pango 1.6 (or newer)
that is compatible with your system or you can compile it yourself
against your version of glibc.

     /Mats




_______________________________________________
lilypond-user mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/lilypond-user
Reply | Threaded
Open this post in threaded view
|

Re: pango problem with lilypond 2.7

Jan Nieuwenhuizen
Michael Porcaro writes:

> "Either you have to find a precompiled package with Pango 1.6 (or newer)
> that is compatible with your system "
>
> No rpm above 1.2 works on my system

Then upgrade your system.  Pango 1.2.0 is three years old.  You
mentioned that it's a server, chances are you will hit security
problems if you do not upgrade.

Jan.

--
Jan Nieuwenhuizen <[hidden email]> | GNU LilyPond - The music typesetter
http://www.xs4all.nl/~jantien       | http://www.lilypond.org


_______________________________________________
lilypond-user mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/lilypond-user