osx 2.7.26 backend failure

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

osx 2.7.26 backend failure

Graham Percival-2
Hi all,

10.3.9, most recent fink, no packages installed manually, 2.7.26  
release from cvs, no extra patches (other than the one in  
./darwin.patch, which does the istream/iostream/std thing).

Test file is foo.ly:
{ c'4 }


lilypond foo.ly works perfectly.
lilypond -b=ps foo.ly  fails.  Yes, I know that -b=ps  should work  
exactly like having no arguments.  Any ideas?  I've got gdb installed,  
although I don't know how to use it.  Other backends fail with the same  
error message.

Cheers,
- Graham
----
spark:~/tmp/ly gpermus$ lilypond -VV -b=ps foo.ly
GNU LilyPond 2.7.26

LILYPOND_DATADIR="/Users/gpermus/usr/pkg/lilypond/share/lilypond/2.7.26"
LOCALEDIR="/Users/gpermus/usr/pkg/lilypond/share/locale"

Effective prefix:  
"/Users/gpermus/usr/pkg/lilypond/share/lilypond/2.7.26"
Initializing FontConfig...
adding font directory:  
/Users/gpermus/usr/pkg/lilypond/share/lilypond/2.7.26/fonts/otf/
adding font directory:  
/Users/gpermus/usr/pkg/lilypond/share/lilypond/2.7.26/fonts/type1/
Processing `foo.ly'
Parsing...[/Users/gpermus/usr/pkg/lilypond/share/lilypond/2.7.26/ly/
init.ly[/Users/gpermus/usr/pkg/lilypond/share/lilypond/2.7.26/ly/
declarations-init.ly[/Users/gpermus/usr/pkg/lilypond/share/lilypond/
2.7.26/ly/music-functions-init.ly][/Users/gpermus/usr/pkg/lilypond/
share/lilypond/2.7.26/ly/nederlands.ly][/Users/gpermus/usr/pkg/
lilypond/share/lilypond/2.7.26/ly/drumpitch-init.ly][/Users/gpermus/
usr/pkg/lilypond/share/lilypond/2.7.26/ly/chord-modifiers-init.ly][/
Users/gpermus/usr/pkg/lilypond/share/lilypond/2.7.26/ly/script-
init.ly][/Users/gpermus/usr/pkg/lilypond/share/lilypond/2.7.26/ly/
scale-definitions-init.ly][/Users/gpermus/usr/pkg/lilypond/share/
lilypond/2.7.26/ly/grace-init.ly][/Users/gpermus/usr/pkg/lilypond/
share/lilypond/2.7.26/ly/midi-init.ly[/Users/gpermus/usr/pkg/lilypond/
share/lilypond/2.7.26/ly/performer-init.ly]][/Users/gpermus/usr/pkg/
lilypond/share/lilypond/2.7.26/ly/paper-defaults.ly[/Users/gpermus/usr/
pkg/lilypond/share/lilypond/2.7.26/ly/titling-init.ly]][/Users/gpermus/
usr/pkg/lilypond/share/lilypond/2.7.26/ly/engraver-init.ly][/Users/
gpermus/usr/pkg/lilypond/share/lilypond/2.7.26/ly/dynamic-scripts-
init.ly][/Users/gpermus/usr/pkg/lilypond/share/lilypond/2.7.26/ly/
spanners-init.ly][/Users/gpermus/usr/pkg/lilypond/share/lilypond/
2.7.26/ly/property-init.ly]][foo.ly]
foo.ly: 0: warning: no \version statement found,  add

\version "2.7.26"

for future compatibility
Interpreting music...  
[/Users/gpermus/usr/pkg/lilypond/share/lilypond/2.7.26/fonts/otf/
emmentaler-20.otf][1]
elapsed time: 0.05 seconds
Element count 27 (spanners 8)
Preprocessing graphical objects...
Grob count 49
Calculating line breaks...  
[/Users/gpermus/usr/pkg/lilypond/share/lilypond/2.7.26/fonts/otf/
emmentaler-11.otf][/Users/gpermus/usr/pkg/lilypond/share/lilypond/
2.7.26/fonts/otf/emmentaler-13.otf][/Users/gpermus/usr/pkg/lilypond/
share/lilypond/2.7.26/fonts/otf/emmentaler-14.otf][/Users/gpermus/usr/
pkg/lilypond/share/lilypond/2.7.26/fonts/otf/emmentaler-16.otf][/Users/
gpermus/usr/pkg/lilypond/share/lilypond/2.7.26/fonts/otf/emmentaler
-18.otf][/Users/gpermus/usr/pkg/lilypond/share/lilypond/2.7.26/fonts/
otf/emmentaler-23.otf]
Global shortest duration is 3/16
[2]
Optimal demerits: 103.495995
Element count 39.[0]
Calculating page breaks...[century_schoolbook_l__3.865234375]
/Users/gpermus/usr/pkg/lilypond/share/lilypond/2.7.26/ly/init.ly:37:1:  
error: GUILE signaled an error for the expression beginning here
#
  (if (pair? toplevel-scores)unbound variable: output-framework

/Users/gpermus/usr/pkg/lilypond/share/lilypond/2.7.26/ly/init.ly:37:5:  
error: syntax error, unexpected '(', expecting '='
#(if
      (pair? toplevel-scores)]
error: failed files: "foo.ly"



_______________________________________________
lilypond-devel mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/lilypond-devel
Reply | Threaded
Open this post in threaded view
|

Re: osx 2.7.26 backend failure

Han-Wen Nienhuys
Graham Percival wrote:

> Hi all,
>
> 10.3.9, most recent fink, no packages installed manually, 2.7.26  
> release from cvs, no extra patches (other than the one in  
> ./darwin.patch, which does the istream/iostream/std thing).
>
> Test file is foo.ly:
> { c'4 }
>
>
> lilypond foo.ly works perfectly.
> lilypond -b=ps foo.ly  fails.  Yes, I know that -b=ps  should work  
> exactly like having no arguments.  Any ideas?  I've got gdb installed,  


try -b ps

we don't have a "=ps" backend.


--
  Han-Wen Nienhuys - [hidden email] - http://www.xs4all.nl/~hanwen


_______________________________________________
lilypond-devel mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/lilypond-devel