make web fails on debug build

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

make web fails on debug build

Joe Neeman-2
When I build with --enable-debug --disable-optimising, make web fails (with latest git master). I've narrowed it down to the following command:

./out/bin/lilypond -dgs-load-fonts --verbose  -b eps input/regression/utf- 8.ly

Which causes gs (8.50) to barf with:

Invoking `gs   -dNOSAFER   -dEPSCrop  -dCompatibilityLevel=1.4  -dNOPAUSE -dBATCH -r1200  -sDEVICE=pdfwrite -sOutputFile="utf-8-1.pdf" -c .setpdfwrite -f " utf-8-1.eps"'...GPL Ghostscript 8.50 (2005-12-31)
Copyright (C) 2005 artofcode LLC, Benicia, CA.  All rights reserved.
This software comes with NO WARRANTY: see the file PUBLIC for details.
Error: /rangecheck in --string--
Operand stack:
   --nostringval--   155849   155850
Execution stack:
   %interp_exit   .runexec2   --nostringval--   --nostringval--   --nostringval--   2   %stopped_push   --nostringval--   --nostringval--   --nostringval--   false   1   %stopped_push   1   3   %oparray_pop   1   3   %oparray_pop   --nostringval--   1   3   %oparray_pop   1   3   %oparray_pop   .runexec2   --nostringval--   --nostringval--   --nostringval--   2   %stopped_push   --nostringval--   --nostringval--   --nostringval--   %loop_continue   --nostringval--   1   --nostringval--   --nostringval--   false   1   %stopped_push   --nostringval--   --nostringval--   --nostringval--   --nostringval--   --nostringval--   %array_continue   --nostringval--   --nostringval--   --nostringval--
Dictionary stack:
   --dict:1123/1686(ro)(G)--   --dict:0/20(G)--   --dict:74/200(L)--   --dict:28/50(ro)(G)--   --dict:15/40(L)--
Current allocation mode is local
Current file position is 855
GPL Ghostscript 8.50: Unrecoverable error, exit code 1


Any ideas? I've also tried upgrading gs to 8.54, but it still failed. The full output is attached.

_______________________________________________
lilypond-devel mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/lilypond-devel

lilydump.txt (13K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: make web fails on debug build

Han-Wen Nienhuys-2
Joe Neeman escreveu:
> When I build with --enable-debug --disable-optimising, make web fails
> (with latest git master). I've narrowed it down to the following command:
>
> ./out/bin/lilypond -dgs-load-fonts --verbose  -b eps
> input/regression/utf- 8.ly <http://8.ly>
>
>
> Any ideas? I've also tried upgrading gs to 8.54, but it still failed.
> The full output is attached.

sounds like a TTF GS problem. Have you tried svn HEAD ?

--

Han-Wen Nienhuys - [hidden email] - http://www.xs4all.nl/~hanwen

LilyPond Software Design
  -- Code for Music Notation
http://www.lilypond-design.com



_______________________________________________
lilypond-devel mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/lilypond-devel