lilypond-windows.exe does nothing

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

lilypond-windows.exe does nothing

Plmcky
I'm trying to upgrade from 2.19 to 2.20 on a laptop running Win 10. Uninstalled lilypond and Frescobaldi. Reinstalled 2.20. Loaded .ly file.
Asked to engrave it. It worked but there were errors in the .ly file. Fixed them. Asked to engrave it. Nothing happened. Repeatedly … No other files would engrave. Uninstalled Frescobaldi. Manually deleted all references to it from the registry. Reinstalled it. No change. Tried to run lilypond manually. (Lilypond and Lilypond/usr/bin are in my path.) lilypond -h works fine and gives me the output I expect. lilypond-windows -h does nothing. I uninstalled lilypond. Manually removed most mentions in the registry. Downloaded it again and reinstalled. It still does nothing whenever Frescobaldi or I try run it.

Any suggestions as to what to try next would be appreciated.
Thanks
Paul McKay
Reply | Threaded
Open this post in threaded view
|

Re: lilypond-windows.exe does nothing

Anders Eriksson
Just FYI, I'm running Windows 10 and Lilypond 2.20 (and 2.21) and lilypond-windows -h does nothing as you say. But if I call
lilypond-windows test.ly then it creates test.pdf

Also running it via Frescobaldi v3.1.2 works perfectly.
I tried to change lilypond-windows.exe to lilypond.exe in Frescobaldi and that worked also...

// Anders

On 2020-10-03 09:20, Paul McKay wrote:
I'm trying to upgrade from 2.19 to 2.20 on a laptop running Win 10. Uninstalled lilypond and Frescobaldi. Reinstalled 2.20. Loaded .ly file.
Asked to engrave it. It worked but there were errors in the .ly file. Fixed them. Asked to engrave it. Nothing happened. Repeatedly … No other files would engrave. Uninstalled Frescobaldi. Manually deleted all references to it from the registry. Reinstalled it. No change. Tried to run lilypond manually. (Lilypond and Lilypond/usr/bin are in my path.) lilypond -h works fine and gives me the output I expect. lilypond-windows -h does nothing. I uninstalled lilypond. Manually removed most mentions in the registry. Downloaded it again and reinstalled. It still does nothing whenever Frescobaldi or I try run it.

Any suggestions as to what to try next would be appreciated.
Thanks
Paul McKay