lilypond-book problem 2.5.30

classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|

lilypond-book problem 2.5.30

libero.mureddu3
Hi,
after a crash of two months of my laptop, I am very happy to use again lilypond!
And congratulation for the new installer, it is really easy and nice to install
and use!

I've just tried to use lilypond-book in 2.5.30 on mac os x 10.3.9, but I've
received the following error:

Computer-di-Libero-Mureddu:~/Desktop liberomureddu$ /Applications/LilyPond.app/Contents/Resources/bin/lilypond-book
--output=~/Desktop  prova.tex
Traceback (most recent call last):
  File "/Applications/LilyPond.app/Contents/Resources/bin/lilypond-book",
line 60, in ?
    import lilylib as ly
ImportError: No module named lilylib

The file I used is from the manual:

\documentclass[]{article}
\begin{document}
Normal LaTeX text.
\begin{lilypond}
\relative c?? { a4 b c d }
\end{lilypond}
 More LaTeX text.
\begin{lilypond}
\relative c?? { d4 c b a }
\end{lilypond}
\end{document}

Thanks again for your great job!!!

Libero Mureddu




_______________________________________________
lilypond-user mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/lilypond-user
Reply | Threaded
Open this post in threaded view
|

Re: lilypond-book problem 2.5.30

Graham Percival

On 13-Jun-05, at 5:08 AM, [hidden email] wrote:

> The file I used is from the manual:

Sorry, you currently need to add one line to this example (see below).
This will be fixed Very Soon Now (tm).

> \documentclass[]{article}

\usepackage{graphics}

> \begin{document}
> Normal LaTeX text.
> \begin{lilypond}
> \relative c?? { a4 b c d }
> \end{lilypond}
>  More LaTeX text.
> \begin{lilypond}
> \relative c?? { d4 c b a }
> \end{lilypond}
> \end{document}

Cheers,
- Graham



_______________________________________________
lilypond-user mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/lilypond-user
Reply | Threaded
Open this post in threaded view
|

Re: lilypond-book problem 2.5.30

libero.mureddu3
Thanks, but still I obtain the same error message:

Traceback (most recent call last):
  File "/Applications/LilyPond.app/Contents/Resources/bin/lilypond-book",
line 60, in ?
    import lilylib as ly
ImportError: No module named lilylib

Libero

>-- Original Message --
>Date: Mon, 13 Jun 2005 16:50:39 -0700
>From: Graham Percival <[hidden email]>
>Subject: Re: lilypond-book problem 2.5.30
>To: [hidden email]
>Cc: [hidden email]
>
>
>
>On 13-Jun-05, at 5:08 AM, [hidden email] wrote:
>
>> The file I used is from the manual:
>
>Sorry, you currently need to add one line to this example (see below).
>This will be fixed Very Soon Now (tm).
>
>> \documentclass[]{article}
>
>\usepackage{graphics}
>
>> \begin{document}
>> Normal LaTeX text.
>> \begin{lilypond}
>> \relative c?? { a4 b c d }
>> \end{lilypond}
>>  More LaTeX text.
>> \begin{lilypond}
>> \relative c?? { d4 c b a }
>> \end{lilypond}
>> \end{document}
>
>Cheers,
>- Graham
>




_______________________________________________
lilypond-user mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/lilypond-user
Reply | Threaded
Open this post in threaded view
|

Re: lilypond-book problem 2.5.30

Graham Percival
In reply to this post by Graham Percival
Sorry, I don't have a clue.  Try a new binary package, and if it still
happens,
send an email to bug-lilypond.

- Graham

On 13-Jun-05, at 11:19 PM, Libero Mureddu wrote:

> Thanks, but still I obtain the same error message:
>
> Traceback (most recent call last):
>   File
> "/Applications/LilyPond.app/Contents/Resources/bin/lilypond-book",
> line 60, in ?
>     import lilylib as ly
> ImportError: No module named lilylib
>
> Libero
>
>
> Il giorno 14/giu/05, alle 02:50, Graham Percival ha scritto:
>
>>
>> On 13-Jun-05, at 5:08 AM, [hidden email] wrote:
>>
>>> The file I used is from the manual:
>>
>> Sorry, you currently need to add one line to this example (see below).
>> This will be fixed Very Soon Now (tm).
>>
>>> \documentclass[]{article}
>>
>> \usepackage{graphics}
>>
>>> \begin{document}
>>> Normal LaTeX text.
>>> \begin{lilypond}
>>> \relative c?? { a4 b c d }
>>> \end{lilypond}
>>>  More LaTeX text.
>>> \begin{lilypond}
>>> \relative c?? { d4 c b a }
>>> \end{lilypond}
>>> \end{document}
>>
>> Cheers,
>> - Graham
>>
>



_______________________________________________
lilypond-user mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/lilypond-user
Reply | Threaded
Open this post in threaded view
|

Re: lilypond-book problem 2.5.30

Jan Nieuwenhuizen
In reply to this post by libero.mureddu3
libero writes:

> Thanks, but still I obtain the same error message:
>
> Traceback (most recent call last):
>   File "/Applications/LilyPond.app/Contents/Resources/bin/lilypond-book",
> line 60, in ?
>     import lilylib as ly
> ImportError: No module named lilylib

Thanks.  This will be fixed in 2.5.30

Jan.

--
Jan Nieuwenhuizen <[hidden email]> | GNU LilyPond - The music typesetter
http://www.xs4all.nl/~jantien       | http://www.lilypond.org


_______________________________________________
lilypond-user mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/lilypond-user
Reply | Threaded
Open this post in threaded view
|

Re: lilypond-book problem 2.5.30

Han-Wen Nienhuys
In reply to this post by libero.mureddu3
[hidden email] wrote:

> Hi,
> after a crash of two months of my laptop, I am very happy to use again lilypond!
> And congratulation for the new installer, it is really easy and nice to install
> and use!
>
> I've just tried to use lilypond-book in 2.5.30 on mac os x 10.3.9, but I've
> received the following error:
>
> Computer-di-Libero-Mureddu:~/Desktop liberomureddu$ /Applications/LilyPond.app/Contents/Resources/bin/lilypond-book
> --output=~/Desktop  prova.tex
> Traceback (most recent call last):
>   File "/Applications/LilyPond.app/Contents/Resources/bin/lilypond-book",
> line 60, in ?
>     import lilylib as ly
> ImportError: No module named lilylib
>

can you try .31-2 ?
--
  Han-Wen Nienhuys - [hidden email] - http://www.xs4all.nl/~hanwen


_______________________________________________
lilypond-user mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/lilypond-user
Reply | Threaded
Open this post in threaded view
|

Re: lilypond-book problem 2.5.30

libero.mureddu3
Hi!
I tried the new version, but I obtain the following error message (with the
verbose option):
At the moment I have texshop installed, with the tex package of Gerben Wierda,
I mean, not the fink tex intallation. Maybe this is useful to know.
Thanks

Libero

Computer-di-Libero-Mureddu:~/Desktop liberomureddu$ lilypond-book --output=out
-V prova.tex
lilypond-book (GNU LilyPond) 2.5.31
Opening pipe `kpsexpand \$TEXMF'
Opening pipe `kpsewhich -expand-path=\$T1FONTS'
Reading prova.tex...
Opening filter `latex "\nonstopmode \input /dev/stdin"'
Dissecting...
Writing snippets...
Processing...
Invoking `lilypond --formats=ps --backend eps  -I /Volumes/scripta/Users/liberomureddu/Desktop
snippet-map.ly lily-1481342208 lily-867219905'GNU LilyPond 2.5.31
Processing `/Volumes/scripta/Users/liberomureddu/Desktop/out/snippet-map.ly'
Parsing...
Processing `/Volumes/scripta/Users/liberomureddu/Desktop/out/lily-1481342208.ly'
Parsing...
Interpreting music... [1]
Preprocessing graphical objects...
Calculating line breaks... [2]/Volumes/scripta/Users/liberomureddu/Desktop/out/lily-1481342208.ly:2:32:
In procedure module-lookup in expression (ly:parser-print-score p (ly:music-scorify
m p)):
/Volumes/scripta/Users/liberomureddu/Desktop/out/lily-1481342208.ly:2:32:
unbound variable: output-classic-framework
lilypond-book: warning: `lilypond' failed (status 2) (ignored)

lilypond-book: error: Process lilypond --formats=ps --backend eps  -I /Volumes/scripta/Users/liberomureddu/Desktop
snippet-map.ly lily-1481342208 lily-867219905 exited unsuccessfully.
Removing `prova.tex'
Traceback (most recent call last):
  File "/Applications/LilyPond.app/Contents/Resources/bin/lilypond-book",
line 1614, in ?
    main ()
  File "/Applications/LilyPond.app/Contents/Resources/bin/lilypond-book",
line 1597, in main
    ly.exit (1)
  File "/Applications/LilyPond.app/Contents/Resources/share/lilypond/current/python/lilylib.py",
line 132, in exit
    raise _ ('Exiting (%d)...') % i
Exiting (1)...

>-- Original Message --
>Date: Wed, 15 Jun 2005 17:14:53 +0200
>From: Han-Wen Nienhuys <[hidden email]>
>To: [hidden email]
>CC: [hidden email]
>Subject: Re: lilypond-book problem 2.5.30
>
>
>[hidden email] wrote:
>> Hi,
>> after a crash of two months of my laptop, I am very happy to use again
>lilypond!
>> And congratulation for the new installer, it is really easy and nice to
>install
>> and use!
>>
>> I've just tried to use lilypond-book in 2.5.30 on mac os x 10.3.9, but
>I've
>> received the following error:
>>
>> Computer-di-Libero-Mureddu:~/Desktop liberomureddu$ /Applications/LilyPond.app/Contents/Resources/bin/lilypond-book
>> --output=~/Desktop  prova.tex
>> Traceback (most recent call last):
>>   File "/Applications/LilyPond.app/Contents/Resources/bin/lilypond-book",
>> line 60, in ?
>>     import lilylib as ly
>> ImportError: No module named lilylib
>>
>
>can you try .31-2 ?
>--
>  Han-Wen Nienhuys - [hidden email] - http://www.xs4all.nl/~hanwen




_______________________________________________
lilypond-user mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/lilypond-user
Reply | Threaded
Open this post in threaded view
|

Re: lilypond-book problem 2.5.30

libero.mureddu3
In reply to this post by Han-Wen Nienhuys
Hi!
I tried the new version, but I obtain the following error message (with the
verbose option):
At the moment I have texshop installed, with the tex package of Gerben Wierda,
I mean, not the fink tex intallation. Maybe this is useful to know.
Thanks

Libero

Computer-di-Libero-Mureddu:~/Desktop liberomureddu$ lilypond-book --output=out
-V prova.tex
lilypond-book (GNU LilyPond) 2.5.31
Opening pipe `kpsexpand \$TEXMF'
Opening pipe `kpsewhich -expand-path=\$T1FONTS'
Reading prova.tex...
Opening filter `latex "\nonstopmode \input /dev/stdin"'
Dissecting...
Writing snippets...
Processing...
Invoking `lilypond --formats=ps --backend eps  -I /Volumes/scripta/Users/liberomureddu/Desktop
snippet-map.ly lily-1481342208 lily-867219905'GNU LilyPond 2.5.31
Processing `/Volumes/scripta/Users/liberomureddu/Desktop/out/snippet-map.ly'
Parsing...
Processing `/Volumes/scripta/Users/liberomureddu/Desktop/out/lily-1481342208.ly'
Parsing...
Interpreting music... [1]
Preprocessing graphical objects...
Calculating line breaks... [2]/Volumes/scripta/Users/liberomureddu/Desktop/out/lily-1481342208.ly:2:32:
In procedure module-lookup in expression (ly:parser-print-score p (ly:music-scorify
m p)):
/Volumes/scripta/Users/liberomureddu/Desktop/out/lily-1481342208.ly:2:32:
unbound variable: output-classic-framework
lilypond-book: warning: `lilypond' failed (status 2) (ignored)

lilypond-book: error: Process lilypond --formats=ps --backend eps  -I /Volumes/scripta/Users/liberomureddu/Desktop
snippet-map.ly lily-1481342208 lily-867219905 exited unsuccessfully.
Removing `prova.tex'
Traceback (most recent call last):
  File "/Applications/LilyPond.app/Contents/Resources/bin/lilypond-book",
line 1614, in ?
    main ()
  File "/Applications/LilyPond.app/Contents/Resources/bin/lilypond-book",
line 1597, in main
    ly.exit (1)
  File "/Applications/LilyPond.app/Contents/Resources/share/lilypond/current/python/lilylib.py",
line 132, in exit
    raise _ ('Exiting (%d)...') % i
Exiting (1)...

>-- Original Message --
>Date: Wed, 15 Jun 2005 17:14:53 +0200
>From: Han-Wen Nienhuys <[hidden email]>
>To: [hidden email]
>CC: [hidden email]
>Subject: Re: lilypond-book problem 2.5.30
>
>
>[hidden email] wrote:
>> Hi,
>> after a crash of two months of my laptop, I am very happy to use again
>lilypond!
>> And congratulation for the new installer, it is really easy and nice to
>install
>> and use!
>>
>> I've just tried to use lilypond-book in 2.5.30 on mac os x 10.3.9, but
>I've
>> received the following error:
>>
>> Computer-di-Libero-Mureddu:~/Desktop liberomureddu$ /Applications/LilyPond.app/Contents/Resources/bin/lilypond-book
>> --output=~/Desktop  prova.tex
>> Traceback (most recent call last):
>>   File "/Applications/LilyPond.app/Contents/Resources/bin/lilypond-book",
>> line 60, in ?
>>     import lilylib as ly
>> ImportError: No module named lilylib
>>
>
>can you try .31-2 ?
>--
>  Han-Wen Nienhuys - [hidden email] - http://www.xs4all.nl/~hanwen




_______________________________________________
lilypond-user mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/lilypond-user