lilypond 2.19.82 now in macports

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

lilypond 2.19.82 now in macports

Werner LEMBERG

Folks,


lilypond 2.19.82, the last released development version, is now
available in macports.


    Werner

_______________________________________________
lilypond-user mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/lilypond-user
Reply | Threaded
Open this post in threaded view
|

Re: lilypond 2.19.82 now in macports

Thomas Scharkowski-2
-------- Original-Nachricht --------

>
> Folks,
>
>
> lilypond 2.19.82, the last released development version, is now
> available in macports.
>
>
>      Werner
>
Just curious - why should one use the macports version instead of the
binary provided by lilypond.org?

Thomas

_______________________________________________
lilypond-user mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/lilypond-user
Reply | Threaded
Open this post in threaded view
|

Re: lilypond 2.19.82 now in macports

Thomas Scharkowski
In reply to this post by Werner LEMBERG
-------- Original-Nachricht --------

>
> Folks,
>
>
> lilypond 2.19.82, the last released development version, is now
> available in macports.
>
>
>      Werner
>
Just curious - why should one use the macports version instead of the
binary provided by lilypond.org?

Thomas

_______________________________________________
lilypond-user mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/lilypond-user
Reply | Threaded
Open this post in threaded view
|

Fwd: lilypond 2.19.82 now in macports

Sven Axelsson-3
In reply to this post by Thomas Scharkowski-2
On Sat, 1 Dec 2018 at 23:30, Michael Hendry <[hidden email]> wrote:
> On 1 Dec 2018, at 22:19, Karlin High <[hidden email]> wrote:
>
> On 12/1/2018 3:50 PM, Werner LEMBERG wrote:
>> It seamlessly integrates into macports, which means it can be easily
>>   installed with `port install lilypond-devel'.  It can be also easily
>>   removed with a similar command.
>
> How hard would it be to get LilyPond into the macOS App Store?


…and is there any reason why it couldn’t be made available for Homebrew?

It was removed from Homebrew due to the dependency on Guile 1.8 which conflicted with too many other packages. But the prebuilt binaries from lilypond.org *are* available through "brew cask" which is the most convenient way of installing applications for macOS.

--
Sven Axelsson
++++++++++[>++++++++++>+++++++++++>++++++++++>++++++
>++++<<<<<-]>++++.+.++++.>+++++.>+.<<-.>>+.>++++.<<.
+++.>-.<<++.>>----.<++.>>>++++++.<<<<.>>++++.<----.


_______________________________________________
lilypond-user mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/lilypond-user