layout doesn't work as I expected

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

layout doesn't work as I expected

fcorvi
This post was updated on .
CONTENTS DELETED
The author has deleted this message.
Reply | Threaded
Open this post in threaded view
|

Re: layout doesn't work as I expected

pkx166h-4
hello fcorvi

This sounds like a question for the 'user' list not the 'bug' list.

I suggest you try there first.

This 'bug-lilypond' list is specifically for problems with the lilypond
code/ incorrect/ugly output than for questions about how to do X or why
something might not do what you expect - at least at first.

The user list is very active and I am sure someone will be able to
advise you.

See:


        |[hidden email]|

http://lists.gnu.org/mailman/listinfo/lilypond-user

Regards

James


On 02/02/2020 14:36, fcorvi wrote:

> Hello everybody,
> I am moving the first steps into lilypond and I am currently trying to
> create a musical sheet for percussions.
> I would like to be able to specify different measure lenghts for each staff
> independently and I am doing this in the layout options.
> What is happening in that when I put the layout option after my score it
> doesn't affects nothing at all, when I put it after the pdf file will not be
> generated.
>
> This is my code
>
>      \version "2.18.2"
>   \language "italiano"
>  
>
>  
> \header {
>    title = "Ritmic"
> }
>
>        % rendo i due pentagrammi indipendenti
>    \layout{
>            \context {
>                            \Score
>                            \remove "Timing_translator"
>                            \remove "Default_bar_line_engraver"
>                           }
>             \context {
>                             \DrumStaff
>                             \consists "Timing_translator"
>                             \consists "Default_bar_line_engraver"
>                            }
>                }
>                
>
> rul = \drummode { \time 3/8 dc4 dc8 dc dc dc
>          
>        }
> timp = \drummode {
>          % timh4 ssh timl8 ssh r timh r4 ssh8 timl
>          \time 2/8 timh4 timl
>         }
>
> \score {
>    <<
>      \new DrumStaff \with {
>                                            instrumentName = #"timpani"
>                                            drumStyleTable = #timbales-style
>                                            \override StaffSymbol.line-count =
> #2
>                                            \override BarLine.bar-extent =
> #'(-1 . 1)
>                                            }
>      <<
>        \timp
>      >>
>      \new DrumStaff \with {
>                                            instrumentName = #"rullante"
>                                             %drumStyleTable = #timbales-style
>                                            \override StaffSymbol.line-count =
> #1
>                                            %\override BarLine.bar-extent =
> #'(-1 . 1)
>                                            }
>      <<
>      \rul
>      % \new DrumVoice { \stemUp \timp }
>      %  \new DrumVoice { \stemDown \rul }
>      >>
>    >>
>    
>
>                
>    \midi { \tempo 4 = 120 }
>
> }
>
>
>
> Any help will be very appreciate, even if there are some mistakes or
> suggestion apart from what I've asked
>
>
>
> --
> Sent from: http://lilypond.1069038.n5.nabble.com/Bugs-f58488.html
>
> _______________________________________________
> bug-lilypond mailing list
> [hidden email]
> https://lists.gnu.org/mailman/listinfo/bug-lilypond


_______________________________________________
bug-lilypond mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/bug-lilypond
Reply | Threaded
Open this post in threaded view
|

Re: layout doesn't work as I expected

fcorvi
Ok, thanks.

Il Dom 2 Feb 2020, 20:55 <[hidden email]> ha scritto:

> hello fcorvi
>
> This sounds like a question for the 'user' list not the 'bug' list.
>
> I suggest you try there first.
>
> This 'bug-lilypond' list is specifically for problems with the lilypond
> code/ incorrect/ugly output than for questions about how to do X or why
> something might not do what you expect - at least at first.
>
> The user list is very active and I am sure someone will be able to advise
> you.
>
> See:
> [hidden email]
>
> http://lists.gnu.org/mailman/listinfo/lilypond-user
> Regards
>
> James
>
> On 02/02/2020 14:36, fcorvi wrote:
>
> Hello everybody,
> I am moving the first steps into lilypond and I am currently trying to
> create a musical sheet for percussions.
> I would like to be able to specify different measure lenghts for each staff
> independently and I am doing this in the layout options.
> What is happening in that when I put the layout option after my score it
> doesn't affects nothing at all, when I put it after the pdf file will not be
> generated.
>
> This is my code
>
>     \version "2.18.2"
>  \language "italiano"
>
>
>
> \header {
>   title = "Ritmic"
> }
>
>       % rendo i due pentagrammi indipendenti
>   \layout{
>           \context {
>                           \Score
>                           \remove "Timing_translator"
>                           \remove "Default_bar_line_engraver"
>                          }
>            \context {
>                            \DrumStaff
>                            \consists "Timing_translator"
>                            \consists "Default_bar_line_engraver"
>                           }
>               }
>
>
> rul = \drummode { \time 3/8 dc4 dc8 dc dc dc
>
>       }
> timp = \drummode {
>         % timh4 ssh timl8 ssh r timh r4 ssh8 timl
>         \time 2/8 timh4 timl
>        }
>
> \score {
>   <<
>     \new DrumStaff \with {
>                                           instrumentName = #"timpani"
>                                           drumStyleTable = #timbales-style
>                                           \override StaffSymbol.line-count =
> #2
>                                           \override BarLine.bar-extent =
> #'(-1 . 1)
>                                           }
>     <<
>       \timp
>     >>
>     \new DrumStaff \with {
>                                           instrumentName = #"rullante"
>                                            %drumStyleTable = #timbales-style
>                                           \override StaffSymbol.line-count =
> #1
>                                           %\override BarLine.bar-extent =
> #'(-1 . 1)
>                                           }
>     <<
>     \rul
>     % \new DrumVoice { \stemUp \timp }
>     %  \new DrumVoice { \stemDown \rul }
>     >>
>   >>
>
>
>
>   \midi { \tempo 4 = 120 }
>
> }
>
>
>
> Any help will be very appreciate, even if there are some mistakes or
> suggestion apart from what I've asked
>
>
>
> --
> Sent from: http://lilypond.1069038.n5.nabble.com/Bugs-f58488.html
>
> _______________________________________________
> bug-lilypond mailing [hidden email]://lists.gnu.org/mailman/listinfo/bug-lilypond
>
>
>
_______________________________________________
bug-lilypond mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/bug-lilypond