jedit and dvi

classic Classic list List threaded Threaded
14 messages Options
Reply | Threaded
Open this post in threaded view
|

jedit and dvi

Art Hixson
Sorry to bring this up again as there were quite a few posts a while
ago.  However, I couldn't seem to make much sense of them.

I'm experimenting with Jedit in XP and an unable to get the JDVI
function to find the music fonts, although the PostScript viewer works fine.

I assume that I need to put the path to fonts somewhere in Jedit but I'm
not finding a file or dialog in which to do this.

Otherwise, I'm having a grand time with Lilypond.


--
No virus found in this outgoing message.
Checked by AVG Anti-Virus.
Version: 7.0.323 / Virus Database: 267.6.4 - Release Date: 2005/06/06



_______________________________________________
lilypond-user mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/lilypond-user
Reply | Threaded
Open this post in threaded view
|

Re: jedit and dvi

Bertalan Fodor
Finding the fonts sometimes works from the first time, sometimes
doesn't. I'll put on a  newer version of lily4jedit this week.

Bert


_______________________________________________
lilypond-user mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/lilypond-user
Reply | Threaded
Open this post in threaded view
|

Re: jedit and dvi

Art Hixson
Bertalan Fodor wrote:

> Finding the fonts sometimes works from the first time, sometimes
> doesn't. I'll put on a  newer version of lily4jedit this week.
>
> Bert
>
Bert were you able to fix this?

I just uninstalled lily4jedit and reinstalled it.  For a short while
jdvi worked very well but then something happened and it issued a
message that it was building fonts.  At that point the whole application
froze and had to be killed.  On restart, the same problem occurs.  This
is exactly what happened on my first post.

I like jedit very much for this type of coding and the plugin is very
nice.  So, I hope you can figure this one out.  Let me know!

Cheers,
Arthur


--
No virus found in this outgoing message.
Checked by AVG Anti-Virus.
Version: 7.0.323 / Virus Database: 267.6.7 - Release Date: 2005/06/10



_______________________________________________
lilypond-user mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/lilypond-user
Reply | Threaded
Open this post in threaded view
|

Re: jedit and dvi

Bertalan Fodor
Hi,

I uploaded a new development version.
It is not stable, but all functions that worked before, should work now
as well.
There are some new functions that doesn't work (like internal pdf viewer)

Download lily4jedit-0.2.8-2 from
https://sourceforge.net/project/showfiles.php?group_id=91119&package_id=121443&release_id=334169

You must unzip it into jEdit's jars directory.

There is also a new dependency, that you must install manually:
Download jtextcheck from:
http://prdownloads.sourceforge.net/jtextcheck/jtextcheck-1.0-b5-bin.tar.gz?download
It is very big, but you only need to put one jar file into jEdit's jars
directory:
jtextcheck-1.0-b5.jar

I hope it will solve your problems. If not, let me know.

Bert



Art Hixson ?rta:

> Bertalan Fodor wrote:
>
>> Finding the fonts sometimes works from the first time, sometimes
>> doesn't. I'll put on a  newer version of lily4jedit this week.
>>
>> Bert
>>
> Bert were you able to fix this?
>
> I just uninstalled lily4jedit and reinstalled it.  For a short while
> jdvi worked very well but then something happened and it issued a
> message that it was building fonts.  At that point the whole
> application froze and had to be killed.  On restart, the same problem
> occurs.  This is exactly what happened on my first post.
>
> I like jedit very much for this type of coding and the plugin is very
> nice.  So, I hope you can figure this one out.  Let me know!
>
> Cheers,
> Arthur
>
>



_______________________________________________
lilypond-user mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/lilypond-user
Reply | Threaded
Open this post in threaded view
|

Re: jedit and dvi

Thomas Scharkowski
Hello Bert,

I have installed the new version and get the following:

/usr/share/guile/1.6/srfi/srfi-13.scm:159:1: In procedure dynamic-
link in expression (load-extension "libguile-srfi-srfi-13-14-v-1"
"scm_init_srfi_13"):
/usr/share/guile/1.6/srfi/srfi-13.scm:159:1: file: "libguile-srfi-
srfi-13-14-v-1", message: "dlopen, Win32 error 126"

As do do not know how to handle I will switch back to the last
version.

Thanks,
Thomas
LilyPond 2.4.6, Windows XP, Cygwin

> Hi,
>
> I uploaded a new development version.
> It is not stable, but all functions that worked before, should work
> now as well. There are some new functions that doesn't work (like
> internal pdf viewer)



_______________________________________________
lilypond-user mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/lilypond-user
Reply | Threaded
Open this post in threaded view
|

Re: jedit and dvi

Bertalan Fodor
I suggest looking at Plugin Options, because now the default is to use
the native version of LilyPond.

Bert


_______________________________________________
lilypond-user mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/lilypond-user
Reply | Threaded
Open this post in threaded view
|

Re: jedit and dvi

Thomas Scharkowski
Thank you, I had changed this already!

Thomas
> I suggest looking at Plugin Options, because now the default is to use
> the native version of LilyPond.
>
> Bert




_______________________________________________
lilypond-user mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/lilypond-user
Reply | Threaded
Open this post in threaded view
|

Re: jedit and dvi

Bertalan Fodor
That's strange, because it works for me and I don't see why this error
message appears.
Could you try tpying this into the Console: echo $PWD
 It should return your file's path.
If it does, then
lilypond %buffer
should work, if everything is correctly installed.
(make sure that Use cygwin is checked in the options.)
Or you could try lilypond --verbose %buffer, to see if something is not set.

Bert

Thomas Scharkowski ?rta:

>Thank you, I had changed this already!
>
>Thomas
>  
>
>>I suggest looking at Plugin Options, because now the default is to use
>>the native version of LilyPond.
>>
>>Bert
>>    
>>
>
>
>
>
>  
>



_______________________________________________
lilypond-user mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/lilypond-user
Reply | Threaded
Open this post in threaded view
|

Re: jedit and dvi

Thomas Scharkowski
Sorry,I had overlooked this option:
> (make sure that Use cygwin is checked in the options.)

Works now.
I had to change some "\" to "/" manually in jEdit plugin options.

Now I get this message:

GNU LilyPond 2.4.6
lstat(./C:) failed ...
./C:: No such file or directory

Then everything works as expected.

Thomas



_______________________________________________
lilypond-user mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/lilypond-user
Reply | Threaded
Open this post in threaded view
|

Re: jedit and dvi

Art Hixson
In reply to this post by Bertalan Fodor
Hello again Bert,

The fix you sent seems to work but every time I run JDVI it waits to
build a font and I think this message applies:

This is dvips(k) 5.95a Copyright 2005 Radical Eye Software
(www.radicaleye.com)
' TeX output 2005.06.11:1224' -> /dev/null
kpathsea: Running mktexpk --mfmode / --bdpi 600 --mag 1+0/600 --dpi 600
ecbx10
mktexpk: don't know how to create bitmap font for ecbx10.
kpathsea: Appending font creation commands to missfont.log.
dvips: Font ecbx10 not found, characters will be left blank.
<tex.pro><music-drawing-routines.ps><special.pro>. [1] [2]

Bertalan Fodor wrote:

> Hi,
>
> I uploaded a new development version.
> It is not stable, but all functions that worked before, should work
> now as well.
> There are some new functions that doesn't work (like internal pdf viewer)
>
> Download lily4jedit-0.2.8-2 from
> https://sourceforge.net/project/showfiles.php?group_id=91119&package_id=121443&release_id=334169 
>
>
> You must unzip it into jEdit's jars directory.
>
> There is also a new dependency, that you must install manually:
> Download jtextcheck from:
> http://prdownloads.sourceforge.net/jtextcheck/jtextcheck-1.0-b5-bin.tar.gz?download 
>
> It is very big, but you only need to put one jar file into jEdit's
> jars directory:
> jtextcheck-1.0-b5.jar
>
> I hope it will solve your problems. If not, let me know.
>
> Bert
>
>
>
> Art Hixson ?rta:
>
>> Bertalan Fodor wrote:
>>
>>> Finding the fonts sometimes works from the first time, sometimes
>>> doesn't. I'll put on a  newer version of lily4jedit this week.
>>>
>>> Bert
>>>
>> Bert were you able to fix this?
>>
>> I just uninstalled lily4jedit and reinstalled it.  For a short while
>> jdvi worked very well but then something happened and it issued a
>> message that it was building fonts.  At that point the whole
>> application froze and had to be killed.  On restart, the same problem
>> occurs.  This is exactly what happened on my first post.
>>
>> I like jedit very much for this type of coding and the plugin is very
>> nice.  So, I hope you can figure this one out.  Let me know!
>>
>> Cheers,
>> Arthur
>>
>>
>
>
>
>



--
No virus found in this outgoing message.
Checked by AVG Anti-Virus.
Version: 7.0.323 / Virus Database: 267.6.8 - Release Date: 2005/06/11



_______________________________________________
lilypond-user mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/lilypond-user
Reply | Threaded
Open this post in threaded view
|

Re: jedit and dvi

Bertalan Fodor
I don't why ecbx10 misses from your system. Try installing the
tetex-extra package.

Bert


_______________________________________________
lilypond-user mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/lilypond-user
Reply | Threaded
Open this post in threaded view
|

Re: jedit and dvi

Art Hixson
In reply to this post by Bertalan Fodor
Thank you Bert for all your help.  This fix and the info on tetex-extra
has resolved all the problems.

I also want to compliment you and the other developers of both Lilypond
and Jedit for a first rate job of programming.
I just produced an edition of a large late renaissance manuscript in
record time, compared to old Finale.

Bertalan Fodor wrote:

> Hi,
>
> I uploaded a new development version.
> It is not stable, but all functions that worked before, should work
> now as well.
> There are some new functions that doesn't work (like internal pdf viewer)
>
> Download lily4jedit-0.2.8-2 from
> https://sourceforge.net/project/showfiles.php?group_id=91119&package_id=121443&release_id=334169 
>
>
> You must unzip it into jEdit's jars directory.
>
> There is also a new dependency, that you must install manually:
> Download jtextcheck from:
> http://prdownloads.sourceforge.net/jtextcheck/jtextcheck-1.0-b5-bin.tar.gz?download 
>
> It is very big, but you only need to put one jar file into jEdit's
> jars directory:
> jtextcheck-1.0-b5.jar
>
> I hope it will solve your problems. If not, let me know.
>
> Bert
>
>
>
> Art Hixson ?rta:
>
>> Bertalan Fodor wrote:
>>
>>> Finding the fonts sometimes works from the first time, sometimes
>>> doesn't. I'll put on a  newer version of lily4jedit this week.
>>>
>>> Bert
>>>
>> Bert were you able to fix this?
>>
>> I just uninstalled lily4jedit and reinstalled it.  For a short while
>> jdvi worked very well but then something happened and it issued a
>> message that it was building fonts.  At that point the whole
>> application froze and had to be killed.  On restart, the same problem
>> occurs.  This is exactly what happened on my first post.
>>
>> I like jedit very much for this type of coding and the plugin is very
>> nice.  So, I hope you can figure this one out.  Let me know!
>>
>> Cheers,
>> Arthur
>>
>>
>
>
>
>



--
No virus found in this outgoing message.
Checked by AVG Anti-Virus.
Version: 7.0.323 / Virus Database: 267.6.9 - Release Date: 2005/06/11



_______________________________________________
lilypond-user mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/lilypond-user
Reply | Threaded
Open this post in threaded view
|

Re: jedit and dvi

Donald Axel
In reply to this post by Bertalan Fodor
On Sat, 11 Jun 2005 12:30:16 +0200
Bertalan wrote:


> It is not stable, but all functions that worked before, should work now
> as well.
> There are some new functions that doesn't work (like internal pdf viewer)
>
> Download lily4jedit-0.2.8-2 from
> https://sourceforge.net/project/showfiles.php?group_id=91119&package_id=121443&release_id=334169
>
> You must unzip it into jEdit's jars directory.
>
> There is also a new dependency, that you must install manually:
> Download jtextcheck from:
> http://prdownloads.sourceforge.net/jtextcheck/jtextcheck-1.0-b5-bin.tar.gz?download
> It is very big, but you only need to put one jar file into jEdit's jars
> directory:
> jtextcheck-1.0-b5.jar

I get some errors regarding lilyjedit-0.2.8.2, stating that there
are some more dependencies. The first of these reads like this
(I folded the lines):

[error] ErrorListDialog$ErrorEntry:
 /usr/local/share/jedit/4.2/jars/LilyPondTool.jar:
[error] ErrorListDialog$ErrorEntry:
 Requires version 1.3.2 or later of errorlist.ErrorListPlugin,
[error] ErrorListDialog$ErrorEntry:
 but errorlist.ErrorListPlugin is not installed.


Is there a fast way to get the dependency list so I can try jedit
with Lilypond plugin?

I think I should try the "score-builder". Sounds fascinating!


Thank you beforehand - and again thanks for so much quality
typesetting discussions and knowledge on the list!


/Donald


_______________________________________________
lilypond-user mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/lilypond-user
Reply | Threaded
Open this post in threaded view
|

Dependencies for lilypondTool: WAS: jedit and dvi

Donald Axel
On Mon, 13 Jun 2005 02:03:01 +0200
dax2 wrote:

> On Sat, 11 Jun 2005 12:30:16 +0200
> Bertalan wrote:

> > There is also a new dependency, that you must install
> > manually: Download jtextcheck from:

 ... I found the other dependencies on
    http://plugins.jedit.org/plugins/?LilyPondTool


Sorry for previous posting and thanks for a nice plugin!


_______________________________________________
lilypond-user mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/lilypond-user