extender lines in figured bass for Lilypond 2.7.12

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

extender lines in figured bass for Lilypond 2.7.12

seng_liang
Hi, I have some problems regarding extender lines in figured basses for
Lilypond version 2.7.12 for Windows 98. Here is the file content:

\version "2.7.12"
 \relative c { << \context Voice {
\clef bass
c8 c c c d d e e f4 }
\context FiguredBass
\figuremode {
\set useBassFigureExtenders = ##t  
<6 4>2 <6>2 <5 3>4 } >>
}

Here, I would like to put <6 4> on the 1st beat with the extender lines until
the end of the 2nd beat. Then <6> on the 3rd beat with the extender line until
the end of the bar. The <5 3> is for the 2nd bar. 3 problems came up:

First, why did the extender line from "6" of <6 4> at the 1st beat continue
until the start of the 3rd beat where <6> should have been, and now the "6" has
disappeared. Why is this? How can I make the line stop before the 2nd "6" and
then continue after it until the end of the bar?

Second, how do I make two extender lines of the same length lined up vertically
to start from both "6" and "4" after the figure <6 4>?

Finally, why is the order of <5 3> in the pdf file reversed (3 on top of 5), at
least it does on my computer system? Is this a bug?
Thank you.
Yours sincerely,
Seng Liang.





_______________________________________________
lilypond-user mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/lilypond-user
Reply | Threaded
Open this post in threaded view
|

RE: misalignment of lyric extender line

Fairchild
Looks fine in v 2.4.6.

                   - Bruce

-----Original Message-----
From: lilypond-user-bounces+fairchild=[hidden email]
[mailto:lilypond-user-bounces+fairchild=[hidden email]] On Behalf Of
Seng Liang
Sent: Wednesday, November 09, 2005 10:56 AM
To: [hidden email]
Subject: misalignment of lyric extender line


Hi, I am typing a work for soprano by Mozart and I encountered into a
problem
with the lyrics extender lines. I'm using Lilypond 2.7.12 for Windows. Here
is
the file:

\version "2.7.12"
\relative c'
{
 \clef treble
  \key f \major #(set-accidental-style 'modern)
  \time 4/4  \autoBeamOff
g'4 r4 c2\melisma  \break
bes16[ c bes a] bes[ f' e f] e[ f g f] e[ d c bes] a[ bes c d] c4 a16[ bes c
d]
c4 bes16[ c bes a] bes[ f' e f] e[ f g f] e[ d c bes] a[ bes c d] c4 a16[
bes c
d] c4 |  
d2~d16[ bes f' e] g[ f e f] c2~c16[ a f' e] g[ f e f] bes,2~bes16[ e g f] e[
d
c bes]
 a4\melismaEnd r4 c8[( a]) d[( c]) bes4 a \appoggiatura c16 bes4 a8[( g]) f4
r4
r2 }

\addlyrics { me, "  " __ psal -- lant ae -- the -- ra cum me. }


Here, the lyric extender line starts from bar 1 until the beginning of bar 9

and the extender line is meant to be a continous line. However, what
happened
was the line only starts near the middle on bar 4 and is completely missing
on
bar 7. I used a barline break after the 1st bar to show that the extender
line
starts on the 2nd note and not the 1st at the next bar, as it should.  Why
is
this? Is this a bug and can it be fixed? Any help will be appreciated. Thank
you very much. Yours sincerely, Seng Liang



_______________________________________________
lilypond-user mailing list
[hidden email] http://lists.gnu.org/mailman/listinfo/lilypond-user





_______________________________________________
lilypond-user mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/lilypond-user
Reply | Threaded
Open this post in threaded view
|

Re: extender lines in figured bass for Lilypond 2.7.12

Han-Wen Nienhuys
In reply to this post by seng_liang
Seng Liang wrote:

> Hi, I have some problems regarding extender lines in figured basses for
> Lilypond version 2.7.12 for Windows 98. Here is the file content:
>
> \version "2.7.12"
>  \relative c { << \context Voice {
> \clef bass
> c8 c c c d d e e f4 }
> \context FiguredBass
> \figuremode {
> \set useBassFigureExtenders = ##t  
> <6 4>2 <6>2 <5 3>4 } >>
> }
>
> Here, I would like to put <6 4> on the 1st beat with the extender lines until
> the end of the 2nd beat. Then <6> on the 3rd beat with the extender line until
> the end of the bar. The <5 3> is for the 2nd bar. 3 problems came up:
>
> First, why did the extender line from "6" of <6 4> at the 1st beat continue
> until the start of the 3rd beat where <6> should have been, and now the "6" has
> disappeared. Why is this? How can I make the line stop before the 2nd "6" and
> then continue after it until the end of the bar?

Extender lines indicate that the figure is still holding, so said figure
is assumed to continue on the 3rd beat, and the figure is replaced by the 6.

> Second, how do I make two extender lines of the same length lined up vertically
> to start from both "6" and "4" after the figure <6 4>?

try

   { <6 4>4. <6 4>8 <6\!>2 <5 3>4 }

the \! ends the extender.

> Finally, why is the order of <5 3> in the pdf file reversed (3 on top of 5), at
> least it does on my computer system? Is this a bug?

Can't duplicate. I guess it's time that I built 2.7.15 for windows too.

--
  Han-Wen Nienhuys - [hidden email] - http://www.xs4all.nl/~hanwen


_______________________________________________
lilypond-user mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/lilypond-user
Reply | Threaded
Open this post in threaded view
|

Re: misalignment of lyric extender line

Sven Axelsson-3
In reply to this post by Fairchild
Looks fine to me in 2.7.12 Windows.

/Sven Axelsson

On 09/11/05, Fairchild <[hidden email]> wrote:
Looks fine in v 2.4.6.

                   - Bruce

-----Original Message-----
From: lilypond-user-bounces+fairchild=[hidden email]
[mailto:[hidden email]] On Behalf Of
Seng Liang
Sent: Wednesday, November 09, 2005 10:56 AM
To: [hidden email]
Subject: misalignment of lyric extender line


Hi, I am typing a work for soprano by Mozart and I encountered into a
problem
with the lyrics extender lines. I'm using Lilypond 2.7.12 for Windows. Here
is
the file:

\version "2.7.12"
\relative c'
{
\clef treble
  \key f \major #(set-accidental-style 'modern)
  \time 4/4  \autoBeamOff
g'4 r4 c2\melisma  \break
bes16[ c bes a] bes[ f' e f] e[ f g f] e[ d c bes] a[ bes c d] c4 a16[ bes c
d]
c4 bes16[ c bes a] bes[ f' e f] e[ f g f] e[ d c bes] a[ bes c d] c4 a16[
bes c
d] c4 |
d2~d16[ bes f' e] g[ f e f] c2~c16[ a f' e] g[ f e f] bes,2~bes16[ e g f] e[
d
c bes]
a4\melismaEnd r4 c8[( a]) d[( c]) bes4 a \appoggiatura c16 bes4 a8[( g]) f4
r4
r2 }

\addlyrics { me, "  " __ psal -- lant ae -- the -- ra cum me. }


Here, the lyric extender line starts from bar 1 until the beginning of bar 9

and the extender line is meant to be a continous line. However, what
happened
was the line only starts near the middle on bar 4 and is completely missing
on
bar 7. I used a barline break after the 1st bar to show that the extender
line
starts on the 2nd note and not the 1st at the next bar, as it should.  Why
is
this? Is this a bug and can it be fixed? Any help will be appreciated. Thank
you very much. Yours sincerely, Seng Liang

_______________________________________________
lilypond-user mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/lilypond-user