autopackage 2.6.4.3 on Kanotix/Debian

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

autopackage 2.6.4.3 on Kanotix/Debian

Thomas Scharkowski
Hi list,

I have a brand new Kanotix/Debian-sid and installed the autopackage.
Everything worked smoothly without any error messages.
Now, when I start lilypond, I get the following error:

/usr/lib/libstdc++.so.6: version 'GLIBCXX_3.4.6' not found (required
by lilypond)

shouldn't autopackage take care of dependencies?
What is the best way to solve the problem?
Or should I better use the Debian package?

Thank you,
Thomas (new to Linux)


_______________________________________________
lilypond-user mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/lilypond-user
Reply | Threaded
Open this post in threaded view
|

Re: autopackage 2.6.4.3 on Kanotix/Debian

Han-Wen Nienhuys


Thomas Scharkowski wrote:

> Hi list,
>
> I have a brand new Kanotix/Debian-sid and installed the autopackage.
> Everything worked smoothly without any error messages.
> Now, when I start lilypond, I get the following error:
>
> /usr/lib/libstdc++.so.6: version 'GLIBCXX_3.4.6' not found (required
> by lilypond)
>
> shouldn't autopackage take care of dependencies?

Hi can you double check that this the 2.6.4.3 binary?  the latter is
linked statically against libstdc++, so this should be impossible. If in
doubt, do

   lilypond-2.6.4.3.x86.package -x

and examine the lilypond-bin-2.6.4.3 binary that is unpacked with ldd.

> What is the best way to solve the problem?


> Or should I better use the Debian package?

Yes!

--
  Han-Wen Nienhuys - [hidden email] - http://www.xs4all.nl/~hanwen


_______________________________________________
lilypond-user mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/lilypond-user
Reply | Threaded
Open this post in threaded view
|

Re: autopackage 2.6.4.3 on Kanotix/Debian

Thomas Scharkowski
I did what you suggested:
lilypond-2.6.4.3.x86.package -x

and the result is as expected.
I have this version of the binary.

Now I played around a bit and entered:
lilypond-2.6.4.3

And: It works! Isn't this strange?
I have to learn more about Linux to understand this, maybe.
Or, could I install a 2.7.* version now and use both versions this
way?

Thomas

> Thomas Scharkowski wrote:
> > Hi list,
> >
> > I have a brand new Kanotix/Debian-sid and installed the autopackage.
> > Everything worked smoothly without any error messages. Now, when I
> > start lilypond, I get the following error:
> >
> > /usr/lib/libstdc++.so.6: version 'GLIBCXX_3.4.6' not found (required
> > by lilypond)
> >
> > shouldn't autopackage take care of dependencies?
>
> Hi can you double check that this the 2.6.4.3 binary?  the latter is
> linked statically against libstdc++, so this should be impossible. If
> in doubt, do
>
>    lilypond-2.6.4.3.x86.package -x
>
> and examine the lilypond-bin-2.6.4.3 binary that is unpacked with ldd.
>
> > What is the best way to solve the problem?
>
>
> > Or should I better use the Debian package?
>
> Yes!
>
> --
>   Han-Wen Nienhuys - [hidden email] - http://www.xs4all.nl/~hanwen




_______________________________________________
lilypond-user mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/lilypond-user
Reply | Threaded
Open this post in threaded view
|

Re: autopackage 2.6.4.3 on Kanotix/Debian

Han-Wen Nienhuys
Thomas Scharkowski wrote:
> I did what you suggested:
> lilypond-2.6.4.3.x86.package -x
>
> and the result is as expected.
> I have this version of the binary.

I think you have another binary called 'lilypond'  lying around
somewhere, eg. in /usr/bin/ or /usr/local/bin/

--
  Han-Wen Nienhuys - [hidden email] - http://www.xs4all.nl/~hanwen


_______________________________________________
lilypond-user mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/lilypond-user