./autogen.sh gcc/g++ version detection

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

./autogen.sh gcc/g++ version detection

Graham Percival-2
OSX (intel) 10.4.8


ERROR: Please install required programs:  gcc >= 4.0 (installed: ) g++
 >= 4.0 (installed: ) ...


tsubasa:~/tmp gperciva$ gcc --version
i686-apple-darwin8-gcc-4.0.1 (GCC) 4.0.1 (Apple Computer, Inc. build 5363)
Copyright (C) 2005 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

tsubasa:~/tmp gperciva$ g++ --version
i686-apple-darwin8-g++-4.0.1 (GCC) 4.0.1 (Apple Computer, Inc. build 5363)
Copyright (C) 2005 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.


_______________________________________________
lilypond-devel mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/lilypond-devel
Reply | Threaded
Open this post in threaded view
|

Re: ./autogen.sh gcc/g++ version detection

Jan Nieuwenhuizen-2
Graham Percival <[hidden email]> writes:

> ERROR: Please install required programs:  gcc >= 4.0 (installed: ) g++
>>= 4.0 (installed: ) ...

Fixed in master.  In this hairy version determination we did something
really stupid.

Jan.

--
Jan Nieuwenhuizen <[hidden email]> | GNU LilyPond - The music typesetter
http://www.xs4all.nl/~jantien       | http://www.lilypond.org


_______________________________________________
lilypond-devel mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/lilypond-devel