Wrong \version statements in LSR snippets

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Wrong \version statements in LSR snippets

Werner LEMBERG

Using the brand-new `MySQL::Dump::Parser::XS' module from CPAN (with
some additions by me :-) I can now access the LSR sqldump directly
(file `lsr-XXXX-XX-XX.mysqldump.gz' in directory
http://lsr.di.unimi.it/download, updated daily) without using any
MySQL tools, converting it to a readable text dump with about 30 lines
of Perl code – I will extend this soon to generate the snippet files
directly so that we have full control over the HTML to texinfo
conversion in the documentation parts.  This will eventually improve
the formatting of snippets in the LilyPond manuals, since the current
conversion of HTML tags to corresponding texinfo features is very
limited.  For example, the `<pre>' HTML tag used in some snippets
isn't handled at all.

While doing some first checks on the dump I found that two snippets
contain `\version' statements newer than 2.18.2 (actually, snippets in
the LSR shouldn't contain a `\version' statement at all).  Here's the
complete list.

  888: 2.18.0
  951: 2.18.0
  970: 2.21.0 !
  975: 2.18.0
 1054: 2.18.2
 1063: 2.18.2
 1064: 2.18.2
 1065: 2.19.80 !

Maybe this should be fixed in LSR?  In particular, it should be
checked whether the two snippets asking for newer versions do
correctly compile with the lilypond version used for the LSR (i.e.,
2.18.2).


    Werner
_______________________________________________
lilypond-devel mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/lilypond-devel
Reply | Threaded
Open this post in threaded view
|

Re: Wrong \version statements in LSR snippets

Thomas Morley-2
Am Do., 3. Okt. 2019 um 08:22 Uhr schrieb Werner LEMBERG <[hidden email]>:

> While doing some first checks on the dump I found that two snippets
> contain `\version' statements newer than 2.18.2 (actually, snippets in
> the LSR shouldn't contain a `\version' statement at all).  Here's the
> complete list.
>
>   888: 2.18.0
>   951: 2.18.0
>   970: 2.21.0 !
>   975: 2.18.0
>  1054: 2.18.2
>  1063: 2.18.2
>  1064: 2.18.2
>  1065: 2.19.80 !
>
> Maybe this should be fixed in LSR?  In particular, it should be
> checked whether the two snippets asking for newer versions do
> correctly compile with the lilypond version used for the LSR (i.e.,
> 2.18.2).

All fixed now.

Some remarks:

http://lsr.di.unimi.it/LSR/Item?id=970
used some 2.19-syntax and omitted default-arguments in functions (not
possible with 2.18.2). I've no clue why LSR accepted it, on my machine
it errors and doesn't return an image with 2.18.2. Now downgraded.

Two snippets were not even approved
http://lsr.di.unimi.it/LSR/Item?id=1063
http://lsr.di.unimi.it/LSR/Item?id=1064
Done now.

None of said snippets was tagged 'doc', thus they don't appear in our docs.

Thanks,
  Harm

_______________________________________________
lilypond-devel mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/lilypond-devel