Web site manual search defaulting to 2.17

classic Classic list List threaded Threaded
9 messages Options
Reply | Threaded
Open this post in threaded view
|

Web site manual search defaulting to 2.17

Nick Payne-3
Using the search box at top right on the LP web site is searching the
2.17 rather than the 2.18 manuals. e.g. The search submitted to google is:

https://www.google.com/search?btnG=Google+Search&brute_query=bar+engraver&q=site%3Alilypond.org%2Fdoc%2Fv2.17+bar+engraver

Shouldn't the default search be the current stable version?

Nick

_______________________________________________
bug-lilypond mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/bug-lilypond
Reply | Threaded
Open this post in threaded view
|

Re: Web site manual search defaulting to 2.17

fedelogy
2014/1/23 Nick Payne <[hidden email]>

> Using the search box at top right on the LP web site is searching the 2.17
> rather than the 2.18 manuals. e.g. The search submitted to google is:
>
> https://www.google.com/search?btnG=Google+Search&brute_
> query=bar+engraver&q=site%3Alilypond.org%2Fdoc%2Fv2.17+bar+engraver
>
> Shouldn't the default search be the current stable version?
>

There's an issue already:
https://code.google.com/p/lilypond/issues/detail?id=2909

I think that it's just a matter of waiting for google to reindex the pages.
You can try and see that a search on v2.17 gives more results than v2.18
But I agree that the version should be the stable. I can't remember why the
dev version is set
_______________________________________________
bug-lilypond mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/bug-lilypond
Reply | Threaded
Open this post in threaded view
|

Re: Web site manual search defaulting to 2.17

Phil Holmes
"Federico Bruni" <[hidden email]> wrote in message
news:CAPjDBprh2G_JO79U18zF=VZwhDHsN2VsqfNUDJNAw8=[hidden email]...

> 2014/1/23 Nick Payne <[hidden email]>
>
>> Using the search box at top right on the LP web site is searching the
>> 2.17
>> rather than the 2.18 manuals. e.g. The search submitted to google is:
>>
>> https://www.google.com/search?btnG=Google+Search&brute_
>> query=bar+engraver&q=site%3Alilypond.org%2Fdoc%2Fv2.17+bar+engraver
>>
>> Shouldn't the default search be the current stable version?
>>
>
> There's an issue already:
> https://code.google.com/p/lilypond/issues/detail?id=2909
>
> I think that it's just a matter of waiting for google to reindex the
> pages.
> You can try and see that a search on v2.17 gives more results than v2.18
> But I agree that the version should be the stable. I can't remember why
> the
> dev version is set

As it stands, the search box will only search one set of documents.  I
believe we use the development set, since that will progressively improve as
people fix documentation bugs.

An alternative might be to think of some JavaScript that picks up the
version number from the URL of the documentation page and uses this as the
search site?

A check with Google shows it seems to have indexed both 2.18 and 2.19 so the
search box could be updated now.

--
Phil Holmes



_______________________________________________
bug-lilypond mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/bug-lilypond
Reply | Threaded
Open this post in threaded view
|

Re: Web site manual search defaulting to 2.17

Nick Payne-3
In reply to this post by fedelogy
On 23/01/2014 4:24 PM, Federico Bruni wrote:

> 2014/1/23 Nick Payne <[hidden email]
> <mailto:[hidden email]>>
>
>     Using the search box at top right on the LP web site is searching
>     the 2.17 rather than the 2.18 manuals. e.g. The search submitted
>     to google is:
>
>     https://www.google.com/search?btnG=Google+Search&brute_query=bar+engraver&q=site%3Alilypond.org%2Fdoc%2Fv2.17+bar+engraver
>
>     Shouldn't the default search be the current stable version?
>
>
> There's an issue already:
> https://code.google.com/p/lilypond/issues/detail?id=2909
>
> I think that it's just a matter of waiting for google to reindex the
> pages.

No, it's not a matter of waiting for Google to reindex pages. The
parameters being passed to Google search by the LP web site include
site:lilypond.org/doc/2.17, which limits the search to the manuals for 2.17.

Nick
_______________________________________________
bug-lilypond mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/bug-lilypond
Reply | Threaded
Open this post in threaded view
|

Re: Web site manual search defaulting to 2.17

fedelogy
Il 24/gen/2014 22:04 "Nick Payne" <[hidden email]> ha scritto:
>
> On 23/01/2014 4:24 PM, Federico Bruni wrote:
>>
>> 2014/1/23 Nick Payne <[hidden email]>
>>>
>>> Using the search box at top right on the LP web site is searching the
2.17 rather than the 2.18 manuals. e.g. The search submitted to google is:
>>>
>>>
https://www.google.com/search?btnG=Google+Search&brute_query=bar+engraver&q=site%3Alilypond.org%2Fdoc%2Fv2.17+bar+engraver
>>>
>>> Shouldn't the default search be the current stable version?
>>
>>
>> There's an issue already:
>> https://code.google.com/p/lilypond/issues/detail?id=2909
>>
>> I think that it's just a matter of waiting for google to reindex the
pages.
>
>
> No, it's not a matter of waiting for Google to reindex pages. The
parameters being passed to Google search by the LP web site include site:
lilypond.org/doc/2.17, which limits the search to the manuals for 2.17.
>

You cut a relevant part of my e-mail
_______________________________________________
bug-lilypond mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/bug-lilypond
Reply | Threaded
Open this post in threaded view
|

Re: Web site manual search defaulting to 2.17

Phil Holmes
In reply to this post by Nick Payne-3
"Nick Payne" <[hidden email]> wrote in message
news:[hidden email]...

> On 23/01/2014 4:24 PM, Federico Bruni wrote:
>> 2014/1/23 Nick Payne <[hidden email]
>> <mailto:[hidden email]>>
>>
>>     Using the search box at top right on the LP web site is searching
>>     the 2.17 rather than the 2.18 manuals. e.g. The search submitted
>>     to google is:
>>
>>
>> https://www.google.com/search?btnG=Google+Search&brute_query=bar+engraver&q=site%3Alilypond.org%2Fdoc%2Fv2.17+bar+engraver
>>
>>     Shouldn't the default search be the current stable version?
>>
>>
>> There's an issue already:
>> https://code.google.com/p/lilypond/issues/detail?id=2909
>>
>> I think that it's just a matter of waiting for google to reindex the
>> pages.
>
> No, it's not a matter of waiting for Google to reindex pages. The
> parameters being passed to Google search by the LP web site include
> site:lilypond.org/doc/2.17, which limits the search to the manuals for
> 2.17.
>
> Nick

There's not much point restricting the search to 2.18 documents unless
Google has indexed them.

--
Phil Holmes



_______________________________________________
bug-lilypond mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/bug-lilypond
Reply | Threaded
Open this post in threaded view
|

Re: Web site manual search defaulting to 2.17

Paul Morris
Phil Holmes-2 wrote
There's not much point restricting the search to 2.18 documents unless Google has indexed them.
Google's pretty quick with indexing so I thought I'd check their progress.  Searched for:
site:lilypond.org/doc/v2.18

54 pages of results (10 per page, and seems to include some translated pages).  
"about 5,120 results"
"...we have omitted some entries very similar to the 531 already displayed."


Compare that with a search for:
site:lilypond.org/doc/v2.17

66 pages of results (10 per page)
"about 7,770 results"
"...we have omitted some entries very similar to the 660 already displayed."

So that's roughly 80% at this point (531 / 660).  
(That's assuming that the number of web pages in /v2.18/ and /v2.17/ are similar.)

--
Paul Morris
Reply | Threaded
Open this post in threaded view
|

Re: Web site manual search defaulting to 2.17

Phil Holmes
"Paul Morris" <[hidden email]> wrote in message
news:[hidden email]...

> Phil Holmes-2 wrote
>> There's not much point restricting the search to 2.18 documents unless
>> Google has indexed them.
>
> Google's pretty quick with indexing so I thought I'd check their progress.
> Searched for:
> site:lilypond.org/doc/v2.18
>
> 54 pages of results (10 per page, and seems to include some translated
> pages).
> "about 5,120 results"
> "...we have omitted some entries very similar to the 531 already
> displayed."
>
>
> Compare that with a search for:
> site:lilypond.org/doc/v2.17
>
> 66 pages of results (10 per page)
> "about 7,770 results"
> "...we have omitted some entries very similar to the 660 already
> displayed."
>
> So that's roughly 80% at this point (531 / 660).
> (That's assuming that the number of web pages in /v2.18/ and /v2.17/ are
> similar.)


Yes, I agree that this could be done now.

--
Phil Holmes



_______________________________________________
bug-lilypond mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/bug-lilypond
Reply | Threaded
Open this post in threaded view
|

Re: Web site manual search defaulting to 2.17

fedelogy
In reply to this post by Phil Holmes
2014/1/23 Phil Holmes <[hidden email]>

> "Federico Bruni" <[hidden email]> wrote in message
> news:CAPjDBprh2G_JO79U18zF=VZwhDHsN2VsqfNUDJNAw8=[hidden email]...
>
>  2014/1/23 Nick Payne <[hidden email]>
>>
>>  Using the search box at top right on the LP web site is searching the
>>> 2.17
>>> rather than the 2.18 manuals. e.g. The search submitted to google is:
>>>
>>> https://www.google.com/search?btnG=Google+Search&brute_
>>> query=bar+engraver&q=site%3Alilypond.org%2Fdoc%2Fv2.17+bar+engraver
>>>
>>> Shouldn't the default search be the current stable version?
>>>
>>>
>> There's an issue already:
>> https://code.google.com/p/lilypond/issues/detail?id=2909
>>
>> I think that it's just a matter of waiting for google to reindex the
>> pages.
>> You can try and see that a search on v2.17 gives more results than v2.18
>> But I agree that the version should be the stable. I can't remember why
>> the
>> dev version is set
>>
>
> As it stands, the search box will only search one set of documents.  I
> believe we use the development set, since that will progressively improve
> as people fix documentation bugs.
>
> An alternative might be to think of some JavaScript that picks up the
> version number from the URL of the documentation page and uses this as the
> search site?
>
>
Just to clarify: the problem is just in the "general search", the one you
see in the home page and all the pages of the website, where there's no
version number in the URL.
The search in each stable version of the documentation can be easily fixed,
because each version is "frozen" in a separate branch. Now we can update
search-box.ihtml in 2.18 branch without affecting the current version.

It's a trade-off:
If we keep 2.18 in the current version, the search in 2.19 manuals will
look up 2.18 pages.
If we put 2.19, a user might search the development version instead of the
stable.  I think that the user should learn and use the search bar within a
manual.


> A check with Google shows it seems to have indexed both 2.18 and 2.19 so
> the search box could be updated now.


yes, I've added a comment here:
https://code.google.com/p/lilypond/issues/detail?id=2909#c5
_______________________________________________
bug-lilypond mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/bug-lilypond