Special characters problem

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Special characters problem

Jamie Bullock
Hi,

I have just started using lilypond 2.5.29 in order to take advantage of
some of the newer features. Having used convert-ly to import a recent
score from 2.4.5 (I don't think it did very much), most things seem to
work OK.

However any 'special characters' called in the 2.4.5 score don't seem to
get rendered with 2.5.29. For example, in my header I have:

        copyright = "Copyright \copyright 2005, Jamie Bullock"

With 2.4.5, this gave me a nice copyright symbol before 2005. In 2.5.29
I just get \copyright.

Likewise, in the score I specify a piu mosso as:

        ^\markup{\column <\bold "Pi\\`u mosso" \italic "pizz.">}

In 2.4.6 I got the correct accent, whereas in 2.5.29 I get "Pi\`u
mosso".

Is there a new way of specifying these characters, or have I failed to
install a required font?

Any help appreciated.


--
Regards,

Jamie



_______________________________________________
lilypond-user mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/lilypond-user
Reply | Threaded
Open this post in threaded view
|

Re: Special characters problem

Graham Percival

On 14-Jun-05, at 9:51 AM, Jamie Bullock wrote:

> However any 'special characters' called in the 2.4.5 score don't seem
> to
> get rendered with 2.5.29. For example, in my header I have:

Lilypond no longer uses latex, so the latex special chars don't work.  
Instead,
insert them directly (cut and paste from a character map if necessary).

Your text file must be saved as utf-8 for this to work.

Cheers,
- Graham



_______________________________________________
lilypond-user mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/lilypond-user