Running Lilypond through jEdit in Windows

classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|

Running Lilypond through jEdit in Windows

Eduardo Vieira
Hello friends,
 
I have installed jEdit with Lilypond Tools in Windows ME. Besides that, I have installed the native version for Windows (not Cygwin) of Lilypond 2.6.3. How can I run Lilypond from its menu in jEdit? Is it possible I tried configuring the plugin giving the right path for lilypond.exe, but didn't work. It gave me this message:
This is a console shell for running LilyPond and related commands.
 
"You can use %buffer to substitute the current buffer's path.
 
LilyPond ready.
 
lilypond /cygdrive/C/musark/ode.ly
 
C:\Arquivos de programas\LilyPond\usr\bin\lilypond.exe: unrecognized option: `--login'
 
LilyPond ready."
 
 
Cheers,
 
Eduardo

_______________________________________________
lilypond-user mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/lilypond-user
Reply | Threaded
Open this post in threaded view
|

Re: Running Lilypond through jEdit in Windows

Bertalan Fodor
Yes, you're really right. I still not have uploaded the new, 2.6.x
compatible LilyPondTool to the jEdit plugin central.
I promise that on Thursday I will do that.

Until that you can download manually:

http://prdownloads.sourceforge.net/lily4jedit/lily4jedit-0.2.8-6.zip?download
Unzip its contents into c:\jedit\jars (assuming you have installed jedit
to c:\jedit)

Do the same with
http://prdownloads.sourceforge.net/lily4jedit/lilyjhelp-2.6.0-1.zip?download

I hope that will be enough.

Bert


_______________________________________________
lilypond-user mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/lilypond-user
Reply | Threaded
Open this post in threaded view
|

RE: Running Lilypond through jEdit in Windows

Stephan Moss-2
In reply to this post by Eduardo Vieira
Checking the Apple site, it looks like Java 5 is availabel for OS X now:
Java 2 SE 5.0 Release 1
http://www.apple.com/support/downloads/java2se50release1.html

This is probably a dumb question, but what does  Volume 35, Issue 56 refer to?  Until the jEdit plugin central gets updated, I'd still like trying to use the new version of the tool.

Thanks

Steve

-----Original Message-----
From: lilypond-user-bounces+steve.moss=[hidden email] [mailto:lilypond-user-bounces+steve.moss=[hidden email]] On Behalf Of Fodor Bertalan
Sent: Friday, October 28, 2005 1:11 AM
To: anders stenberg
Cc: [hidden email]
Subject: RE:Running Lilypond through jEdit in Windows

You need Java 5.0 (aka 1.5) for this version (and now on). I know this is sad for Mac users, but I would not have had enough motivation to work on LilyPondTool if I must stay with 1.4

Bert

anders stenberg <[hidden email]> írta:

> Hi!
>
> I did folow the procedure outlined by Bertalan Fodor in vol 35 issue
56.
>
> When loading the lilytool 0.2.8-6 all I get is an Error message:
>
> Cannot start: java.lang. Unsuported ClassVersionError,
> Lilytool/lilytool.jar:
> (Unsuported major.minor version 49.0 ) try uploading to a newer
version
> of the plugin.
>
>
> Is there anything wrong with my setup? or is this a bug?
allternatively
> did I stupidly do something wrong?
>
> Yours Anders Stenberg
>
>

_________________________________________________________________________________
Realisztikus csengőhangok, polifónikus csengőhangok, háttérképek.
Iratkozz fel hírlevelünkre, és tölts le akár FÉL áron is!  http://www.sztarsms.hu



_______________________________________________
lilypond-user mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/lilypond-user

-------------------------------------------------------------
This message has been scanned by Postini anti-virus software.



_______________________________________________
lilypond-user mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/lilypond-user
Reply | Threaded
Open this post in threaded view
|

Re: Running Lilypond through jEdit in Windows

uunail
In reply to this post by Bertalan Fodor
According to your message you wanted to upload the 2.6 compatible version onto the jEdit plugin central.

Until now (two weeks later) this is obviously not yet done.

I tried to use the downloads you refer to, but after installation of the files I get java error messages while running.

Is there any way you can help me? I'm using the native windows versions of both Lilypond and jEdit.

Best regards

Uwe
Reply | Threaded
Open this post in threaded view
|

Re: Running Lilypond through jEdit in Windows

Bertalan Fodor
uunail (sent by Nabble.com) wrote:

> According to your message you wanted to upload the 2.6 compatible
> version onto the jEdit plugin central.
>
> Until now (two weeks later) this is obviously not yet done.

I've done what I could (I put it into Plugin Central Submission tracker
of jEdit). It takes time (days or weeks) to get into the official plugin
bunch.

>
> I tried to use the downloads you refer to, but after installation of
> the files I get java error messages while running.

Note you must have Java 5.0 (aka 1.5). You should also try the latest
version (0.2.9) on http://www.sf.net/projects/lily4jedit Just download
and unzip into - assuming jEdit is installed at c:\jedit - c:\jedit\jars:

http://prdownloads.sourceforge.net/lily4jedit/lily4jedit-0.2.9.zip?download
http://prdownloads.sourceforge.net/lily4jedit/lilyjhelp-2.6.0-1.zip?download

I hope I have not forgot anything from the zip. If you get error
messages (when starting jEdit), please let me know.

Also note that if you'd like to keep with 0.2.8, it must have been
unzipped into c:\jedit (because it already contains the jars folder).
However, the new 0.2.9 must be unzipped into c:\jedit\jars.

Bert


_______________________________________________
lilypond-user mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/lilypond-user
Reply | Threaded
Open this post in threaded view
|

Re: Running Lilypond through jEdit in Windows

uunail
Thank you for the information. I installed Java 5.0 according to your suggestion.

However I did not yet have success. On starting jEdit I get the following error message:

Cannot start java.lang.UnsupportedClassVersionError: lilytool/LilyToolPlugin (Unsupported major.minor version 49.0). Try updating to a newer veriso0n of the plugin.

Can you help me?

Best regards

Uwe
Reply | Threaded
Open this post in threaded view
|

Re: Running Lilypond through jEdit in Windows

Bertalan Fodor
I'm afraid that jEdit has not been starting the 5.0 Java. (Have you
uninstalled the 1.4)

Bert

uunail (sent by Nabble.com) wrote:

> Thank you for the information. I installed Java 5.0 according to your
> suggestion.
>
> However I did not yet have success. On starting jEdit I get the
> following error message:
>
> Cannot start java.lang.UnsupportedClassVersionError:
> lilytool/LilyToolPlugin (Unsupported major.minor version 49.0). Try
> updating to a newer veriso0n of the plugin.
>
> Can you help me?
>
> Best regards
>
> Uwe
> ------------------------------------------------------------------------
> Sent from the Gnu - Lilypond - User
> <http://www.nabble.com/Running-Lilypond-through-jEdit-in-Windows-t450088.html#a1443492>
> forum at Nabble.com.
>
>------------------------------------------------------------------------
>
>_______________________________________________
>lilypond-user mailing list
>[hidden email]
>http://lists.gnu.org/mailman/listinfo/lilypond-user
>  
>



_______________________________________________
lilypond-user mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/lilypond-user
Reply | Threaded
Open this post in threaded view
|

Re: Running Lilypond through jEdit in Windows

uunail
Thank you once again.

Indeed jEdit didn't start the correct java version.

After uninstallation of both java versions and jEdit I then installed java 5.0 and afterwards jEdit.

Now everything works fine.

Uwe