Re: Horizontal spacing markup bug?

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Horizontal spacing markup bug?

Erik Sandberg
On Tuesday 31 May 2005 02.52, Daniel Johnson wrote:
> I've noticed that when I have a long markup associated with a note, and
> a short markup associated with a space occupying the same beat as the
> note, the short markup is aligned along the center X-axis of the longer
> markup.  I first noticed this with the piano centered-dynamics template,
> but I've narrowed it down to the following code.  Is this a known
> issue?  Surely I can't be the first to notice this.

It's a previously unknown issue, thanks for the report! It should be
considered release-critical IMHO.

%critical important
%Daniel Johnson

\version "2.5.26"
\paper { raggedright = ##t }
\header {
texidoc = "The two p's should be horizontally aligned with each other."
reportedin = "2.5.26"
}
\score {
    <<
        \context Staff = voiceOne { c''4^\markup{\dynamic "p" \italic "mezzo
voce"
} c'' c'' c'' }
        \context Staff = voiceTwo { s4^\p c''4 c'' c'' }
    >>
}
%%% end lilycode %%%

--
Erik Sandberg
Maintainer of the Lilypond bug CVS archive,
http://savannah.gnu.org/cgi-bin/viewcvs/lilypond/lily-bugs/bugs/
http://lilypond.org/doc/v2.5/bugs/out/index.html


_______________________________________________
bug-lilypond mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/bug-lilypond
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Horizontal spacing markup bug?

Han-Wen Nienhuys
Erik Sandberg wrote:

> On Tuesday 31 May 2005 02.52, Daniel Johnson wrote:
>
>>I've noticed that when I have a long markup associated with a note, and
>>a short markup associated with a space occupying the same beat as the
>>note, the short markup is aligned along the center X-axis of the longer
>>markup.  I first noticed this with the piano centered-dynamics template,
>>but I've narrowed it down to the following code.  Is this a known
>>issue?  Surely I can't be the first to notice this.
>
>
> It's a previously unknown issue, thanks for the report! It should be
> considered release-critical IMHO.

fixed in cvs.


--
  Han-Wen Nienhuys - [hidden email] - http://www.xs4all.nl/~hanwen


_______________________________________________
bug-lilypond mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/bug-lilypond
Loading...