Re: 64-bit version of Lilypond?

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Re: 64-bit version of Lilypond?

Hans Åberg-2

> On 30 Jun 2019, at 22:49, Yentl Tijssens <[hidden email]> wrote:
>
> Hey,
>
> I’m a bit of a nooby tech enthusiast and upgraded to the Catalina Beta. Of course Lilypond doesn’t work on that version because it is a 32-bit application.
> I saw your post and was wondering if you could provide me your way to use a functional lilypond 64-bit version with Frescobaldi.

I added the devel list, as there is an issue to consider when using MacPorts for LilyPond, namely that it tends to be slow updating with the new MacOS’s, typically some month after the official public release.



_______________________________________________
lilypond-devel mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/lilypond-devel
Reply | Threaded
Open this post in threaded view
|

Re: 64-bit version of Lilypond?

Hans Åberg-2
[Please keep the cc to the list, so that others can follow the issue.]

For MacOS 10.14 or earlier, install MacPorts, and issue in Terminal the command
  port install lilypond-devel

There is probably no MacPorts for 10.15, though.


> On 17 Jul 2019, at 16:53, Yentl Tijssens <[hidden email]> wrote:
>
> Yes I read about the slow updating, but I guess that’s better than having nothing. Is there a place that I could download that build?
>
>> On 1 Jul 2019, at 00:11, Hans Åberg <[hidden email]> wrote:
>>
>>
>>> On 30 Jun 2019, at 22:49, Yentl Tijssens <[hidden email]> wrote:
>>>
>>> Hey,
>>>
>>> I’m a bit of a nooby tech enthusiast and upgraded to the Catalina Beta. Of course Lilypond doesn’t work on that version because it is a 32-bit application.
>>> I saw your post and was wondering if you could provide me your way to use a functional lilypond 64-bit version with Frescobaldi.
>>
>> I added the devel list, as there is an issue to consider when using MacPorts for LilyPond, namely that it tends to be slow updating with the new MacOS’s, typically some month after the official public release.
>>
>>
>


_______________________________________________
lilypond-devel mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/lilypond-devel
Reply | Threaded
Open this post in threaded view
|

Re: 64-bit version of Lilypond?

Yentl Tijssens
Thank you. I hope there will be one for 10.15 soon. Or by the time Catalina comes out, a Lilypond build that doesn’t require MacPorts. I know a lot of people who will update without knowing Lilypond will not work anymore.

On 17 Jul 2019, at 17:46, Hans Åberg <[hidden email]> wrote:

>
> [Please keep the cc to the list, so that others can follow the issue.]
>
> For MacOS 10.14 or earlier, install MacPorts, and issue in Terminal the command
>  port install lilypond-devel
>
> There is probably no MacPorts for 10.15, though.
>
>
>> On 17 Jul 2019, at 16:53, Yentl Tijssens <[hidden email]> wrote:
>>
>> Yes I read about the slow updating, but I guess that’s better than having nothing. Is there a place that I could download that build?
>>
>>>> On 1 Jul 2019, at 00:11, Hans Åberg <[hidden email]> wrote:
>>>
>>>
>>>> On 30 Jun 2019, at 22:49, Yentl Tijssens <[hidden email]> wrote:
>>>>
>>>> Hey,
>>>>
>>>> I’m a bit of a nooby tech enthusiast and upgraded to the Catalina Beta. Of course Lilypond doesn’t work on that version because it is a 32-bit application.
>>>> I saw your post and was wondering if you could provide me your way to use a functional lilypond 64-bit version with Frescobaldi.
>>>
>>> I added the devel list, as there is an issue to consider when using MacPorts for LilyPond, namely that it tends to be slow updating with the new MacOS’s, typically some month after the official public release.
>>>
>>>
>>
>


_______________________________________________
lilypond-devel mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/lilypond-devel