Problems with ps and pdf output

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Problems with ps and pdf output

Nathan Curry
I got some problems worked out with my client's Lilypond installation, but I
have a script that he runs that converts everything to pdf and ps, but there
are errors:

1. .ps and .pdf are picking up the feta font (i.e. the music) but not the
markup.
2. .dvi is picking up the markup but only partially the feta font.

I execute the commands from the intended output directory. The commands I
run are, for lilypond files:

/usr/bin/lilypond -V --include=/path/to/input/directory input_file

for lilypond-book files:

/usr/bin/lilypond-book -V --include=/path/to/input/directory input_file
/usr/bin/latex input_file
/usr/bin/dvips -Ppdf -u+lilypond -u+ec-mftrace input_file
/usr/bin/ps2pdf file.ps <http://file.ps>

I don't know what is going wrong. It seems like there might be an error in
the conversion process, since the output is inconsistent across formats, but
then again, direct lilypond output produces the same anomalies.
-Nathan
_______________________________________________
bug-lilypond mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/bug-lilypond
Reply | Threaded
Open this post in threaded view
|

Re: Problems with ps and pdf output

Nathan Curry
More on the issue. In the example:

 \relative {
        c4 ^"Test"
        ^\markup "Test"
        ^\markup \override #'(font-magnification . 0.9) \override
#'(font-name . "ptmr") "Hello"
        }


The one with the override is the one that works. It seems to be a problem
with fonts? Could it be that there is no default font set? Also, I looked at
the problem detailed here:
http://lists.gnu.org/archive/html/lilypond-user/2001-10/msg00107.html

Could this be related? I'm not clear on the internal process of lilypond,
and whether it is calling other programs to convert the files to pdf or ps.
-Nathan
_______________________________________________
bug-lilypond mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/bug-lilypond
Reply | Threaded
Open this post in threaded view
|

Re: Problems with ps and pdf output

Graham Percival

On 11-Jun-05, at 11:10 AM, Nathan Curry wrote:

>  \relative {
> c4 ^"Test"
>         ^\markup "Test"
> ^\markup \override #'(font-magnification . 0.9) \override
> #'(font-name . "ptmr") "Hello"
> }
>
>
> The one with the override is the one that works. It seems to be a
> problem
> with fonts? Could it be that there is no default font set? Also, I
> looked at
> the problem detailed here:

What OS and version are you using?  It works fine with self-compiled
2.5.30 on OSX.

- Graham



_______________________________________________
bug-lilypond mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/bug-lilypond
Reply | Threaded
Open this post in threaded view
|

Re: Problems with ps and pdf output

Graham Percival
Please keep lilypond traffic on the mailist; this means that other  
people can help
answer, or receive help from other people's answers.

I'd try 2.5.31; we're almost at the 2.6.0 release.  My build process  
wouldn't really
help you, since I'm on OSX and I have to apply some extra patches.  But  
on
linux, I'd be surprised if you have to do anything other than
./autogen.sh
make all
make install

- Graham

On 12-Jun-05, at 9:30 AM, Nathan Curry wrote:

> Using Arch Linux, with v. 2.4.6 installed.  How do you build it, eg,  
> what commands?  The build procedure I'm using is as follows:

>    cd $startdir/src/$pkgname-$pkgver
>    ./configure --prefix=/usr
>    sed -i "s:SUBDIRS=user bibliography pictures topdocs   
> misc:SUBDIRS=bibliography pictures topdocs  misc:"  
> Documentation/GNUmakefile #Stop from making info pages
>    make || return 1
>  #  make lilypond_datadir=$startdir/pkg/usr/share/lilypond  
> local_lilypond_datadir=$startdir/pkg/usr/share/lilypond/$pkgver  
> install
>    make DESTDIR=$startdir/pkg install
>    install -D -m755 buildscripts/out/lilypond-profile  
> $startdir/pkg/usr/share/lilypond/$pkgver/buildscripts/out/lilypond-
> profile
>    install -D -m755 buildscripts/out/lilypond-login  
> $startdir/pkg/usr/share/lilypond/$pkgver/buildscripts/out/lilypond-
> login
>    install -D -m755 buildscripts/out/clean-fonts  
> $startdir/pkg/usr/share/lilypond/$pkgver/buildscripts/out/clean-fonts
>    install -D -m755 buildscripts/out/lilypond-words  
> $startdir/pkg/usr/share/lilypond/$pkgver/buildscripts/out/lilypond-
> words
>    cd $startdir/pkg/usr/share/lilypond/$pkgver/buildscripts/out
>    patch -p0 < $startdir/src/clean-fonts.diff # We don't need clean  
> fonts referencing .
>    mkdir -p $startdir/pkg/etc/profile.d
>    ln -sf  
> /usr/share/lilypond/$pkgver/buildscripts/out/lilypond-profile  
> $startdir/pkg/etc/profile.d/lilypond.sh
>
>  Thanks,
>  Nathan
>
> On 6/11/05, Graham Percival <[hidden email]> wrote:
>> On 11-Jun-05, at 11:10 AM, Nathan Curry wrote:
>>
>> >  \relative {
>> >       c4 ^"Test"
>> >         ^\markup "Test"
>> >       ^\markup \override #'(font-magnification . 0.9) \override
>> > #'(font-name . "ptmr") "Hello"
>> >       }
>> >
>> >
>> > The one with the override is the one that works. It seems to be a
>> > problem
>> > with fonts? Could it be that there is no default font set? Also, I
>> > looked at
>> > the problem detailed here:
>>
>> What OS and version are you using?  It works fine with self-compiled
>> 2.5.30 on OSX.
>>
>> - Graham
>>



_______________________________________________
bug-lilypond mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/bug-lilypond