Problems with autopackaged 2.5.28

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

Problems with autopackaged 2.5.28

Erik Sandberg
Hi,

I have tried the autopackage on a few systems.

Some problems under ubuntu:
1. gs isn't well-configured. If I use gs-8.15 as my default gs interpreter, gv
and friends don't work; spitting out something like "unknown interface x11". I
guess this might be a bug in the gs package, not in lily.

2. If a binary called 'lilypond' already exists in the target directory, all
created binaries will be suffixed '-2.5.28'. However, lilypond-book-bin-2.5.28
will run 'lilypond', not 'lilypond-2.5.28'. (Pedro found a way around this
problem with his -snapshot deb packages)

A problem under Mandrake 10:
I created a fresh user, and ran the installer as this user. Installation goes
fine, and libpng and ghostscript are installed in addition. When running
lilypond, I get the following:
[erik@localhost report]$ lilypond --verbose
GNU LilyPond 2.5.28

LILYPOND_DATADIR="/usr/share/lilypond/2.5.28"
LILYPONDPREFIX="/home/erik/.local/share/lilypond/2.5.28"
LOCALEDIR="/usr/share/locale"

Effective prefix: "/home/erik/.local/share/lilypond/2.5.28"
GS_FONTPATH="/home/erik/.local/share/ghostscript/8.15/fonts"
GS_LIB="/home/krille/.fonts"
PATH="/home/erik/.local/bin:/usr//bin:/bin:/usr/bin::/usr/local/bin:/usr/X11R6/bin:/usr/games:/home/krille/bin:./:/home/krille/bin:./:/home/krille/bin:./:/home/erik/.local/bin"
Segmentation fault (core dumped)

The coredump is ~2 meg, and I uploaded it here:
www.math.uu.se/~sandberg/core.22324

I don't regularly have access to this computer.

Erik



_______________________________________________
lilypond-devel mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/lilypond-devel
Reply | Threaded
Open this post in threaded view
|

Re: Problems with autopackaged 2.5.28

Han-Wen Nienhuys
Erik Sandberg wrote:
> Hi,
>
> I have tried the autopackage on a few systems.
>
> Some problems under ubuntu:
> 1. gs isn't well-configured. If I use gs-8.15 as my default gs interpreter, gv
> and friends don't work; spitting out something like "unknown interface x11". I
> guess this might be a bug in the gs package, not in lily.

No, it's intentional. Adding X11 would blow up the size of the package
enormously (we'd have to ship compatible X11 libraries too)

> A problem under Mandrake 10:
> I created a fresh user, and ran the installer as this user. Installation goes
> fine, and libpng and ghostscript are installed in addition. When running
> lilypond, I get the following:
> [erik@localhost report]$ lilypond --verbose
> GNU LilyPond 2.5.28
>
> LILYPOND_DATADIR="/usr/share/lilypond/2.5.28"
> LILYPONDPREFIX="/home/erik/.local/share/lilypond/2.5.28"
> LOCALEDIR="/usr/share/locale"
>
> Effective prefix: "/home/erik/.local/share/lilypond/2.5.28"
> GS_FONTPATH="/home/erik/.local/share/ghostscript/8.15/fonts"
> GS_LIB="/home/krille/.fonts"
> PATH="/home/erik/.local/bin:/usr//bin:/bin:/usr/bin::/usr/local/bin:/usr/X11R6/bin:/usr/games:/home/krille/bin:./:/home/krille/bin:./:/home/krille/bin:./:/home/erik/.local/bin"
> Segmentation fault (core dumped)
>
> The coredump is ~2 meg, and I uploaded it here:
> www.math.uu.se/~sandberg/core.22324


that doesn't. You need to load the coredump in GDB and run a backtrace.
Then again, the binaries are stripped, so it won't make sense anyway.
What does

   ldd lilypond-2.5.28

say?



--
  Han-Wen Nienhuys - [hidden email] - http://www.xs4all.nl/~hanwen


_______________________________________________
lilypond-devel mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/lilypond-devel
Reply | Threaded
Open this post in threaded view
|

Re: Problems with autopackaged 2.5.28

Erik Sandberg
On Thursday 09 June 2005 12.18, Han-Wen Nienhuys wrote:
> > The coredump is ~2 meg, and I uploaded it here:
> > www.math.uu.se/~sandberg/core.22324
>
> that doesn't. You need to load the coredump in GDB and run a backtrace.
> Then again, the binaries are stripped, so it won't make sense anyway.

Ah, I hoped that someone had kept the original non-stripped binary (for which
I guess the coredump would make sense).

> What does
>
>    ldd lilypond-2.5.28
>
> say?

I no longer have access to this computer, but I'll send a mail to the owner &
ask.

Erik


_______________________________________________
lilypond-devel mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/lilypond-devel
Reply | Threaded
Open this post in threaded view
|

Re: Problems with autopackaged 2.5.28

Erik Sandberg
In reply to this post by Erik Sandberg
On Thursday 09 June 2005 11.46, Erik Sandberg wrote:
> Hi,
>
> I have tried the autopackage on a few systems.
>
> Some problems under ubuntu:
> 2. If a binary called 'lilypond' already exists in the target directory,
> all created binaries will be suffixed '-2.5.28'. However,
> lilypond-book-bin-2.5.28 will run 'lilypond', not 'lilypond-2.5.28'. (Pedro
> found a way around this problem with his -snapshot deb packages)

Also, lilypond*-2.5.28 should use gs-bin-8.15 rather than gs, since old gs
versions may exist as a default, and they will override autopackage's
versions. (default gs version in ubuntu is 7.07)

Erik


_______________________________________________
lilypond-devel mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/lilypond-devel
Reply | Threaded
Open this post in threaded view
|

Re: Problems with autopackaged 2.5.28

Jan Nieuwenhuizen
Erik Sandberg writes:

> Also, lilypond*-2.5.28 should use gs-bin-8.15 rather than gs, since old gs
> versions may exist as a default, and they will override autopackage's
> versions. (default gs version in ubuntu is 7.07)

We may want to call our gs gs-nox, and search in PATH for that before
plain gs.

Jan.

--
Jan Nieuwenhuizen <[hidden email]> | GNU LilyPond - The music typesetter
http://www.xs4all.nl/~jantien       | http://www.lilypond.org


_______________________________________________
lilypond-devel mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/lilypond-devel
Reply | Threaded
Open this post in threaded view
|

Re: Problems with autopackaged 2.5.28

Jan Nieuwenhuizen
In reply to this post by Erik Sandberg
Erik Sandberg writes:

> I have tried the autopackage on a few systems.

Thanks, btw.

> Some problems under ubuntu:
> 1. gs isn't well-configured. If I use gs-8.15 as my default gs interpreter, gv
> and friends don't work; spitting out something like "unknown interface x11". I
> guess this might be a bug in the gs package, not in lily.

Will be fixed in 2.5.30: use name gs-nox.

> 2. If a binary called 'lilypond' already exists in the target directory, all
> created binaries will be suffixed '-2.5.28'. However, lilypond-book-bin-2.5.28
> will run 'lilypond', not 'lilypond-2.5.28'. (Pedro found a way around this
> problem with his -snapshot deb packages)

Will be fixed in 2.5.30.

> A problem under Mandrake 10:

I removed that binary, but we might want to see an ldd and backtrace
of a special package with debugging symbols.

Jan.

--
Jan Nieuwenhuizen <[hidden email]> | GNU LilyPond - The music typesetter
http://www.xs4all.nl/~jantien       | http://www.lilypond.org


_______________________________________________
lilypond-devel mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/lilypond-devel