OSX bug?

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

OSX bug?

Steven Gordon Carroll
Hi,

I am running OSX on two machines, one a PowerBook. LilyPond 2.5.27 on
both.

On my Tower running Preview 2.1.0 all is working.

However on the PowerBook, Preview 2.1.1, instead of the expected PDF
file I get this:

Converting to `test.pdf'...
`gs -dSAFER -dCompatibilityLevel=1.4  -sPAPERSIZE="a4" -q -dNOPAUSE
-dBATCH -sDEVICE=pdfwrite -sOutputFile="test.pdf" -c .setpdfwrite -f
"test.ps"' failed (34048)
error: failed files: "/Users/stevengordoncarroll/Desktop/test.ly"
LilyPond exited with status 12005-06-06 18:09:34.513 open[896] No such
file: /Users/stevengordoncarroll/Desktop/test.pdf

Otherwise all seems equal.

Just discovered LilyPond and am enthralled, great job!!
_______________________________________________
bug-lilypond mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/bug-lilypond
Reply | Threaded
Open this post in threaded view
|

Re: OSX bug?

Graham Percival

On 6-Jun-05, at 6:28 PM, Steven Gordon Carroll wrote:
> I am running OSX on two machines, one a PowerBook. LilyPond 2.5.27 on
> both.
>
> On my Tower running Preview 2.1.0 all is working.
>
> However on the PowerBook, Preview 2.1.1, instead of the expected PDF
> file I get this:

Would this be a machine running 10.4 ?  On my 10.3.9 system, Preview is
2.1.0.

Cheers,
- Graham



_______________________________________________
bug-lilypond mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/bug-lilypond
Reply | Threaded
Open this post in threaded view
|

Re: OSX bug?

Han-Wen Nienhuys
In reply to this post by Steven Gordon Carroll
Steven Gordon Carroll wrote:

> Hi,
>
> I am running OSX on two machines, one a PowerBook. LilyPond 2.5.27 on both.
>
> On my Tower running Preview 2.1.0 all is working.
>
> However on the PowerBook, Preview 2.1.1, instead of the expected PDF
> file I get this:
>
> Converting to `test.pdf'...
> `gs -dSAFER -dCompatibilityLevel=1.4  -sPAPERSIZE="a4" -q -dNOPAUSE
> -dBATCH -sDEVICE=pdfwrite -sOutputFile="test.pdf" -c .setpdfwrite -f
> "test.ps"' failed (34048)
> error: failed files: "/Users/stevengordoncarroll/Desktop/test.ly"
> LilyPond exited with status 12005-06-06 18:09:34.513 open[896] No such
> file: /Users/stevengordoncarroll/Desktop/test.pdf
>
> Otherwise all seems equal.

Can you upgrade to .29, and if you still have problems:

run

     lilypond.sh --debug  test.ly

from a terminal. Send the output to the list.
  --
  Han-Wen Nienhuys - [hidden email] - http://www.xs4all.nl/~hanwen


_______________________________________________
bug-lilypond mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/bug-lilypond
Reply | Threaded
Open this post in threaded view
|

Re: OSX bug?

Will Oram
In reply to this post by Steven Gordon Carroll
Regarding this message...

Converting to `test.pdf'...
`gs -dSAFER -dCompatibilityLevel=1.4 -sPAPERSIZE="a4" -q -dNOPAUSE -dBATCH
-sDEVICE=pdfwrite -sOutputFile="test.pdf" -c .setpdfwrite -f "test.ps"'
failed (34048)
error: failed files: "/Users/stevengordoncarroll/Desktop/test.ly"
LilyPond exited with status 12005-06-06 18:09:34.513 open[896] No such
file: /Users/
stevengordoncarroll/Desktop/test.pdf

Mr Carroll didn't send a bug report regarding this, so I'll try, because I
found the same problem
when I installed the .30 binary on a second computer running 10.3.9 and ran
a file I knew would
work.

Running ./lilypond.sh --debug test.ly , I got this message in Terminal:

python: can't open file
'/Applications/LilyPond.app/Contents/Resources/script'

Best,
Will

--------------------------------------------------------------------
mail2web - Check your email from the web at
http://mail2web.com/ .




_______________________________________________
bug-lilypond mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/bug-lilypond