OOoLilyPond-0.5.8 : SVG Issue

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

OOoLilyPond-0.5.8 : SVG Issue

SoundsFromSound

Good morning!

For those of you who use OOoLilyPond:

I am having some problems using the OOoLilyPond extension in LibreOffice and I was just wondering if someone knew how to get this fixed.

SVG output into my documents won't work, no matter what changes I make to the template, config, or the file itself. I have plenty of space for the SVG in the paragraph location and all commands are configured correctly to run outside LibreOffice just fine.

I noticed no change when using/not using the preamble either. PNG insertion works fine however, it's just SVG on both GNU/Linux and Windows systems. SVG won't seem to work into the document at all.

I've included some attachments to show what it looks like now.

Has anyone experienced this issue when using SVG and OOoLilyPond? Thanks!



_______________________________________________
lilypond-user mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/lilypond-user

OOoLilyPond-0.5.8_SVGfail.png (15K) Download Attachment
terminal_0.5.8_SVGok.png (30K) Download Attachment
composer | sound designer | asmr artist
Reply | Threaded
Open this post in threaded view
|

Re: OOoLilyPond-0.5.8 : SVG Issue

Klaus Blum
Hi Ben,


SoundsFromSound wrote
> SVG output into my documents won't work, no matter what changes I make
> to the template, config, or the file itself

could you post the contents of the "Ly Output" window clicking away the
error message?
If the music is split into multiple svg images, OLy cannot handle it.
It could be interesting to know if (at the time of that error message) there
are multiple svg output files in your temp folder or none at all.

Cheers,
Klaus



--
Sent from: http://lilypond.1069038.n5.nabble.com/User-f3.html

_______________________________________________
lilypond-user mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/lilypond-user
Reply | Threaded
Open this post in threaded view
|

Re: OOoLilyPond-0.5.8 : SVG Issue

Klaus Blum
In reply to this post by SoundsFromSound
Hi Ben,

could you post the contents of the "Ly Output" window clicking away the
error message?
If the music is split into multiple svg images, OLy cannot handle it.
It could be interesting to know if (at the time of that error message) there
are multiple svg output files in your temp folder or none at all.

Cheers,
Klaus


SoundsFromSound wrote
> SVG output into my documents won't work, no matter what changes I make
> to the template, config, or the file itself.





--
Sent from: http://lilypond.1069038.n5.nabble.com/User-f3.html

_______________________________________________
lilypond-user mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/lilypond-user
Reply | Threaded
Open this post in threaded view
|

Re: OOoLilyPond-0.5.8 : SVG Issue

Klaus Blum
In reply to this post by SoundsFromSound
Hi Ben,

to be a little more precise:

The lilypond-book-preamble should never be used with svg format. It only
works with the png (or eps) format.

OLy needs one file named OOoLilyPond.svg.

The first point of the error window gives some hints.
Your settings defining the score size (e.g. given in "Line Width" and
"Custom 2" - depending on your template) should provide enough space to fit
your music into one page.
If not, LilyPond will split it up into multiple images. In that case, the
"Ly Output" window will talk about successful compilation and at least two
filenames

OOoLilyPond-1.svg
OOoLilyPond-2.svg
etc.

If your code contains something like "page-count = 1" (e.g. the "Piano
[SVG]" template does), no image at all will be created. Then the output
window will report successful compiling but also errors like
     number of pages is out of bounds
     tried to space systems on a bad number of pages

In both cases, try to provide more space in the OLy settings.

Does that help?

Cheers,
Klaus



--
Sent from: http://lilypond.1069038.n5.nabble.com/User-f3.html

_______________________________________________
lilypond-user mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/lilypond-user
Reply | Threaded
Open this post in threaded view
|

Re: OOoLilyPond-0.5.8 : SVG Issue

SoundsFromSound
On 2/13/2019 11:24 AM, Klaus Blum wrote:
Hi Ben, 

to be a little more precise: 

The lilypond-book-preamble should never be used with svg format. It only
works with the png (or eps) format. 

OLy needs one file named OOoLilyPond.svg.

The first point of the error window gives some hints. 
Your settings defining the score size (e.g. given in "Line Width" and
"Custom 2" - depending on your template) should provide enough space to fit
your music into one page. 
If not, LilyPond will split it up into multiple images. In that case, the
"Ly Output" window will talk about successful compilation and at least two
filenames 

OOoLilyPond-1.svg
OOoLilyPond-2.svg
etc. 

If your code contains something like "page-count = 1" (e.g. the "Piano
[SVG]" template does), no image at all will be created. Then the output
window will report successful compiling but also errors like 
     number of pages is out of bounds
     tried to space systems on a bad number of pages

In both cases, try to provide more space in the OLy settings. 

Does that help?

Cheers, 
Klaus



Hi Klaus,

The ly output looks pretty standard to my eyes in LO:

--------------------------
GNU LilyPond 2.19.82
Processing `OOoLilyPond.ly'
Parsing...
Interpreting music...
Preprocessing graphical objects...
Fitting music on 1 page...
Drawing systems...
Layout output to `OOoLilyPond.svg'...
Success: compilation successfully completed
--------------------------

However, I was using my own custom SVG template when the errors popped up, but when I switched to the included-DefaultSVG config, it worked ok...hmm....

I didn't know about the SVG limitation in OOoLilyPond, because for multiple SVG pages I've just been using Inkscape and manually dragging them into my LO documents. But it's good to know about OOo and multi-page SVGs.

So I guess there must have been something wrong with my SVG template...but I can't see anything that stands out.

I think I'll rebuild it based on the included-DefaultSVG config and see if I can pinpoint the error.

Thanks for your help Klaus! :)





_______________________________________________
lilypond-user mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/lilypond-user
composer | sound designer | asmr artist
Reply | Threaded
Open this post in threaded view
|

Re: OOoLilyPond-0.5.8 : SVG Issue

Klaus Blum
Hi Ben,


SoundsFromSound wrote
> Layout output to `OOoLilyPond.svg'...

indeed, that looks quite reasonable.
It seems that a file named "OOoLilyPond.svg" is created.
Can you check inside your temp folder if that graphic file looks like
intended?

Cheers,
Klaus




--
Sent from: http://lilypond.1069038.n5.nabble.com/User-f3.html

_______________________________________________
lilypond-user mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/lilypond-user
Reply | Threaded
Open this post in threaded view
|

Re: OOoLilyPond-0.5.8 : SVG Issue

SoundsFromSound
On 2/14/2019 8:02 AM, Klaus Blum wrote:
Hi Ben, 


SoundsFromSound wrote
Layout output to `OOoLilyPond.svg'...
indeed, that looks quite reasonable. 
It seems that a file named "OOoLilyPond.svg" is created. 
Can you check inside your temp folder if that graphic file looks like
intended? 

Cheers, 
Klaus

Hi Klaus,

Yes the file looks correct :) Thanks!


_______________________________________________
lilypond-user mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/lilypond-user
composer | sound designer | asmr artist