New release

classic Classic list List threaded Threaded
14 messages Options
Reply | Threaded
Open this post in threaded view
|

New release

Phil Holmes-3
We have just released LilyPond version 2.19.84.  We hope this will quickly
be followed by a new stable release, version 2.20.0.  Please download
2.19.84 and test it, to ensure it is stable enough to form the new stable
release.

Thank you.

--
Phil Holmes



Reply | Threaded
Open this post in threaded view
|

Re: New release

Gianmaria Lari
Hello Phil,

I downloaded and I'm trying to install the windows version.

Is it normal that 2.19.84 version tries to install itself it in the old folder "LilyPond2.19.83"?

Have a look to the attached screenshot.
Regards Gianmaria

On Thu, 6 Feb 2020 at 14:40, Phil Holmes <[hidden email]> wrote:
We have just released LilyPond version 2.19.84.  We hope this will quickly
be followed by a new stable release, version 2.20.0.  Please download
2.19.84 and test it, to ensure it is stable enough to form the new stable
release.

Thank you.

--
Phil Holmes




Annotation 2020-02-06 145656.jpg (33K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: New release

Noeck
In reply to this post by Phil Holmes-3
Thanks a lot! I installed it and tested it on my scores.
Everything works as expected.

Joram

Reply | Threaded
Open this post in threaded view
|

Re: New release

Federico Bruni-2
In reply to this post by Gianmaria Lari
I'm installing on Windows 7 after cleaning a previous very old version.
The default path is C:\Program Files (x86)\LilyPond

Gianmaria, can you test this issue?

Il giorno gio 6 feb 2020 alle 15:02, Gianmaria Lari <[hidden email]> ha scritto:
Hello Phil,

I downloaded and I'm trying to install the windows version.

Is it normal that 2.19.84 version tries to install itself it in the old folder "LilyPond2.19.83"?

Have a look to the attached screenshot.
Regards Gianmaria

On Thu, 6 Feb 2020 at 14:40, Phil Holmes <<a href="mail to:email@philholmes.net" target="_blank">email@...> wrote:
We have just released LilyPond version 2.19.84.  We hope this will quickly
be followed by a new stable release, version 2.20.0.  Please download
2.19.84 and test it, to ensure it is stable enough to form the new stable
release.

Thank you.

--
Phil Holmes



Reply | Threaded
Open this post in threaded view
|

Re: New release

David Kastrup
In reply to this post by Gianmaria Lari
Gianmaria Lari <[hidden email]> writes:

> Hello Phil,
>
> I downloaded and I'm trying to install the windows version.
>
> Is it normal that 2.19.84 version tries to install itself it in the old
> folder "LilyPond2.19.83"?
>
> Have a look to the attached screenshot.

I suspect that it just tries installing into the same directory that you
directed it to install to with the last invocation.  That this contains
a version string is not detected.  It would likely be an interesting
change to the installer to search for such patterns and replace them,
but since the installer is not generic to LilyPond but a
Windows-specific GUB component, that change would likely require some
knowledgable surgery.  Alternatively I am not sure whether Frescobaldi
does not offer a means to download and install LilyPond versions.

--
David Kastrup

Reply | Threaded
Open this post in threaded view
|

Re: New release

ptoye
In reply to this post by Phil Holmes-3
Re: New release > Message: 3
> Date: Thu, 06 Feb 2020 17:57:20 +0100
> From: David Kastrup <
[hidden email]>
> To: Gianmaria Lari <
[hidden email]>
> Cc: Phil Holmes <
[hidden email]>,  LilyPond User Group
>         <
[hidden email]>
> Subject: Re: New release
> Message-ID: <
[hidden email]>
> Content-Type: text/plain

> Gianmaria Lari <
[hidden email]> writes:

>> Hello Phil,

>> I downloaded and I'm trying to install the windows version.

>> Is it normal that 2.19.84 version tries to install itself it in the old
>> folder "LilyPond2.19.83"?

>> Have a look to the attached screenshot.

> I suspect that it just tries installing into
> the same directory that you
> directed it to install to with the last
> invocation.  That this contains
> a version string is not detected.  It would
> likely be an interesting
> change to the installer to search for such
> patterns and replace them,
> but since the installer is not generic to LilyPond but a
> Windows-specific GUB component, that change
> would likely require some
> knowledgable surgery.  Alternatively I am not
> sure whether Frescobaldi
> does not offer a means to download and install LilyPond versions.

I've just had a quick look at Frescobaldi and can't see anything on its menus which implies that you can install Lilypond. Unless it's well hidden.

Peter
Reply | Threaded
Open this post in threaded view
|

Re: New release

David Kastrup
Peter Toye <[hidden email]> writes:

>> Message: 3
>> Date: Thu, 06 Feb 2020 17:57:20 +0100
>> From: David Kastrup <[hidden email]>
>> To: Gianmaria Lari <[hidden email]>
>> Cc: Phil Holmes <[hidden email]>,  LilyPond User Group
>>         <[hidden email]>
>> Subject: Re: New release
>> Message-ID: <[hidden email]>
>> Content-Type: text/plain
>
>> Gianmaria Lari <[hidden email]> writes:
>
>>> Hello Phil,
>
>>> I downloaded and I'm trying to install the windows version.
>
>>> Is it normal that 2.19.84 version tries to install itself it in the old
>>> folder "LilyPond2.19.83"?
>
>>> Have a look to the attached screenshot.
>
>> I suspect that it just tries installing into
>> the same directory that you
>> directed it to install to with the last
>> invocation.  That this contains
>> a version string is not detected.  It would
>> likely be an interesting
>> change to the installer to search for such
>> patterns and replace them,
>> but since the installer is not generic to LilyPond but a
>> Windows-specific GUB component, that change
>> would likely require some
>> knowledgable surgery.  Alternatively I am not
>> sure whether Frescobaldi
>> does not offer a means to download and install LilyPond versions.
>
> I've just had a quick look at Frescobaldi and can't see anything on
> its menus which implies that you can install Lilypond. Unless it's
> well hidden.

I think you are right; at least I cannot find anything like that in
3.0.0.  I thought that this was being discussed at some time, but I
don't know what the conclusion or any resulting action was.

--
David Kastrup

Reply | Threaded
Open this post in threaded view
|

Re: New release

Gianmaria Lari
In reply to this post by Federico Bruni-2
Ciao Federico, I would be very glad to help.

On Thu, 6 Feb 2020 at 17:06, Federico Bruni <[hidden email]> wrote:
I'm installing on Windows 7 after cleaning a previous very old version.
The default path is C:\Program Files (x86)\LilyPond

ok.
 

Sorry but never used Lilyissue. Do you need help for the

#4943 Manual page breaking causing assertion failure

or for the wrong installation path?
Reply | Threaded
Open this post in threaded view
|

Re: New release

ptoye
In reply to this post by David Kastrup
Re: New release Thursday, February 6, 2020, 5:29:00 PM, David Kastrup wrote:

> Peter Toye <
[hidden email]> writes:

>>> Message: 3
>>> Date: Thu, 06 Feb 2020 17:57:20 +0100
>>> From: David Kastrup <
[hidden email]>
>>> To: Gianmaria Lari <
[hidden email]>
>>> Cc: Phil Holmes <
[hidden email]>,  LilyPond User Group
>>>         <
[hidden email]>
>>> Subject: Re: New release
>>> Message-ID: <
[hidden email]>
>>> Content-Type: text/plain

>>> Gianmaria Lari <
[hidden email]> writes:

>>>> Hello Phil,

>>>> I downloaded and I'm trying to install the windows version.

>>>> Is it normal that 2.19.84 version tries to install itself it in the old
>>>> folder "LilyPond2.19.83"?

>>>> Have a look to the attached screenshot.

>>> I suspect that it just tries installing into
>>> the same directory that you
>>> directed it to install to with the last
>>> invocation.  That this contains
>>> a version string is not detected.  It would
>>> likely be an interesting
>>> change to the installer to search for such
>>> patterns and replace them,
>>> but since the installer is not generic to LilyPond but a
>>> Windows-specific GUB component, that change
>>> would likely require some
>>> knowledgable surgery.  Alternatively I am not
>>> sure whether Frescobaldi
>>> does not offer a means to download and install LilyPond versions.

>> I've just had a quick look at Frescobaldi and can't see anything on
>> its menus which implies that you can install Lilypond. Unless it's
>> well hidden.

> I think you are right; at least I cannot find anything like that in
> 3.0.0.  I thought that this was being discussed at some time, but I
> don't know what the conclusion or any resulting action was.

I'm stll on 2.20.0

Peter

Reply | Threaded
Open this post in threaded view
|

RE: New release

Mark Stephen Mrotek
In reply to this post by Phil Holmes-3
Phil,

Downloaded and installed on Windows 7.
Required removal of previous version.
New version number appears in "Snippets/Lilypond Version."

Mark

-----Original Message-----
From: lilypond-user
[mailto:lilypond-user-bounces+carsonmark=[hidden email]] On Behalf Of
Phil Holmes
Sent: Thursday, February 06, 2020 3:35 AM
To: LilyPond User Group <[hidden email]>
Subject: New release

We have just released LilyPond version 2.19.84.  We hope this will quickly
be followed by a new stable release, version 2.20.0.  Please download
2.19.84 and test it, to ensure it is stable enough to form the new stable
release.

Thank you.

--
Phil Holmes




Reply | Threaded
Open this post in threaded view
|

Re: New release

Karlin High
In reply to this post by Federico Bruni-2
On 2/6/2020 10:03 AM, Federico Bruni wrote:
> can you test this issue?
> https://sourceforge.net/p/testlilyissues/issues/4943/

Windows 10 Pro 64-bit Version 1909

Downloaded AssertionFailing.ly from the given issue tracker link

Ran convert-ly on it, it changed file to say \version "2.19.80"

GNU LilyPond 2.19.84
Processing `AssertionFailing.ly'
Parsing...
Interpreting music...[8][16][24]
warning: omitting tuplet bracket with neither left nor right bound
[32][40][48][56][64][72]
Preprocessing graphical objects...
programming error: insane spring distance requested, ignoring it
continuing, cross fingers
programming error: insane spring min_distance requested, ignoring it
continuing, cross fingers
programming error: insane spring constant
continuing, cross fingers
programming error: insane spring distance requested, ignoring it
continuing, cross fingers
programming error: insane spring min_distance requested, ignoring it
continuing, cross fingers
programming error: insane spring constant
continuing, cross fingers
Finding the ideal number of pages...
Fitting music on 1 page...
Drawing systems...
Layout output to `./tmp-lilypond-MEs9cs'...
Converting to `AssertionFailing.pdf'...
Deleting `./tmp-lilypond-MEs9cs'...
Success: compilation successfully completed

Resulting PDF attached.
--
Karlin High
Missouri, USA

AssertionFailing.pdf (71K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: New release

Urs Liska-3
In reply to this post by David Kastrup


Am 6. Februar 2020 18:29:00 MEZ schrieb David Kastrup <[hidden email]>:

>Peter Toye <[hidden email]> writes:
>
>>> Message: 3
>>> Date: Thu, 06 Feb 2020 17:57:20 +0100
>>> From: David Kastrup <[hidden email]>
>>> To: Gianmaria Lari <[hidden email]>
>>> Cc: Phil Holmes <[hidden email]>,  LilyPond User Group
>>>         <[hidden email]>
>>> Subject: Re: New release
>>> Message-ID: <[hidden email]>
>>> Content-Type: text/plain
>>
>>> Gianmaria Lari <[hidden email]> writes:
>>
>>>> Hello Phil,
>>
>>>> I downloaded and I'm trying to install the windows version.
>>
>>>> Is it normal that 2.19.84 version tries to install itself it in the
>old
>>>> folder "LilyPond2.19.83"?
>>
>>>> Have a look to the attached screenshot.
>>
>>> I suspect that it just tries installing into
>>> the same directory that you
>>> directed it to install to with the last
>>> invocation.  That this contains
>>> a version string is not detected.  It would
>>> likely be an interesting
>>> change to the installer to search for such
>>> patterns and replace them,
>>> but since the installer is not generic to LilyPond but a
>>> Windows-specific GUB component, that change
>>> would likely require some
>>> knowledgable surgery.  Alternatively I am not
>>> sure whether Frescobaldi
>>> does not offer a means to download and install LilyPond versions.
>>
>> I've just had a quick look at Frescobaldi and can't see anything on
>> its menus which implies that you can install Lilypond. Unless it's
>> well hidden.
>
>I think you are right; at least I cannot find anything like that in
>3.0.0.  I thought that this was being discussed at some time, but I
>don't know what the conclusion or any resulting action was.

The conclusion was that this feature request was moved to the top of our backlog, and it will probably included in a Frescobaldi 3.2 release  whenever that happens.

Urs

--
Diese Nachricht wurde von meinem Android-Gerät mit K-9 Mail gesendet.

Reply | Threaded
Open this post in threaded view
|

Re: New release

Knute Snortum
In reply to this post by Karlin High
Tested (lightly) on Windows 10 and Ubuntu 19.10.  Everything looks good!

---
Knute Snortum
(via Gmail)


On Thu, Feb 6, 2020 at 10:53 AM Karlin High <[hidden email]> wrote:
On 2/6/2020 10:03 AM, Federico Bruni wrote:
> can you test this issue?
> https://sourceforge.net/p/testlilyissues/issues/4943/

Windows 10 Pro 64-bit Version 1909

Downloaded AssertionFailing.ly from the given issue tracker link

Ran convert-ly on it, it changed file to say \version "2.19.80"

GNU LilyPond 2.19.84
Processing `AssertionFailing.ly'
Parsing...
Interpreting music...[8][16][24]
warning: omitting tuplet bracket with neither left nor right bound
[32][40][48][56][64][72]
Preprocessing graphical objects...
programming error: insane spring distance requested, ignoring it
continuing, cross fingers
programming error: insane spring min_distance requested, ignoring it
continuing, cross fingers
programming error: insane spring constant
continuing, cross fingers
programming error: insane spring distance requested, ignoring it
continuing, cross fingers
programming error: insane spring min_distance requested, ignoring it
continuing, cross fingers
programming error: insane spring constant
continuing, cross fingers
Finding the ideal number of pages...
Fitting music on 1 page...
Drawing systems...
Layout output to `./tmp-lilypond-MEs9cs'...
Converting to `AssertionFailing.pdf'...
Deleting `./tmp-lilypond-MEs9cs'...
Success: compilation successfully completed

Resulting PDF attached.
--
Karlin High
Missouri, USA
Reply | Threaded
Open this post in threaded view
|

Re: New release

Karlin High
In reply to this post by Federico Bruni-2
On 2/6/2020 10:03 AM, Federico Bruni wrote:
> can you test this issue?
> https://sourceforge.net/p/testlilyissues/issues/4943/

Tested OK on a Mac.

Model Name: MacBook Air (11-inch, Mid 2012)
   Model Identifier: MacBookAir5,1
   Processor Name: Intel Core i5
   Processor Speed: 1.7 GHz
   Number of Processors: 1
   Total Number of Cores: 2
   L2 Cache (per Core): 256 KB
   L3 Cache: 3 MB
   Hyper-Threading Technology: Enabled
   Memory: 4 GB

System Version: macOS Mojave 10.14.6 (18G2022)
   Kernel Version: Darwin 18.7.0

./lilypond --version
GNU LilyPond 2.19.84

Processing `/Users/karlin/Downloads/AssertionFailing.ly'
Parsing...
Interpreting music...[8][16][24]
warning: omitting tuplet bracket with neither left nor right bound
[32][40][48][56][64][72]
Preprocessing graphical objects...
programming error: insane spring distance requested, ignoring it
continuing, cross fingers
programming error: insane spring min_distance requested, ignoring it
continuing, cross fingers
programming error: insane spring constant
continuing, cross fingers
programming error: insane spring distance requested, ignoring it
continuing, cross fingers
programming error: insane spring min_distance requested, ignoring it
continuing, cross fingers
programming error: insane spring constant
continuing, cross fingers
Finding the ideal number of pages...
Fitting music on 1 page...
Drawing systems...
Layout output to
`/var/folders/yz/_lzzxl3s6873pn8kl0zr42cc0000gn/T//lilypond-4UuwYi'...
Converting to `AssertionFailing.pdf'...
Deleting
`/var/folders/yz/_lzzxl3s6873pn8kl0zr42cc0000gn/T//lilypond-4UuwYi'...
Success: compilation successfully completed

--
Karlin High
Missouri, USA