Make web fails

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Make web fails

Daniel Johnson-2
Hello all...

I've been unable to make web for a number of releases now.  The make
consistently fails in the same place.  I am currently trying to make web
for 2.5.29 on a Gentoo box with the following installed:

Ghostscript: 8.51
teTeX: 2.0.2
Texinfo: 4.8
Imagemagick: 6.2.2-3
Netpbm: 10.20

I've uploaded my output to the following URLs:
http://www.theologian.org/ly/lilypond.log [dvips log]
http://www.theologian.org/ly/make-web-fail.log [last ~900 lines of
screen output]

Here is the tail-end of the make web failure:
Overfull \hbox (32.24495pt too wide) in paragraph at lines 48--48
 []@texttt user_pref("network.protocol-handler.app.textedit",
"lilypond-pdfpc-h
elper");[]
) (./cheatsheet.texi Appendix E [274] (./lily-2042019296-systems.texi)
(./lily-248870474-systems.texi) (./lily-945023456-systems.texi)
(./lily-388364830-systems.texi) (./lily-605244784-systems.texi)
(./lily-2114314103-systems.texi) (./lily-1812719299-systems.texi)
(./lily-1767385086-systems.texi) (./lily-1152213738-systems.texi)
(./lily-580592364-systems.texi) (./lily-1539167117-systems.texi)
(./lily-921117753-systems.texi) (./lily-245981719-systems.texi)
(./lily-268610260-systems.texi) (./lily-1551172889-systems.texi)
(./lily-1386231839-systems.texi) (./lily-1717311400-systems.texi)
(./lily-568893750-systems.texi) (./lily-709051882-systems.texi)
(./lily-715761078-systems.texi) (./lily-42491253-systems.texi)
(./lily-1687585142-systems.texi) (./lily-1873764757-systems.texi)
(./lily-623747908-systems.texi) (./lily-94492014-systems.texi)
(./lily-671770684-systems.texi) (./lily-1227302337-systems.texi)
(./lily-397208174-systems.texi) [275] [276] [277]) (./fdl.texi Appendix F
[278] [279] [280] [281] [282] [283]) Appendix G [284] [285] )
(see the transcript file for additional information)
Output written on lilypond.dvi (287 pages, 599340 bytes).
Transcript written on lilypond.log.
/usr/bin/texi2dvi: etex exited with bad status, quitting.
/usr/bin/texi2dvi: see lilypond.log for errors.
make[3]: *** [out-www/lilypond.dvi] Error 1
make[3]: Leaving directory
`/var/tmp/portage/lilypond-2.5.29/work/lilypond-2.5.29/Documentation/user'
make[2]: *** [WWW] Error 2
make[2]: Leaving directory
`/var/tmp/portage/lilypond-2.5.29/work/lilypond-2.5.29/Documentation'
make[1]: *** [WWW] Error 2
make[1]: Leaving directory
`/var/tmp/portage/lilypond-2.5.29/work/lilypond-2.5.29'
make: *** [web] Error 2

Any ideas?

--Daniel


_______________________________________________
lilypond-devel mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/lilypond-devel
Reply | Threaded
Open this post in threaded view
|

Re: Make web fails

Daniel Johnson-2
Hmmm... acting on a suspicion, I re-ran "make web".  It got a little
further this time and then died again.  I ran it a third time and it
seems to have gotten past that roadblock.

I seem to recall that either lilypond-book or TeX itself has a tendency
to run out of available temp space, and then it dies without a
meaningful error message.  Is that what is happening here?

Daniel Johnson wrote:

>Hello all...
>
>I've been unable to make web for a number of releases now.  The make
>consistently fails in the same place.  I am currently trying to make web
>for 2.5.29 on a Gentoo box with the following installed:
>
>Ghostscript: 8.51
>teTeX: 2.0.2
>Texinfo: 4.8
>Imagemagick: 6.2.2-3
>Netpbm: 10.20
>
>I've uploaded my output to the following URLs:
>http://www.theologian.org/ly/lilypond.log [dvips log]
>http://www.theologian.org/ly/make-web-fail.log [last ~900 lines of
>screen output]
>
>Here is the tail-end of the make web failure:
>  
>
<snip>


_______________________________________________
lilypond-devel mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/lilypond-devel
Reply | Threaded
Open this post in threaded view
|

Re: Make web fails

Han-Wen Nienhuys
In reply to this post by Daniel Johnson-2
Daniel Johnson wrote:
> Hello all...
>
> I've been unable to make web for a number of releases now.  The make
> consistently fails in the same place.  I am currently trying to make web
> for 2.5.29 on a Gentoo box with the following installed:
>
> Ghostscript: 8.51
> teTeX: 2.0.2
> Texinfo: 4.8

Thanks. The problem is that it is loading the wrong texinfo.tex.

   Loading texinfo [version 2003-02-03.16]: Basics,
   \bindingoffset=\dimen16

I'll look into it
--
  Han-Wen Nienhuys - [hidden email] - http://www.xs4all.nl/~hanwen


_______________________________________________
lilypond-devel mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/lilypond-devel