Lilypond for Windows 2.5.28 - Guile error

classic Classic list List threaded Threaded
11 messages Options
Reply | Threaded
Open this post in threaded view
|

Lilypond for Windows 2.5.28 - Guile error

Thomas Scharkowski
Hello list,

I have asked about a week ago:
Typing "guile" at cmd gives the following:

ERROR: In procedure primitive-load-path:
ERROR: Unable to find file "ice-9/boot-9.scm" in load path

This is my guile.bat:

@echo off
set GUILE_LOAD_PATH=C:\Programme\LilyPond\usr\share\guile\1.7
"C:\Programme\LilyPond\usr\bin\guile.exe" %1 %2 %3 %4 %5 %6 %7 %8 %9

The files are there.
What am I missing?
Wild guess: Could it be a "\" or "/" problem?

BTW, I still cannot start lilypond from cmd, I get no reaction, no
error message.
Typing "lilypond" from the jEdit shell gives the same ERROR as quoted
above.
I got convert-ly working now by installing python24 and copying
"convert-ly" to "convert-ly.py". Shouldn't this be unnecessary?

Thomas


_______________________________________________
lilypond-user mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/lilypond-user
Reply | Threaded
Open this post in threaded view
|

Re: Lilypond for Windows 2.5.28 - Guile error

Jan Nieuwenhuizen
Thomas Scharkowski writes:

> Hello list,
>
> I have asked about a week ago:
> Typing "guile" at cmd gives the following:
>
> ERROR: In procedure primitive-load-path:
> ERROR: Unable to find file "ice-9/boot-9.scm" in load path

What flavour of Windows?

> This is my guile.bat:
>
> @echo off
> set GUILE_LOAD_PATH=C:\Programme\LilyPond\usr\share\guile\1.7
> "C:\Programme\LilyPond\usr\bin\guile.exe" %1 %2 %3 %4 %5 %6 %7 %8 %9
>
> The files are there.
> What am I missing?

Try

    set "GUILE_LOAD_PATH=C:\Programme\LilyPond\usr\share\guile\1.7"

Does that help?  Make sure that you are not using Cygwin's guile.exe,
that won't work.

> BTW, I still cannot start lilypond from cmd, I get no reaction, no
> error message.

Ah,

> Typing "lilypond" from the jEdit shell gives the same ERROR as quoted
> above.
> I got convert-ly working now by installing python24 and copying
> "convert-ly" to "convert-ly.py". Shouldn't this be unnecessary?

Great.  Yes, ideally that should not be necessary.  Maybe renaming the
scripts is a good start.  How do you operate convert-ly.py?  I was
thinking of adding BAT wrappers that invoke

   python convert-ly -e

Jan.

--
Jan Nieuwenhuizen <[hidden email]> | GNU LilyPond - The music typesetter
http://www.xs4all.nl/~jantien       | http://www.lilypond.org


_______________________________________________
lilypond-user mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/lilypond-user
Reply | Threaded
Open this post in threaded view
|

Re: Lilypond for Windows 2.5.28 - Guile error

Thomas Scharkowski
> Thomas Scharkowski writes:
>
> > Hello list,
> >
> > I have asked about a week ago:
> > Typing "guile" at cmd gives the following:
> >
> > ERROR: In procedure primitive-load-path:
> > ERROR: Unable to find file "ice-9/boot-9.scm" in load path
>
> What flavour of Windows?

XP SP1

> > This is my guile.bat:
> >
> > @echo off
> > set GUILE_LOAD_PATH=C:\Programme\LilyPond\usr\share\guile\1.7
> > "C:\Programme\LilyPond\usr\bin\guile.exe" %1 %2 %3 %4 %5 %6 %7 %8 %9
> >
> > The files are there.
> > What am I missing?
>
> Try
>
>     set "GUILE_LOAD_PATH=C:\Programme\LilyPond\usr\share\guile\1.7"
>
> Does that help?  Make sure that you are not using Cygwin's guile.exe,
> that won't work.
This did not help.
I also tried

        set GUILE_LOAD_PATH="C:\Programme\LilyPond\usr\share\guile\1.7"

How can I find out if I am using Cywin's guile.exe?
I did not find a "guile.exe" file in my Cygwin installation.
LilyPond 2.4.6 works, though.

> > I got convert-ly working now by installing python24
> > and copying "convert-ly" to "convert-ly.py". Shouldn't this be
> > unnecessary?
>
> Great.  Yes, ideally that should not be necessary.  Maybe renaming the
> scripts is a good start.  How do you operate convert-ly.py?

>From cmd I type: convert-ly.py -e test.ly
Works!

Thomas




_______________________________________________
lilypond-user mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/lilypond-user
Reply | Threaded
Open this post in threaded view
|

Re: Lilypond for Windows 2.5.28 - Guile error

Jan Nieuwenhuizen
Thomas Scharkowski writes:

>> > ERROR: In procedure primitive-load-path:
>> > ERROR: Unable to find file "ice-9/boot-9.scm" in load path
>>
>> What flavour of Windows?
>
> XP SP1

>>     set "GUILE_LOAD_PATH=C:\Programme\LilyPond\usr\share\guile\1.7"
>
> This did not help.
> I also tried
>
> set GUILE_LOAD_PATH="C:\Programme\LilyPond\usr\share\guile\1.7"

>> Wild guess: Could it be a "\" or "/" problem?

I don't know.  It should not matter, but just try it.  What happens if
you also prepend ...LilyPond\usr\bin to PATH, like lilypond.bat does,
ie, insert

  set "PATH=c:\programme\lilypond\usr\bin;%PATH%"

Waitaminute.  Strange problems often have to do with file permissions.
Have you installed LilyPond as superuser?  Double check if you can
actually open the file ice-9/boot-9.scm, in a text editor for example.

> BTW, I still cannot start lilypond from cmd, I get no reaction, no
> error message.

That's the same problem.

> How can I find out if I am using Cywin's guile.exe?

By specifying the absolute file name, but guile.bat already does that.
That was a silly remark.

Jan.

--
Jan Nieuwenhuizen <[hidden email]> | GNU LilyPond - The music typesetter
http://www.xs4all.nl/~jantien       | http://www.lilypond.org


_______________________________________________
lilypond-user mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/lilypond-user
Reply | Threaded
Open this post in threaded view
|

Re: Lilypond for Windows 2.5.28 - Guile error

Bertalan Fodor
In reply to this post by Thomas Scharkowski
I found that lilypond.exe is looking for something srfi, I don't
remember and won't start, but lilypond.bat works.

Bert


_______________________________________________
lilypond-user mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/lilypond-user
Reply | Threaded
Open this post in threaded view
|

Re: Lilypond for Windows 2.5.28 - Guile error

Thomas Scharkowski
In reply to this post by Jan Nieuwenhuizen
> What happens if
> you also prepend ...LilyPond\usr\bin to PATH, like lilypond.bat does,
> ie, insert
>
>   set "PATH=c:\programme\lilypond\usr\bin;%PATH%"

No change.

> Waitaminute.  Strange problems often have to do with file permissions.
> Have you installed LilyPond as superuser?  Double check if you can
> actually open the file ice-9/boot-9.scm, in a text editor for example.

Yes, no problem opening boot-9.scm

Thomas


_______________________________________________
lilypond-user mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/lilypond-user
Reply | Threaded
Open this post in threaded view
|

Re: Lilypond for Windows 2.5.28 - Guile error

Jan Nieuwenhuizen
In reply to this post by Bertalan Fodor
Bertalan Fodor writes:

> I found that lilypond.exe is looking for something srfi, I don't
> remember and won't start, but lilypond.bat works.

Can you try running

   LILYPOND_VERSBOSE=1 lilypond

(or set LILYPOND_VERSBOSE=1;) to see what happens?

--
Jan Nieuwenhuizen <[hidden email]> | GNU LilyPond - The music typesetter
http://www.xs4all.nl/~jantien       | http://www.lilypond.org


_______________________________________________
lilypond-user mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/lilypond-user
Reply | Threaded
Open this post in threaded view
|

Re: Lilypond for Windows 2.5.28 - Guile error

Mats Bengtsson-6
If you try it, spell it correctly  :-)

    /Mats

Jan Nieuwenhuizen wrote:

> Bertalan Fodor writes:
>
>
>>I found that lilypond.exe is looking for something srfi, I don't
>>remember and won't start, but lilypond.bat works.
>
>
> Can you try running
>
>    LILYPOND_VERSBOSE=1 lilypond
>
> (or set LILYPOND_VERSBOSE=1;) to see what happens?
>

--
=============================================
        Mats Bengtsson
        Signal Processing
        Signals, Sensors and Systems
        Royal Institute of Technology
        SE-100 44  STOCKHOLM
        Sweden
        Phone: (+46) 8 790 8463
         Fax:   (+46) 8 790 7260
        Email: [hidden email]
        WWW: http://www.s3.kth.se/~mabe
=============================================


_______________________________________________
lilypond-user mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/lilypond-user
Reply | Threaded
Open this post in threaded view
|

Re: Lilypond for Windows 2.5.28 - Guile error

Bertalan Fodor
In reply to this post by Jan Nieuwenhuizen

With LILYPOND_VERBOSE set 1:

warning: argv0 relocation: argv0=c:\program
files\lilypond\usr\bin\lilypond.exe, prefix=/usr/share/lilypond/2.5.28
warning: no such directory: c:/program
files/lilypond/usr/share/ghostscript/8.15/fonts;C:\WINDOWS/fonts
warning: no such directory: c:/program
files/lilypond/usr/share/ghostscript/8.15/Resource
warning: no such directory: c:/program
files/lilypond/usr/share/ghostscript/8.15/lib
warning: no such directory: c:/program
files/lilypond/usr/share/gs/fonts;C:\WINDOWS/fonts
warning: no such directory: c:/program
files/lilypond/usr/share/gs/lib;c:/program
files/lilypond/usr/share/gs/Resource
warning: no such directory: c:/program
files/lilypond/usr/bin;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;c:\prog\java\jdk1.5.0\bin;C:\Program
Files\Common
Files\GTK\2.0\bin;C:\WINDOWS\system32\nls;C:\WINDOWS\system32\nls\ENGLISH;C:\texmf\miktex\bin;W:.;Z:.;Y:.;X:.

LILYPOND_DATADIR="/usr/share/lilypond/2.5.28"
LOCALEDIR="/usr/share/locale"

Effective prefix: "c:/program files/lilypond/usr/share/lilypond/2.5.28"
FONTCONFIG_FILE="c:/program files/lilypond/usr/etc/fonts/fonts.conf"
GS_FONTPATH="C:\WINDOWS/fonts"
GS_LIB="c:/program files/lilypond/usr/share/gs/Resource"
GUILE_LOAD_PATH="c:/program files/lilypond/usr/share/guile/1.7"
PANGO_RC_FILE="c:/program files/lilypond/usr/etc/pango/pangorc"
PATH="C:\WINDOWS\system32\C:\WINDOWS;C:\WINDOWS\System32\Wbem;c:\prog\java\jdk1.5.0\bin;C:\Program
Files\Common
Files\GTK\2.0\bin;C:\WINDOWS\system32\nls;C:\WINDOWS\system32\nls\ENGLISH;C:\texmf\miktex\bin;W:.;Z:.;Y:.;X:."
ERROR: In procedure dynamic-link:
ERROR: file: "libguile-srfi-srfi-1-v-2", message: "can't open the module"
Process c:\program files\lilypond\usr\bin\lilypond.exe exited with code 1


_______________________________________________
lilypond-user mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/lilypond-user
Reply | Threaded
Open this post in threaded view
|

Re: Lilypond for Windows 2.5.28 - Guile error

Jan Nieuwenhuizen
Bertalan Fodor writes:

> With LILYPOND_VERBOSE set 1:
>
> warning: argv0 relocation: argv0=c:\program
> files\lilypond\usr\bin\lilypond.exe, prefix=/usr/share/lilypond/2.5.28
> warning: no such directory: c:/program

(strange line breakings?)

> warning: no such directory: c:/program
> files/lilypond/usr/bin;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;c:\prog\java\jdk1.5.0\bin;C:\Program
> Files\Common
> Files\GTK\2.0\bin;C:\WINDOWS\system32\nls;C:\WINDOWS\system32\nls\ENGLISH;C:\texmf\miktex\bin;W:.;Z:.;Y:.;X:.

Ah, setting of PATH fails.

> PATH="C:\WINDOWS\system32\C:\WINDOWS;C:\WINDOWS\System32\Wbem;c:\prog\java\jdk1.5.0\bin;C:\Program
> Files\Common
> Files\GTK\2.0\bin;C:\WINDOWS\system32\nls;C:\WINDOWS\system32\nls\ENGLISH;C:\texmf\miktex\bin;W:.;Z:.;Y:.;X:."
> ERROR: In procedure dynamic-link:
> ERROR: file: "libguile-srfi-srfi-1-v-2", message: "can't open the module"
> Process c:\program files\lilypond\usr\bin\lilypond.exe exited with code 1

Try adding ...lilypond\usr\bin to the path.

--
Jan Nieuwenhuizen <[hidden email]> | GNU LilyPond - The music typesetter
http://www.xs4all.nl/~jantien       | http://www.lilypond.org


_______________________________________________
lilypond-user mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/lilypond-user
Reply | Threaded
Open this post in threaded view
|

Re: Lilypond for Windows 2.5.28 - Guile error

Jan Nieuwenhuizen
In reply to this post by Bertalan Fodor
Bertalan Fodor writes:

> warning: no such directory: c:/program
> files/lilypond/usr/bin;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;c:\prog\java\jdk1.5.0\bin;C:\Program
> Files\Common
> Files\GTK\2.0\bin;C:\WINDOWS\system32\nls;C:\WINDOWS\system32\nls\ENGLISH;C:\texmf\miktex\bin;W:.;Z:.;Y:.;X:.

Found it, this is a silly bug.

Jan.

--
Jan Nieuwenhuizen <[hidden email]> | GNU LilyPond - The music typesetter
http://www.xs4all.nl/~jantien       | http://www.lilypond.org


_______________________________________________
lilypond-user mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/lilypond-user