Latest version in Ubuntu

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

Latest version in Ubuntu

John Wiedenhoeft
Hi all,

I finally switched to Ubuntu Linux (best OS ever!), and I would like to
use the latest Lilypond version there. I know it is provided at
http://ftp.ubuntulinux.org/ubuntu/pool/universe/l/lilypond/, but
synaptic doesn't recognise the 2.6.3-9 version (I have 2.2.6-2 now).
Since it works perfectly for all the other packages I think this might
be a Lilypond issue (some package bug probably?).

I know I could download it manually, but I really would like to use
synaptic's update capabilities in the future.

Are there any experiences regarding this topic?

Sincerly,
John


_______________________________________________
lilypond-user mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/lilypond-user
Reply | Threaded
Open this post in threaded view
|

Re: Latest version in Ubuntu

Gauvain Pocentek-3
John Wiedenhoeft a �crit :

> Hi all,
>
> I finally switched to Ubuntu Linux (best OS ever!), and I would
> like to use the latest Lilypond version there. I know it is
> provided at
> http://ftp.ubuntulinux.org/ubuntu/pool/universe/l/lilypond/, but
> synaptic doesn't recognise the 2.6.3-9 version (I have 2.2.6-2
> now). Since it works perfectly for all the other packages I think
> this might be a Lilypond issue (some package bug probably?).

This repository is for Ubuntu Dapper (Unstable). Lily hasn't been
uploaded on the Breezy repositories. You can use my personnal packages
but they are not as clean as the Dapper one is (see
http://pocentek.perso.cegetel.net/ubuntu). But they do work.
I will discuss with the MOTU guys about including Lily in Breezy.

Regards.

Gauvain


       

       
               
___________________________________________________________________________
Appel audio GRATUIT partout dans le monde avec le nouveau Yahoo! Messenger
T?l?chargez cette version sur http://fr.messenger.yahoo.com



_______________________________________________
lilypond-user mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/lilypond-user
Reply | Threaded
Open this post in threaded view
|

Re: Latest version in Ubuntu

Cyprien Gay
Gauvain Pocentek a écrit :
> John Wiedenhoeft a écrit :

>>http://ftp.ubuntulinux.org/ubuntu/pool/universe/l/lilypond/, but
>>synaptic doesn't recognise the 2.6.3-9 version (I have 2.2.6-2
>>now). Since it works perfectly for all the other packages I think
>>this might be a Lilypond issue (some package bug probably?).
>
> This repository is for Ubuntu Dapper (Unstable). Lily hasn't been
> uploaded on the Breezy repositories. You can use my personnal packages
> but they are not as clean as the Dapper one is (see
> http://pocentek.perso.cegetel.net/ubuntu). But they do work.
> I will discuss with the MOTU guys about including Lily in Breezy.


Hi all, hi Gauvain,

as indicated in http://pocentek.perso.cegetel.net/ubuntu
I included
deb http://pocentek.perso.cegetel.net/ubuntu breezy lilypond contrib
deb-src http://pocentek.perso.cegetel.net/ubuntu breezy lilypond contrib
in /etc/apt/sources.list

Then I have a problem.
Probably just because I am new to Debian or Ubuntu.

# apt-get update
(...)

# apt-get install lilypond
(...)
lilypond dépend de guile-1.6
mais il n'est pas installable.
Erreur : paquet défectueux.
(not quoting, just the meaning of it).

Thanks for your help !

Cyprien.


--
Cyprien Gay.

Qu'est-ce qu'un adhésif ?
http://www.crpp-bordeaux.cnrs.fr/~cgay/adhesion.html
http://www.crpp-bordeaux.cnrs.fr/ext/rubrique.php3?id_rubrique=8

Testez votre navigateur et votre dextérité à la souris
http://logiciellibre.free.fr/construction.html


_______________________________________________
lilypond-user mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/lilypond-user
Reply | Threaded
Open this post in threaded view
|

Re: Latest version in Ubuntu

Cyprien Gay
Cyprien Gay a écrit :
> Gauvain Pocentek a écrit :
>>John Wiedenhoeft a écrit :

>>http://pocentek.perso.cegetel.net/ubuntu). But they do work.
>>I will discuss with the MOTU guys about including Lily in Breezy.

> # apt-get install lilypond
> lilypond dépend de guile-1.6
> mais il n'est pas installable.
> Erreur : paquet défectueux.

Sorry, I posted too fast :
for guile I simply needed an apt-update
after uncommenting the main sources in /etc/apt/sources.list

I now have something about :
/var/lib/dpkg/tmp.ci/preinst
(complete message below)

Anyone has a clue ?
Note that after the apt-get isntall lilypond command
has completed, files /var/lib/dpkg/tmp.ci/preinst
and /usr/bin/kpsewhich do not exist.

Thanks a lot,

Cyprien.


# apt-get install lilypond
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Paquets recommandés :
  lilypond-doc tetex-bin tetex-extra
Les NOUVEAUX paquets suivants seront installés :
  lilypond
0 mis à jour, 1 nouvellement installés, 0 à enlever et 0 non mis à jour.
2 partiellement installés ou enlevés.
Il est nécessaire de prendre 0o/1175ko dans les archives.
Après dépaquetage, 2906ko d'espace disque supplémentaires seront utilisés.
ATTENTION : les paquets suivants n'ont pas été authentifiés.
  lilypond
Faut-il installer ces paquets sans vérification (o/N) ? o

Préconfiguration des paquets ...
(Lecture de la base de données... 58299 fichiers et répertoires déjà
installés.)
Dépaquetage de lilypond (à partir de
.../lilypond_2.6.4-0ubuntu6_i386.deb) ...
/var/lib/dpkg/tmp.ci/preinst: line 19: /usr/bin/kpsewhich: Aucun fichier
ou répertoire de ce type
dpkg : erreur de traitement de
/var/cache/apt/archives/lilypond_2.6.4-0ubuntu6_i386.deb (--unpack) :
 le sous-processus pre-installation script a retourné une erreur de
sortie d'état 1
Des erreurs ont été rencontrées pendant l'exécution :
 /var/cache/apt/archives/lilypond_2.6.4-0ubuntu6_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
#


_______________________________________________
lilypond-user mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/lilypond-user
Reply | Threaded
Open this post in threaded view
|

Re: Latest version in Ubuntu

Gauvain Pocentek-3
Hello all,

It's a dependency trouble. Tetex-bin has been removed from
dependencies but is still needed by the dpkg preinstallation script
(kpsewhich is included i this package).
Installing tetex-bin before installing Lily is the fastest solution
for now, but I'll rebuild the package soon.

Gauvain

Cyprien Gay a �crit :

> I now have something about : /var/lib/dpkg/tmp.ci/preinst (complete
> message below)
>
> Anyone has a clue ? Note that after the apt-get isntall lilypond
> command has completed, files /var/lib/dpkg/tmp.ci/preinst and
> /usr/bin/kpsewhich do not exist.
>
> Thanks a lot,
>
> Cyprien.
>
>
> # apt-get install lilypond Lecture des listes de paquets... Fait
> Construction de l'arbre des d�pendances... Fait Paquets recommand�s
> : lilypond-doc tetex-bin tetex-extra Les NOUVEAUX paquets suivants
> seront install�s : lilypond 0 mis � jour, 1 nouvellement install�s,
> 0 � enlever et 0 non mis � jour. 2 partiellement install�s ou
> enlev�s. Il est n�cessaire de prendre 0o/1175ko dans les archives.
> Apr�s d�paquetage, 2906ko d'espace disque suppl�mentaires seront
> utilis�s. ATTENTION : les paquets suivants n'ont pas �t�
> authentifi�s. lilypond Faut-il installer ces paquets sans
> v�rification (o/N) ? o
>
> Pr�configuration des paquets ... (Lecture de la base de donn�es...
> 58299 fichiers et r�pertoires d�j� install�s.) D�paquetage de
> lilypond (� partir de .../lilypond_2.6.4-0ubuntu6_i386.deb) ...
> /var/lib/dpkg/tmp.ci/preinst: line 19: /usr/bin/kpsewhich: Aucun
> fichier ou r�pertoire de ce type dpkg : erreur de traitement de
> /var/cache/apt/archives/lilypond_2.6.4-0ubuntu6_i386.deb (--unpack)
> : le sous-processus pre-installation script a retourn� une erreur
> de sortie d'�tat 1 Des erreurs ont �t� rencontr�es pendant
> l'ex�cution :
> /var/cache/apt/archives/lilypond_2.6.4-0ubuntu6_i386.deb E:
> Sub-process /usr/bin/dpkg returned an error code (1) #
>
>
> _______________________________________________ lilypond-user
> mailing list [hidden email]
> http://lists.gnu.org/mailman/listinfo/lilypond-user
>


       

       
               
___________________________________________________________________________
Appel audio GRATUIT partout dans le monde avec le nouveau Yahoo! Messenger
T?l?chargez cette version sur http://fr.messenger.yahoo.com



_______________________________________________
lilypond-user mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/lilypond-user
Reply | Threaded
Open this post in threaded view
|

Re: Latest version in Ubuntu

Cyprien Gay
Gauvain Pocentek a écrit :

> It's a dependency trouble. Tetex-bin has been removed from
> dependencies but is still needed by the dpkg preinstallation script
> (kpsewhich is included i this package).
> Installing tetex-bin before installing Lily is the fastest solution

Just did it. It worked ! (2.6.4-0ubuntu6)
Run lilypond on an example : worked fine.

Now I'm eager to discover Lilypond !
Many thanks, Gauvain, that's great !

> for now, but I'll rebuild the package soon.

Just saw the update 2.6.4-0ubuntu7
Updated : worked smoothly.
Run lilypond on an example : worked fine.

Should I test anything else on the new package ?
Like uninstall some packages and re-installing lilymond ?

Again, many thanks, what a great work !

Cyprien.


_______________________________________________
lilypond-user mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/lilypond-user
Reply | Threaded
Open this post in threaded view
|

Re: Latest version in Ubuntu

Gauvain Pocentek-3
Cyprien Gay a �crit :

>Gauvain Pocentek a �crit :
>
>  
>
>>It's a dependency trouble. Tetex-bin has been removed from
>>dependencies but is still needed by the dpkg preinstallation script
>>(kpsewhich is included i this package).
>>Installing tetex-bin before installing Lily is the fastest solution
>>    
>>
>
>Just did it. It worked ! (2.6.4-0ubuntu6)
>Run lilypond on an example : worked fine.
>
>  
>
>>for now, but I'll rebuild the package soon.
>>    
>>
>
>Just saw the update 2.6.4-0ubuntu7
>Updated : worked smoothly.
>Run lilypond on an example : worked fine.
>
That's great.
Thanks for the bug report :)

Gauvain

       

       
               
___________________________________________________________________________
Appel audio GRATUIT partout dans le monde avec le nouveau Yahoo! Messenger
T?l?chargez cette version sur http://fr.messenger.yahoo.com



_______________________________________________
lilypond-user mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/lilypond-user