Guile, Mac OS X

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Guile, Mac OS X

Don Blaheta
It seems I spoke a little early.  Although the posted incantation
satisfies configure that guile is present, it still doesn't seem to be
configuring correctly.  Here is the relevant section of the configure
output:

  checking for guile-config... guile-1.6-config
  checking guile-1.6-config version... 1.6.7
  checking guile compile flags... -I/sw/include
  checking guile link flags... -L/sw/lib -lguile -lguile-ltdl -lm
  checking libguile.h usability... yes
  checking libguile.h presence... yes
  checking for libguile.h... yes
  checking for scm_boot_guile in -lguile... yes
  checking for scm_boot_guile... yes

but when it gets around to generating files and subbing values for the
@VARS@, it's subbing

  s!@GUILE@!!g

which of course breaks everything.  I've rooted around a bit but the
configure/stepmake architecture is confusing, and I'm not sure what I
would need to poke to fix this.

--
-=-Don Blaheta-=-=-[hidden email]-=-=-=-<http://www.blahedo.org/>-=-
A diagnostic is someone who doesn't know whether there are two gods.


_______________________________________________
lilypond-devel mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/lilypond-devel
Reply | Threaded
Open this post in threaded view
|

Re: Guile, Mac OS X

Jan Nieuwenhuizen
Don Blaheta writes:

> It seems I spoke a little early.  Although the posted incantation
> satisfies configure that guile is present, it still doesn't seem to be
> configuring correctly.  Here is the relevant section of the configure
> output:

This only shows that libguile and guile-config, and libguile.h are found.
The relevant section would be

    checking for guile... /home/janneke/usr/pkg/guile/bin/guile

Is guile in your path?

Jan.

--
Jan Nieuwenhuizen <[hidden email]> | GNU LilyPond - The music typesetter
http://www.xs4all.nl/~jantien       | http://www.lilypond.org


_______________________________________________
lilypond-devel mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/lilypond-devel
Reply | Threaded
Open this post in threaded view
|

Re: Guile, Mac OS X

Don Blaheta
Quoth Jan Nieuwenhuizen:

> Don Blaheta writes:
> > It seems I spoke a little early.  Although the posted incantation
> > satisfies configure that guile is present, it still doesn't seem to be
> > configuring correctly.  Here is the relevant section of the configure
> > output:
>
> This only shows that libguile and guile-config, and libguile.h are found.
> The relevant section would be
>
>     checking for guile... /home/janneke/usr/pkg/guile/bin/guile

Ah, missed that.  It says:

checking for guile... guile-1.6
checking for guile... no

> Is guile in your path?

guile-1.6 is (as /sw/bin/guile-1.6).  Is there some way to specify that
to configure, or should I just symlink it?  It looks like configure is
already finding it, though, and yet it still is subbing blanks for
@GUILE@.

--
-=-Don Blaheta-=-=-[hidden email]-=-=-=-<http://www.blahedo.org/>-=-
"Sure he was a total flake but he seemed like such a nice total flake."
                                                        --Zach Miller


_______________________________________________
lilypond-devel mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/lilypond-devel
Reply | Threaded
Open this post in threaded view
|

Re: Guile, Mac OS X

Graham Percival-2

On 19-Dec-05, at 3:23 AM, Don Blaheta wrote:

>> Is guile in your path?
>
> guile-1.6 is (as /sw/bin/guile-1.6).  Is there some way to specify that
> to configure, or should I just symlink it?  It looks like configure is
> already finding it, though, and yet it still is subbing blanks for
> @GUILE@.

I run the following script to configure lilypond.  It works well enough  
to compile the binaries, but not docs.  OSX 10.3.9, fink.


#!/bin/sh
export  
PKG_CONFIG_PATH=/sw/lib/fontconfig2/lib/pkgconfig:/sw/lib/freetype219/
lib/pkgconfig:/sw/lib/pango-ft219/lib/pkgconfig:$PKG_CONFIG_PATH
export PYTHON=/sw/bin/python2.3
export GUILE=/sw/bin/guile-1.6
export GUILE_CONFIG=guile-1.6-config

cd lilypond
patch -p1 < ../lilypond-devel.patch
PREFIX=/sw ./lexer-gcc-3.1.sh
nice ./autogen.sh --prefix $HOME/usr/pkg/lilypond



_______________________________________________
lilypond-devel mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/lilypond-devel