GUILE-with-rational-bugfix

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

GUILE-with-rational-bugfix

Andrew Bernard
I am trying to build lilypond 2.19.82 from the source tarfile on Debian
9.6. I built guile 1.8.8 just fine.

Running configure, I am down to one issue:

ERROR: Please install required programs:  GUILE-with-rational-bugfix

What is this and how to get it?

I searched the archives but the information seemed old and all a bit
confusing.

Andrew
_______________________________________________
lilypond-devel mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/lilypond-devel
Reply | Threaded
Open this post in threaded view
|

Re: GUILE-with-rational-bugfix

David Kastrup
Andrew Bernard <[hidden email]> writes:

> I am trying to build lilypond 2.19.82 from the source tarfile on Debian
> 9.6. I built guile 1.8.8 just fine.
>
> Running configure, I am down to one issue:
>
> ERROR: Please install required programs:  GUILE-with-rational-bugfix
>
> What is this and how to get it?

1.8.8 is fine but you have to have its guile-config in your PATH or call

./configure GUILE_CONFIG=/opt/guile-1.8/bin/guile-config

(or wherever it is) when configuring LilyPond.

--
David Kastrup

_______________________________________________
lilypond-devel mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/lilypond-devel
Reply | Threaded
Open this post in threaded view
|

Re: GUILE-with-rational-bugfix

Andrew Bernard
Thanks.

Only guile 1.8.8 in /usr/local. No guile 2 on the system. Debian 9.6.

ldconfig -p output:

 ldconfig -p | grep guile
    libguilereadline-v-17.so.17 (libc6,x86-64) =>
/usr/local/lib/libguilereadline-v-17.so.17
    libguilereadline-v-17.so (libc6,x86-64) =>
/usr/local/lib/libguilereadline-v-17.so
    libguile.so.17 (libc6,x86-64) => /usr/local/lib/libguile.so.17
    libguile.so (libc6,x86-64) => /usr/local/lib/libguile.so
    libguile-srfi-srfi-60-v-2.so.2 (libc6,x86-64) =>
/usr/local/lib/libguile-srfi-srfi-60-v-2.so.2
    libguile-srfi-srfi-60-v-2.so (libc6,x86-64) =>
/usr/local/lib/libguile-srfi-srfi-60-v-2.so
    libguile-srfi-srfi-13-14-v-3.so.3 (libc6,x86-64) =>
/usr/local/lib/libguile-srfi-srfi-13-14-v-3.so.3
    libguile-srfi-srfi-13-14-v-3.so (libc6,x86-64) =>
/usr/local/lib/libguile-srfi-srfi-13-14-v-3.so
    libguile-srfi-srfi-4-v-3.so.3 (libc6,x86-64) =>
/usr/local/lib/libguile-srfi-srfi-4-v-3.so.3
    libguile-srfi-srfi-4-v-3.so (libc6,x86-64) =>
/usr/local/lib/libguile-srfi-srfi-4-v-3.so
    libguile-srfi-srfi-1-v-3.so.3 (libc6,x86-64) =>
/usr/local/lib/libguile-srfi-srfi-1-v-3.so.3
    libguile-srfi-srfi-1-v-3.so (libc6,x86-64) =>
/usr/local/lib/libguile-srfi-srfi-1-v-3.so

PATH includes /usr/local/bin in appropriate place.

From configure:

hecking for guile-config... /usr/local/bin/guile-config
checking /usr/local/bin/guile-config version... 1.8.8
checking guile compile flags... -I/usr/local/include  -pthread
checking guile link flags...  -pthread -L/usr/local/lib -lguile -lltdl
-lgmp -lcrypt -lm -lltdl
checking libguile.h usability... no
checking libguile.h presence... no
checking for libguile.h... no

libguile.h is in the source tree for guile 1.8.8 but not installed in
/usr/include. Is it required?

Same error persists.

What to do next?

Andrew



On Thu, 15 Nov 2018 at 21:04, David Kastrup <[hidden email]> wrote:

>
> 1.8.8 is fine but you have to have its guile-config in your PATH or call
>
> ./configure GUILE_CONFIG=/opt/guile-1.8/bin/guile-config
>
> (or wherever it is) when configuring LilyPond.
>
>
_______________________________________________
lilypond-devel mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/lilypond-devel
Reply | Threaded
Open this post in threaded view
|

Re: GUILE-with-rational-bugfix

David Kastrup
Andrew Bernard <[hidden email]> writes:

> From configure:
>
> hecking for guile-config... /usr/local/bin/guile-config
> checking /usr/local/bin/guile-config version... 1.8.8
> checking guile compile flags... -I/usr/local/include  -pthread
> checking guile link flags...  -pthread -L/usr/local/lib -lguile -lltdl
> -lgmp -lcrypt -lm -lltdl
> checking libguile.h usability... no
> checking libguile.h presence... no
> checking for libguile.h... no
>
> libguile.h is in the source tree for guile 1.8.8 but not installed in
> /usr/include. Is it required?

If your guile-config has been configured to report certain
include/library directories, you _have_ to run "make install" to
actually put the respective files there.  Apparently you have done some
half-baked installation job yourself?

--
David Kastrup

_______________________________________________
lilypond-devel mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/lilypond-devel
Reply | Threaded
Open this post in threaded view
|

Re: GUILE-with-rational-bugfix

Andrew Bernard
Hi David,

Well spotted Sir. The guile 1.8.8 install done by me was in fact half-baked
as you say, since the documentation did not build, and I was not interested
in that. But allowing make -k install to carry on libguile.h gets copied
and all now works.

Many thanks to your for your great assistance.

Andrew

On Thu, 15 Nov 2018 at 21:59, David Kastrup <[hidden email]> wrote:

>
>
> If your guile-config has been configured to report certain
> include/library directories, you _have_ to run "make install" to
> actually put the respective files there.  Apparently you have done some
> half-baked installation job yourself?
>
>
_______________________________________________
lilypond-devel mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/lilypond-devel
Reply | Threaded
Open this post in threaded view
|

Re: GUILE-with-rational-bugfix

David Kastrup
Andrew Bernard <[hidden email]> writes:

> Hi David,
>
> Well spotted Sir. The guile 1.8.8 install done by me was in fact half-baked
> as you say, since the documentation did not build,

I think that origin/branch_release-1-8 has been updated to build by
Thien-Thi Ngyen.  That's a few commits on top of 1.8.8.  Probably worth
trying out since the documentation may be referenced by the online help.

> and I was not interested in that. But allowing make -k install to
> carry on libguile.h gets copied and all now works.

--
David Kastrup

_______________________________________________
lilypond-devel mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/lilypond-devel