Fuitle attempts to build LilyPond 2.8.0

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Fuitle attempts to build LilyPond 2.8.0

Ralf Mattes-2
Ok, I've almost been able to build LilyPond 2.6.0
ex fontes on our Debian/Ubuntu Package builder
using a pbuilder environment (read: strict building
in a clean and well-defined build environment).
Unfortunately the package build process stops with
the following error message (slightly shortened where
indicated):

Renaming input to: `divisiones.ly'
Interpreting music... [7]
Preprocessing graphical objects...
Calculating line breaks... [3][6][8]
Writing header field `texidoc' to `lily-134911652.texidoc'...
Writing header field `texidoc' to `lily-134911652.texidoc'...
Writing lily-134911652-systems.tex...
Writing lily-134911652-systems.texi...
Layout output to `lily-134911652-1.eps'...
Layout output to `lily-134911652-2.eps'...
Layout output to `lily-134911652.eps'...
Converting to PNG...
Processing `/tmp/buildd/lilypond-2.8.0/Documentation/user/out-www/lily-710760103.ly'
Parsing...
Interpreting music... [3]
Preprocessing graphical objects...
Calculating line breaks...
Writing lily-710760103-systems.tex...
Writing lily-710760103-systems.texi...
Layout output to `lily-710760103-1.eps'...
Layout output to `lily-710760103.eps'...
Converting to PNG...

Processing `/tmp/buildd/lilypond-2.8.0/Documentation/user/out-www/lily-2131317917.ly'
Parsing...
Interpreting music...
programming error: Grob `NoteHead' has no interface for property `delta-pitch'
continuing, cross fingers
programming error: Grob `NoteHead' has no interface for property `delta-pitch'
continuing, cross fingers
programming error: Grob `NoteHead' has no interface for property `primitive'
continuing, cross fingers
programming error: Grob `NoteHead' has no interface for property `primitive'
continuing, cross fingers
programming error: Grob `NoteHead' has no interface for property `join-right-amount'
continuing, cross fingers
programming error: Grob `NoteHead' has no interface for property `thickness'
continuing, cross fingers
programming error: Grob `NoteHead' has no interface for property `head-width'
continuing, cross fingers
programming error: Grob `NoteHead' has no interface for property `thickness'
continuing, cross fingers

   <---x snip x--------- AND SO ON for quite a while  ---------x snip x-------------->

programming error: Note_spacing::get_spacing(): Common refpoint incorrect
continuing, cross fingers
programming error: Note_spacing::get_spacing(): Common refpoint incorrect
continuing, cross fingers
[2]
warning: can't find line breaking that satisfies constraints Writing
lily-2131317917-systems.tex... Writing lily-2131317917-systems.texi...
Layout output to
`lily-2131317917-1.eps'.../tmp/buildd/lilypond-2.8.0/out/share/lilypond/current/scm/framework-ps.scm:474:24:
In procedure inexact->exact in expression (inexact->exact (round #)):
/tmp/buildd/lilypond-2.8.0/out/share/lilypond/current/scm/framework-ps.scm:474:24:
Numerical overflow command failed:
/tmp/buildd/lilypond-2.8.0/lily/out/lilypond --backend=eps
--formats=ps,png --header=texidoc -I /tmp/buildd/lilypond-2.8.0/input/test
-dinternal-type-checking -danti-alias-factor=2 -dgs-font-load -I
'/tmp/buildd/lilypond-2.8.0/Documentation/user'  -I
'/tmp/buildd/lilypond-2.8.0/Documentation/user'  -I
'/tmp/buildd/lilypond-2.8.0/Documentation/user/out-www'  -I
'/tmp/buildd/lilypond-2.8.0/input'  -I
'/tmp/buildd/lilypond-2.8.0/input/regression'  -I
'/tmp/buildd/lilypond-2.8.0/input/test'  -I
'/tmp/buildd/lilypond-2.8.0/input/tutorial'  -I
'/tmp/buildd/lilypond-2.8.0/mf/out'  -I
'/tmp/buildd/lilypond-2.8.0/mf/out' snippet-map.ly lily-908236033
lily-815435187 lily-1642467282 lily-130094515 lily-2079704915
lily-1444843630 lily-395461623 lily-1581812251 lily-1867895275
lily-1989015092 lily-653576972 lily-878352493 lily-1512613910
lily-807385207 lily-1261744467 lily-1060443014 lily-748313129
lily-2020795352 lily-669735314 lily-1901446080 lily-669840088

< ---x snip x----- LONG LIST SHORTENED -------x snip x------------------>

lily-1306675122 Child returned 2
lilypond-book.py (GNU LilyPond) @TOPLEVEL_VERSION@ make[4]: ***
[out-www/lilypond.texi] Error 1 make[4]: Leaving directory
`/tmp/buildd/lilypond-2.8.0/Documentation/user' make[3]: *** [WWW] Error 2
make[3]: Leaving directory `/tmp/buildd/lilypond-2.8.0/Documentation'
make[2]: *** [WWW] Error 2
make[2]: Leaving directory `/tmp/buildd/lilypond-2.8.0' make[1]: *** [web]
Error 2
make[1]: Leaving directory `/tmp/buildd/lilypond-2.8.0' make: ***
[build-doc-stamp] Error 2
pbuilder: Failed autobuilding of package
 -> Aborting with an error


Hmmm, anyone with an idea what's going on here? The message
'In procedure inexact->exact in expression (inexact->exact (round #)):
/tmp/buildd/lilypond-2.8.0/out/share/lilypond/current/scm/framework-ps.scm:474:24:
Numerical overflow' just smells like Guile's rather peculiar way to report
a division by zero :-)
Just a few notes about the used software: Ubuntu/Breezy
w.g++-4.0/guile-1.6, gs-gpl 8.50 and rather fresh mftrace  et al.

TIA Ralf Mattes




_______________________________________________
lilypond-devel mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/lilypond-devel
Reply | Threaded
Open this post in threaded view
|

make web fails for LilyPond 2.8.0/2.9.0 source drop [Also] Re: Futile attempts to build LilyPond 2.8.0

Ralf Mattes-2
On Thu, 30 Mar 2006 21:15:57 +0200, R. Mattes wrote:

> Ok, I've almost been able to build LilyPond 2.6.0
> ex fontes on our Debian/Ubuntu Package builder
> using a pbuilder environment (read: strict building
> in a clean and well-defined build environment).
> Unfortunately the package build process stops with
> the following error message (slightly shortened where
> indicated):
>

Ok, i found the "bug". It looks like this is triggered
by using guile-1.6.n instead of guile-1.8 - this also
explains why Andreas' build failed. The distributed binary
ships with guile-1.8.
Hmm, i thought the n.8-Branch was supposed to be stable?

 Cheers, Ralf Mattes




_______________________________________________
lilypond-devel mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/lilypond-devel
Reply | Threaded
Open this post in threaded view
|

Re: make web fails for LilyPond 2.8.0/2.9.0 source drop [Also] Re: Futile attempts to build LilyPond 2.8.0

Andreas Scherer-2
R. Mattes <rm <at> mh-freiburg.de> writes:
> Ok, i found the "bug". It looks like this is triggered
> by using guile-1.6.n instead of guile-1.8 - this also
> explains why Andreas' build failed.

Confirmed. After updating OpenSUSE 10.0 with guile-1.8.0, all is well again.
"make all web" runs to completion with both the LilyPond 2.8.1 source drop
and the 2.9.1 CVS contents.

Thanks, Ralf, for digging into this.

Take care



_______________________________________________
lilypond-devel mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/lilypond-devel
Reply | Threaded
Open this post in threaded view
|

Re: make web fails for LilyPond 2.8.0/2.9.0 source drop [Also] Re: Futile attempts to build LilyPond 2.8.0

Herman Grootaers
On Tuesday 04 April 2006 10:47, Andreas Scherer wrote:
> R. Mattes <rm <at> mh-freiburg.de> writes:
> > Ok, i found the "bug". It looks like this is triggered
> > by using guile-1.6.n instead of guile-1.8 - this also
> > explains why Andreas' build failed.
>
> Confirmed. After updating OpenSUSE 10.0 with guile-1.8.0, all is well
> again. "make all web" runs to completion with both the LilyPond 2.8.1
> source drop and the 2.9.1 CVS contents.
>
I encountered the same error, But it is not a bug in itself; just that
the configure tests against old versions of certain programs, guile and
mftrace that i know about.

Maybe an action for the main-core developers to update the files which
contain old info, so an end-user who is familiar with  the normal
build-procedure can use it.

The GUB-option is nice, but has also some restrictions build in, and is
not completely user-friendly when you are updating an older version.

If I know what to change, I will try to update the CVS for the new
versions (2.[89].X).

Greetings,
Herman Grootaers


_______________________________________________
lilypond-devel mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/lilypond-devel
Reply | Threaded
Open this post in threaded view
|

Re: make web fails for LilyPond 2.8.0/2.9.0 source drop [Also] Re: Futile attempts to build LilyPond 2.8.0

Han-Wen Nienhuys-2
Herman Grootaers wrote:

> On Tuesday 04 April 2006 10:47, Andreas Scherer wrote:
>> R. Mattes <rm <at> mh-freiburg.de> writes:
>>> Ok, i found the "bug". It looks like this is triggered
>>> by using guile-1.6.n instead of guile-1.8 - this also
>>> explains why Andreas' build failed.
>> Confirmed. After updating OpenSUSE 10.0 with guile-1.8.0, all is well
>> again. "make all web" runs to completion with both the LilyPond 2.8.1
>> source drop and the 2.9.1 CVS contents.
>>
> I encountered the same error, But it is not a bug in itself; just that
> the configure tests against old versions of certain programs, guile and
> mftrace that i know about.
>
> Maybe an action for the main-core developers to update the files which
> contain old info, so an end-user who is familiar with  the normal
> build-procedure can use it.

the goal for 2.8 is to be compatible with guile 1.6 , and it largely is.

For 2.9/3.0 we will require guile 1.8, as we'll likely drop our in-house
rational number support for GUILE's.

--

Han-Wen Nienhuys - [hidden email] - http://www.xs4all.nl/~hanwen

LilyPond Software Design
  -- Code for Music Notation
http://www.lilypond-design.com



_______________________________________________
lilypond-devel mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/lilypond-devel