Fatal Error on Launching 2.15.31

classic Classic list List threaded Threaded
17 messages Options
Reply | Threaded
Open this post in threaded view
|

Fatal Error on Launching 2.15.31

Eric Schissel
This may belong on the developer list- apologies.
Immediately after downloading and expanding 2.15.31 in the version appropriate for my Macintosh (10.7.3 Intel Duo) I got a crash reflected in my console with these message:

3/3/12 9:52:59.193 AM [0x0-0x916916].org.lilypond.lilypond: Traceback (most recent call last):
3/3/12 9:52:59.193 AM [0x0-0x916916].org.lilypond.lilypond:   File "/Users/ericschissel/donotbackup/chromedownloads/LilyPond 3.app/Contents/Resources/__boot__.py", line 31, in <module>
3/3/12 9:52:59.193 AM [0x0-0x916916].org.lilypond.lilypond:     _run('LilyPond.py')
3/3/12 9:52:59.193 AM [0x0-0x916916].org.lilypond.lilypond:   File "/Users/ericschissel/donotbackup/chromedownloads/LilyPond 3.app/Contents/Resources/__boot__.py", line 28, in _run
3/3/12 9:52:59.193 AM [0x0-0x916916].org.lilypond.lilypond:     execfile(path, globals(), globals())
3/3/12 9:52:59.193 AM [0x0-0x916916].org.lilypond.lilypond:   File "/Users/ericschissel/donotbackup/chromedownloads/LilyPond 3.app/Contents/Resources/LilyPond.py", line 3, in <module>
3/3/12 9:52:59.193 AM [0x0-0x916916].org.lilypond.lilypond:     from PyObjCTools import AppHelper
3/3/12 9:52:59.193 AM [0x0-0x916916].org.lilypond.lilypond:   File "PyObjCTools/AppHelper.pyc", line 14, in <module>
3/3/12 9:52:59.193 AM [0x0-0x916916].org.lilypond.lilypond:   File "AppKit/__init__.pyc", line 8, in <module>
3/3/12 9:52:59.193 AM [0x0-0x916916].org.lilypond.lilypond:   File "objc/__init__.pyc", line 22, in <module>
3/3/12 9:52:59.193 AM [0x0-0x916916].org.lilypond.lilypond:   File "objc/__init__.pyc", line 19, in _update
3/3/12 9:52:59.193 AM [0x0-0x916916].org.lilypond.lilypond:   File "objc/_objc.pyc", line 18, in <module>
3/3/12 9:52:59.193 AM [0x0-0x916916].org.lilypond.lilypond:   File "objc/_objc.pyc", line 11, in __load
3/3/12 9:52:59.193 AM [0x0-0x916916].org.lilypond.lilypond: ImportError: dlopen(/Users/ericschissel/donotbackup/chromedownloads/LilyPond 3.app/Contents/Resources/lib/python2.6/lib-dynload/objc/_objc.so, 2): Symbol not found: _objc_sync_notify
3/3/12 9:52:59.193 AM [0x0-0x916916].org.lilypond.lilypond:   Referenced from: /Users/ericschissel/donotbackup/chromedownloads/LilyPond 3.app/Contents/Resources/lib/python2.6/lib-dynload/objc/_objc.so
3/3/12 9:52:59.193 AM [0x0-0x916916].org.lilypond.lilypond:   Expected in: /usr/lib/libobjc.A.dylib
3/3/12 9:52:59.392 AM LilyPond: LilyPond Error
3/3/12 9:52:59.393 AM LilyPond: LilyPond Error
An unexpected error has occurred during execution of the main script

ImportError: dlopen(/Users/ericschissel/donotbackup/chromedownloads/LilyPond 3.app/Contents/Resources/lib/python2.6/lib-dynload/objc/_objc.so, 2): Symbol not found: _objc_sync_notify
  Referenced from: /Users/ericschissel/donotbackup/chromedownloads/LilyPond 3.app/Contents/Resources/lib/python2.6/lib-dynload/objc/_objc.so
  Expected in: /usr/lib/libobjc.A.dylib
3/3/12 9:53:28.736 AM com.apple.launchd.peruser.501: ([0x0-0x916916].org.lilypond.lilypond[24955]) Exited with code: 255
3/3/12 9:54:39.134 AM LilyPond: The Info.plist file must have a PyRuntimeLocations array containing string values for preferred Python runtime locations.  These strings should be "otool -L" style mach ids; "@executable_stub" and "~" prefixes will be translated accordingly.
3/3/12 9:55:05.153 AM [0x0-0x91b91b].LilyPond: 0x9a66212b
3/3/12 9:55:05.153 AM com.apple.launchd.peruser.501: ([0x0-0x91b91b].LilyPond[24997]) Exited with code: 255

Apologies for the dump but not sure what to do with that! Seemed to deserve a report somewhere - if not here, again apologies, will forward to if and as I can.
Eric

_______________________________________________
lilypond-user mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/lilypond-user
Reply | Threaded
Open this post in threaded view
|

Re: Fatal Error on Launching 2.15.31

David Kastrup
Eric <[hidden email]> writes:

> This may belong on the developer list- apologies.
>
> Immediately after downloading and expanding 2.15.31 in the version
> appropriate for my Macintosh (10.7.3 Intel Duo) I got a crash
> reflected in my console with these message:

[...]

> Apologies for the dump but not sure what to do with that! Seemed to
> deserve a report somewhere - if not here, again apologies, will
> forward to if and as I can.

You might want to check the bug tracker for previous occurences.

In this case, this looks like
<URL:http://code.google.com/p/lilypond/issues/detail?id=2338>.

--
David Kastrup


_______________________________________________
lilypond-user mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/lilypond-user
Reply | Threaded
Open this post in threaded view
|

Re: Fatal Error on Launching 2.15.31

Hans Aikema-2
In reply to this post by Eric Schissel
On 3-3-2012 16:01, Eric wrote:
This may belong on the developer list- apologies.
Immediately after downloading and expanding 2.15.31 in the version appropriate for my Macintosh (10.7.3 Intel Duo) I got a crash reflected in my console with these message:

...
Apologies for the dump but not sure what to do with that! Seemed to deserve a report somewhere - if not here, again apologies, will forward to if and as I can.
Eric


_______________________________________________
lilypond-user mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/lilypond-user
Belongs more in the developers list, or even better bugs list (see http://lilypond.org/web/devel/participating/bugs).
I'll see if I can reproduce it on my system (Intel Core i5; OS X 10.7.3)

Having dumps included serves as a good help for developers, so that's a good habit, don't loose it :)

regards,
Hans

_______________________________________________
lilypond-user mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/lilypond-user
Reply | Threaded
Open this post in threaded view
|

Re: Fatal Error on Launching 2.15.31

Phil Holmes
In reply to this post by Eric Schissel
Top-posting, because my mail reader interprets this as HTML and won't use proper indenting.  What operating system are you using?  Have you used previous versions of LilyPond without this problem?

Phil Holmes
 
 
----- Original Message -----
Sent: Saturday, March 03, 2012 3:01 PM
Subject: Fatal Error on Launching 2.15.31

This may belong on the developer list- apologies.
Immediately after downloading and expanding 2.15.31 in the version appropriate for my Macintosh (10.7.3 Intel Duo) I got a crash reflected in my console with these message:

3/3/12 9:52:59.193 AM [0x0-0x916916].org.lilypond.lilypond: Traceback (most recent call last):
3/3/12 9:52:59.193 AM [0x0-0x916916].org.lilypond.lilypond:   File "/Users/ericschissel/donotbackup/chromedownloads/LilyPond 3.app/Contents/Resources/__boot__.py", line 31, in <module>
3/3/12 9:52:59.193 AM [0x0-0x916916].org.lilypond.lilypond:     _run('LilyPond.py')
3/3/12 9:52:59.193 AM [0x0-0x916916].org.lilypond.lilypond:   File "/Users/ericschissel/donotbackup/chromedownloads/LilyPond 3.app/Contents/Resources/__boot__.py", line 28, in _run
3/3/12 9:52:59.193 AM [0x0-0x916916].org.lilypond.lilypond:     execfile(path, globals(), globals())
3/3/12 9:52:59.193 AM [0x0-0x916916].org.lilypond.lilypond:   File "/Users/ericschissel/donotbackup/chromedownloads/LilyPond 3.app/Contents/Resources/LilyPond.py", line 3, in <module>
3/3/12 9:52:59.193 AM [0x0-0x916916].org.lilypond.lilypond:     from PyObjCTools import AppHelper
3/3/12 9:52:59.193 AM [0x0-0x916916].org.lilypond.lilypond:   File "PyObjCTools/AppHelper.pyc", line 14, in <module>
3/3/12 9:52:59.193 AM [0x0-0x916916].org.lilypond.lilypond:   File "AppKit/__init__.pyc", line 8, in <module>
3/3/12 9:52:59.193 AM [0x0-0x916916].org.lilypond.lilypond:   File "objc/__init__.pyc", line 22, in <module>
3/3/12 9:52:59.193 AM [0x0-0x916916].org.lilypond.lilypond:   File "objc/__init__.pyc", line 19, in _update
3/3/12 9:52:59.193 AM [0x0-0x916916].org.lilypond.lilypond:   File "objc/_objc.pyc", line 18, in <module>
3/3/12 9:52:59.193 AM [0x0-0x916916].org.lilypond.lilypond:   File "objc/_objc.pyc", line 11, in __load
3/3/12 9:52:59.193 AM [0x0-0x916916].org.lilypond.lilypond: ImportError: dlopen(/Users/ericschissel/donotbackup/chromedownloads/LilyPond 3.app/Contents/Resources/lib/python2.6/lib-dynload/objc/_objc.so, 2): Symbol not found: _objc_sync_notify
3/3/12 9:52:59.193 AM [0x0-0x916916].org.lilypond.lilypond:   Referenced from: /Users/ericschissel/donotbackup/chromedownloads/LilyPond 3.app/Contents/Resources/lib/python2.6/lib-dynload/objc/_objc.so
3/3/12 9:52:59.193 AM [0x0-0x916916].org.lilypond.lilypond:   Expected in: /usr/lib/libobjc.A.dylib
3/3/12 9:52:59.392 AM LilyPond: LilyPond Error
3/3/12 9:52:59.393 AM LilyPond: LilyPond Error
An unexpected error has occurred during execution of the main script

ImportError: dlopen(/Users/ericschissel/donotbackup/chromedownloads/LilyPond 3.app/Contents/Resources/lib/python2.6/lib-dynload/objc/_objc.so, 2): Symbol not found: _objc_sync_notify
  Referenced from: /Users/ericschissel/donotbackup/chromedownloads/LilyPond 3.app/Contents/Resources/lib/python2.6/lib-dynload/objc/_objc.so
  Expected in: /usr/lib/libobjc.A.dylib
3/3/12 9:53:28.736 AM com.apple.launchd.peruser.501: ([0x0-0x916916].org.lilypond.lilypond[24955]) Exited with code: 255
3/3/12 9:54:39.134 AM LilyPond: The Info.plist file must have a PyRuntimeLocations array containing string values for preferred Python runtime locations.  These strings should be "otool -L" style mach ids; "@executable_stub" and "~" prefixes will be translated accordingly.
3/3/12 9:55:05.153 AM [0x0-0x91b91b].LilyPond: 0x9a66212b
3/3/12 9:55:05.153 AM com.apple.launchd.peruser.501: ([0x0-0x91b91b].LilyPond[24997]) Exited with code: 255

Apologies for the dump but not sure what to do with that! Seemed to deserve a report somewhere - if not here, again apologies, will forward to if and as I can.
Eric


_______________________________________________
lilypond-user mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/lilypond-user

_______________________________________________
lilypond-user mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/lilypond-user
Reply | Threaded
Open this post in threaded view
|

Re: Fatal Error on Launching 2.15.31

Hans Aikema-2
In reply to this post by Eric Schissel
On 3-3-2012 16:01, Eric wrote:
This may belong on the developer list- apologies.
Immediately after downloading and expanding 2.15.31 in the version appropriate for my Macintosh (10.7.3 Intel Duo) I got a crash reflected in my console with these message:



Apologies for the dump but not sure what to do with that! Seemed to deserve a report somewhere - if not here, again apologies, will forward to if and as I can.
Eric


_______________________________________________
lilypond-user mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/lilypond-user

I've been able to reproduce your problem and it's the 'swallowed </string>' in the info.plist that featured on this list a couple of days ago (http://old.nabble.com/Mac-info.plist-problem-td33349559.html). Add the missing </string> in line 56 and your Lilypond should return to normal operation.
 

regards,
Hans

_______________________________________________
lilypond-user mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/lilypond-user
Reply | Threaded
Open this post in threaded view
|

Re: Fatal Error on Launching 2.15.31

Hans Aikema-2
In reply to this post by Eric Schissel
Top-posting as my bottom-posting mails seem to not get through to the list.

Is a known bug to be solved in 2.15.32:

http://code.google.com/p/lilypond/issues/detail?id=2338&can=7&q=info.plist&colspec=ID%20Type%20Status%20Stars%20Owner%20Patch%20Needs%20Summary

You can solve it locally by adding the missing </string> in info.plist at line 56

regards,
Hans

On 3-3-2012 16:01, Eric wrote:
This may belong on the developer list- apologies.
Immediately after downloading and expanding 2.15.31 in the version appropriate for my Macintosh (10.7.3 Intel Duo) I got a crash reflected in my console with these message:

3/3/12 9:52:59.193 AM [0x0-0x916916].org.lilypond.lilypond: Traceback (most recent call last):
3/3/12 9:52:59.193 AM [0x0-0x916916].org.lilypond.lilypond:   File "/Users/ericschissel/donotbackup/chromedownloads/LilyPond 3.app/Contents/Resources/__boot__.py", line 31, in <module>
3/3/12 9:52:59.193 AM [0x0-0x916916].org.lilypond.lilypond:     _run('LilyPond.py')
3/3/12 9:52:59.193 AM [0x0-0x916916].org.lilypond.lilypond:   File "/Users/ericschissel/donotbackup/chromedownloads/LilyPond 3.app/Contents/Resources/__boot__.py", line 28, in _run
3/3/12 9:52:59.193 AM [0x0-0x916916].org.lilypond.lilypond:     execfile(path, globals(), globals())
3/3/12 9:52:59.193 AM [0x0-0x916916].org.lilypond.lilypond:   File "/Users/ericschissel/donotbackup/chromedownloads/LilyPond 3.app/Contents/Resources/LilyPond.py", line 3, in <module>
3/3/12 9:52:59.193 AM [0x0-0x916916].org.lilypond.lilypond:     from PyObjCTools import AppHelper
3/3/12 9:52:59.193 AM [0x0-0x916916].org.lilypond.lilypond:   File "PyObjCTools/AppHelper.pyc", line 14, in <module>
3/3/12 9:52:59.193 AM [0x0-0x916916].org.lilypond.lilypond:   File "AppKit/__init__.pyc", line 8, in <module>
3/3/12 9:52:59.193 AM [0x0-0x916916].org.lilypond.lilypond:   File "objc/__init__.pyc", line 22, in <module>
3/3/12 9:52:59.193 AM [0x0-0x916916].org.lilypond.lilypond:   File "objc/__init__.pyc", line 19, in _update
3/3/12 9:52:59.193 AM [0x0-0x916916].org.lilypond.lilypond:   File "objc/_objc.pyc", line 18, in <module>
3/3/12 9:52:59.193 AM [0x0-0x916916].org.lilypond.lilypond:   File "objc/_objc.pyc", line 11, in __load
3/3/12 9:52:59.193 AM [0x0-0x916916].org.lilypond.lilypond: ImportError: dlopen(/Users/ericschissel/donotbackup/chromedownloads/LilyPond 3.app/Contents/Resources/lib/python2.6/lib-dynload/objc/_objc.so, 2): Symbol not found: _objc_sync_notify
3/3/12 9:52:59.193 AM [0x0-0x916916].org.lilypond.lilypond:   Referenced from: /Users/ericschissel/donotbackup/chromedownloads/LilyPond 3.app/Contents/Resources/lib/python2.6/lib-dynload/objc/_objc.so
3/3/12 9:52:59.193 AM [0x0-0x916916].org.lilypond.lilypond:   Expected in: /usr/lib/libobjc.A.dylib
3/3/12 9:52:59.392 AM LilyPond: LilyPond Error
3/3/12 9:52:59.393 AM LilyPond: LilyPond Error
An unexpected error has occurred during execution of the main script

ImportError: dlopen(/Users/ericschissel/donotbackup/chromedownloads/LilyPond 3.app/Contents/Resources/lib/python2.6/lib-dynload/objc/_objc.so, 2): Symbol not found: _objc_sync_notify
  Referenced from: /Users/ericschissel/donotbackup/chromedownloads/LilyPond 3.app/Contents/Resources/lib/python2.6/lib-dynload/objc/_objc.so
  Expected in: /usr/lib/libobjc.A.dylib
3/3/12 9:53:28.736 AM com.apple.launchd.peruser.501: ([0x0-0x916916].org.lilypond.lilypond[24955]) Exited with code: 255
3/3/12 9:54:39.134 AM LilyPond: The Info.plist file must have a PyRuntimeLocations array containing string values for preferred Python runtime locations.  These strings should be "otool -L" style mach ids; "@executable_stub" and "~" prefixes will be translated accordingly.
3/3/12 9:55:05.153 AM [0x0-0x91b91b].LilyPond: 0x9a66212b
3/3/12 9:55:05.153 AM com.apple.launchd.peruser.501: ([0x0-0x91b91b].LilyPond[24997]) Exited with code: 255

Apologies for the dump but not sure what to do with that! Seemed to deserve a report somewhere - if not here, again apologies, will forward to if and as I can.
Eric


_______________________________________________
lilypond-user mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/lilypond-user


_______________________________________________
lilypond-user mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/lilypond-user
Reply | Threaded
Open this post in threaded view
|

Re: Fatal Error on Launching 2.15.31

Hans Aikema-2
In reply to this post by Eric Schissel
On 3-3-2012 16:01, Eric wrote:

> This may belong on the developer list- apologies.
> Immediately after downloading and expanding 2.15.31 in the version
> appropriate for my Macintosh (10.7.3 Intel Duo) I got a crash
> reflected in my console with these message:
>
> ...
> Apologies for the dump but not sure what to do with that! Seemed to
> deserve a report somewhere - if not here, again apologies, will
> forward to if and as I can.
> Eric
>
>
> _______________________________________________
> lilypond-user mailing list
> [hidden email]
> https://lists.gnu.org/mailman/listinfo/lilypond-user

Retrying in plain-tekst as my previous (html-only, based on the original
mail) mails seem to not get through to the list.

It is a known bug presumed to be solved by the yet-to-be-released
2.15.32, which previously featured this list as "Mac info.plist problem":

http://code.google.com/p/lilypond/issues/detail?id=2338&can=7&q=info.plist&colspec=ID%20Type%20Status%20Stars%20Owner%20Patch%20Needs%20Summary

You can solve it locally by adding the missing </string> in info.plist
at line 56

regards,
Hans


_______________________________________________
lilypond-user mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/lilypond-user
Reply | Threaded
Open this post in threaded view
|

Re: Fatal Error on Launching 2.15.31

Rembrandt Wolpert
In reply to this post by Eric Schissel
Go into Lilypond.app/Contents/

open info.plist with your favourite editor and

change Line 56:

        <string>Build from Wed Feb 29 14:13:09 2012

to:

        <string>Build from Wed Feb 29 14:13:09 2012</string>

It's an error since version 2.15.30, in the bug-reports, but not acted
upon (why? it's so easy?)

Rembrandt

On Sat Mar  3 09:01:18 2012, Eric wrote:

> This may belong on the developer list- apologies.
> Immediately after downloading and expanding 2.15.31 in the version
> appropriate for my Macintosh (10.7.3 Intel Duo) I got a crash reflected in
> my console with these message:
>
> 3/3/12 9:52:59.193 AM [0x0-0x916916].org.lilypond.lilypond: Traceback (most
> recent call last):
> 3/3/12 9:52:59.193 AM [0x0-0x916916].org.lilypond.lilypond:   File
> "/Users/ericschissel/donotbackup/chromedownloads/LilyPond
> 3.app/Contents/Resources/__boot__.py", line 31, in <module>
> 3/3/12 9:52:59.193 AM [0x0-0x916916].org.lilypond.lilypond:
> _run('LilyPond.py')
> 3/3/12 9:52:59.193 AM [0x0-0x916916].org.lilypond.lilypond:   File
> "/Users/ericschissel/donotbackup/chromedownloads/LilyPond
> 3.app/Contents/Resources/__boot__.py", line 28, in _run
> 3/3/12 9:52:59.193 AM [0x0-0x916916].org.lilypond.lilypond:
> execfile(path, globals(), globals())
> 3/3/12 9:52:59.193 AM [0x0-0x916916].org.lilypond.lilypond:   File
> "/Users/ericschissel/donotbackup/chromedownloads/LilyPond
> 3.app/Contents/Resources/LilyPond.py", line 3, in <module>
> 3/3/12 9:52:59.193 AM [0x0-0x916916].org.lilypond.lilypond:     from
> PyObjCTools import AppHelper
> 3/3/12 9:52:59.193 AM [0x0-0x916916].org.lilypond.lilypond:   File
> "PyObjCTools/AppHelper.pyc", line 14, in <module>
> 3/3/12 9:52:59.193 AM [0x0-0x916916].org.lilypond.lilypond:   File
> "AppKit/__init__.pyc", line 8, in <module>
> 3/3/12 9:52:59.193 AM [0x0-0x916916].org.lilypond.lilypond:   File
> "objc/__init__.pyc", line 22, in <module>
> 3/3/12 9:52:59.193 AM [0x0-0x916916].org.lilypond.lilypond:   File
> "objc/__init__.pyc", line 19, in _update
> 3/3/12 9:52:59.193 AM [0x0-0x916916].org.lilypond.lilypond:   File
> "objc/_objc.pyc", line 18, in <module>
> 3/3/12 9:52:59.193 AM [0x0-0x916916].org.lilypond.lilypond:   File
> "objc/_objc.pyc", line 11, in __load
> 3/3/12 9:52:59.193 AM [0x0-0x916916].org.lilypond.lilypond: ImportError:
> dlopen(/Users/ericschissel/donotbackup/chromedownloads/LilyPond
> 3.app/Contents/Resources/lib/python2.6/lib-dynload/objc/_objc.so, 2):
> Symbol not found: _objc_sync_notify
> 3/3/12 9:52:59.193 AM [0x0-0x916916].org.lilypond.lilypond:   Referenced
> from: /Users/ericschissel/donotbackup/chromedownloads/LilyPond
> 3.app/Contents/Resources/lib/python2.6/lib-dynload/objc/_objc.so
> 3/3/12 9:52:59.193 AM [0x0-0x916916].org.lilypond.lilypond:   Expected in:
> /usr/lib/libobjc.A.dylib
> 3/3/12 9:52:59.392 AM LilyPond: LilyPond Error
> 3/3/12 9:52:59.393 AM LilyPond: LilyPond Error
> An unexpected error has occurred during execution of the main script
>
> ImportError:
> dlopen(/Users/ericschissel/donotbackup/chromedownloads/LilyPond
> 3.app/Contents/Resources/lib/python2.6/lib-dynload/objc/_objc.so, 2):
> Symbol not found: _objc_sync_notify
>   Referenced from: /Users/ericschissel/donotbackup/chromedownloads/LilyPond
> 3.app/Contents/Resources/lib/python2.6/lib-dynload/objc/_objc.so
>   Expected in: /usr/lib/libobjc.A.dylib
> 3/3/12 9:53:28.736 AM com.apple.launchd.peruser.501:
> ([0x0-0x916916].org.lilypond.lilypond[24955]) Exited with code: 255
> 3/3/12 9:54:39.134 AM LilyPond: The Info.plist file must have a
> PyRuntimeLocations array containing string values for preferred Python
> runtime locations.  These strings should be "otool -L" style mach ids;
> "@executable_stub" and "~" prefixes will be translated accordingly.
> 3/3/12 9:55:05.153 AM [0x0-0x91b91b].LilyPond: 0x9a66212b
> 3/3/12 9:55:05.153 AM com.apple.launchd.peruser.501:
> ([0x0-0x91b91b].LilyPond[24997]) Exited with code: 255
>
> Apologies for the dump but not sure what to do with that! Seemed to deserve
> a report somewhere - if not here, again apologies, will forward to if and
> as I can.
> Eric
>
>
>
> _______________________________________________
> lilypond-user mailing list
> [hidden email]
> https://lists.gnu.org/mailman/listinfo/lilypond-user

--
松下問童子言師採藥去
只在此山中雲深不知處


_______________________________________________
lilypond-user mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/lilypond-user
Reply | Threaded
Open this post in threaded view
|

Re: Fatal Error on Launching 2.15.31

Eric Schissel
In reply to this post by Phil Holmes
Macintosh OS 10.7.3 (Intel , not PPC - Duo Core, desktop, computer is several years old and was bought with 10.4 I think...) - sorry about that. Yes, most recently 2.15.24. 

On Sat, Mar 3, 2012 at 12:07 PM, Phil Holmes <[hidden email]> wrote:
Top-posting, because my mail reader interprets this as HTML and won't use proper indenting.  What operating system are you using?  Have you used previous versions of LilyPond without this problem?

Phil Holmes
 
 
----- Original Message -----
Sent: Saturday, March 03, 2012 3:01 PM
Subject: Fatal Error on Launching 2.15.31

This may belong on the developer list- apologies.
Immediately after downloading and expanding 2.15.31 in the version appropriate for my Macintosh (10.7.3 Intel Duo) I got a crash reflected in my console with these message:

3/3/12 9:52:59.193 AM [0x0-0x916916].org.lilypond.lilypond: Traceback (most recent call last):
3/3/12 9:52:59.193 AM [0x0-0x916916].org.lilypond.lilypond:   File "/Users/ericschissel/donotbackup/chromedownloads/LilyPond 3.app/Contents/Resources/__boot__.py", line 31, in <module>
3/3/12 9:52:59.193 AM [0x0-0x916916].org.lilypond.lilypond:     _run('LilyPond.py')
3/3/12 9:52:59.193 AM [0x0-0x916916].org.lilypond.lilypond:   File "/Users/ericschissel/donotbackup/chromedownloads/LilyPond 3.app/Contents/Resources/__boot__.py", line 28, in _run
3/3/12 9:52:59.193 AM [0x0-0x916916].org.lilypond.lilypond:     execfile(path, globals(), globals())
3/3/12 9:52:59.193 AM [0x0-0x916916].org.lilypond.lilypond:   File "/Users/ericschissel/donotbackup/chromedownloads/LilyPond 3.app/Contents/Resources/LilyPond.py", line 3, in <module>
3/3/12 9:52:59.193 AM [0x0-0x916916].org.lilypond.lilypond:     from PyObjCTools import AppHelper
3/3/12 9:52:59.193 AM [0x0-0x916916].org.lilypond.lilypond:   File "PyObjCTools/AppHelper.pyc", line 14, in <module>
3/3/12 9:52:59.193 AM [0x0-0x916916].org.lilypond.lilypond:   File "AppKit/__init__.pyc", line 8, in <module>
3/3/12 9:52:59.193 AM [0x0-0x916916].org.lilypond.lilypond:   File "objc/__init__.pyc", line 22, in <module>
3/3/12 9:52:59.193 AM [0x0-0x916916].org.lilypond.lilypond:   File "objc/__init__.pyc", line 19, in _update
3/3/12 9:52:59.193 AM [0x0-0x916916].org.lilypond.lilypond:   File "objc/_objc.pyc", line 18, in <module>
3/3/12 9:52:59.193 AM [0x0-0x916916].org.lilypond.lilypond:   File "objc/_objc.pyc", line 11, in __load
3/3/12 9:52:59.193 AM [0x0-0x916916].org.lilypond.lilypond: ImportError: dlopen(/Users/ericschissel/donotbackup/chromedownloads/LilyPond 3.app/Contents/Resources/lib/python2.6/lib-dynload/objc/_objc.so, 2): Symbol not found: _objc_sync_notify
3/3/12 9:52:59.193 AM [0x0-0x916916].org.lilypond.lilypond:   Referenced from: /Users/ericschissel/donotbackup/chromedownloads/LilyPond 3.app/Contents/Resources/lib/python2.6/lib-dynload/objc/_objc.so
3/3/12 9:52:59.193 AM [0x0-0x916916].org.lilypond.lilypond:   Expected in: /usr/lib/libobjc.A.dylib
3/3/12 9:52:59.392 AM LilyPond: LilyPond Error
3/3/12 9:52:59.393 AM LilyPond: LilyPond Error
An unexpected error has occurred during execution of the main script

ImportError: dlopen(/Users/ericschissel/donotbackup/chromedownloads/LilyPond 3.app/Contents/Resources/lib/python2.6/lib-dynload/objc/_objc.so, 2): Symbol not found: _objc_sync_notify
  Referenced from: /Users/ericschissel/donotbackup/chromedownloads/LilyPond 3.app/Contents/Resources/lib/python2.6/lib-dynload/objc/_objc.so
  Expected in: /usr/lib/libobjc.A.dylib
3/3/12 9:53:28.736 AM com.apple.launchd.peruser.501: ([0x0-0x916916].org.lilypond.lilypond[24955]) Exited with code: 255
3/3/12 9:54:39.134 AM LilyPond: The Info.plist file must have a PyRuntimeLocations array containing string values for preferred Python runtime locations.  These strings should be "otool -L" style mach ids; "@executable_stub" and "~" prefixes will be translated accordingly.
3/3/12 9:55:05.153 AM [0x0-0x91b91b].LilyPond: 0x9a66212b
3/3/12 9:55:05.153 AM com.apple.launchd.peruser.501: ([0x0-0x91b91b].LilyPond[24997]) Exited with code: 255

Apologies for the dump but not sure what to do with that! Seemed to deserve a report somewhere - if not here, again apologies, will forward to if and as I can.
Eric


_______________________________________________
lilypond-user mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/lilypond-user



_______________________________________________
lilypond-user mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/lilypond-user
Reply | Threaded
Open this post in threaded view
|

Re: Fatal Error on Launching 2.15.31

Colin Hall-3

Eric,

Thanks for letting us know about the problem. I believe you are
experiencing a known issue, already reported by other Mac OSX users

We have a fix for this issue and I expect it to be included in the
next development release 2.15.32.

I'm hoping to coordinate testing of the next release by Mac OS X
users, once it is available.

Would you like to volounteer to do that? It would be very helpful for
the Lilypond bug squad to have your support.

Cheers,
Colin.

On Sat, Mar 03, 2012 at 05:32:40PM -0500, Eric wrote:

> Macintosh OS 10.7.3 (Intel , not PPC - Duo Core, desktop, computer is
> several years old and was bought with 10.4 I think...) - sorry about that.
> Yes, most recently 2.15.24.
>
> On Sat, Mar 3, 2012 at 12:07 PM, Phil Holmes <[hidden email]> wrote:
>
> > **
> > Top-posting, because my mail reader interprets this as HTML and won't use
> > proper indenting.  What operating system are you using?  Have you used
> > previous versions of LilyPond without this problem?
> >
> > Phil Holmes
> >
> >
> >
> > ----- Original Message -----
> > *From:* Eric <[hidden email]>
> > *To:* [hidden email]
> > *Sent:* Saturday, March 03, 2012 3:01 PM
> > *Subject:* Fatal Error on Launching 2.15.31
> >
> > This may belong on the developer list- apologies.
> > Immediately after downloading and expanding 2.15.31 in the version
> > appropriate for my Macintosh (10.7.3 Intel Duo) I got a crash reflected in
> > my console with these message:
> >
> >  3/3/12 9:52:59.193 AM [0x0-0x916916].org.lilypond.lilypond: Traceback
> > (most recent call last):
> > 3/3/12 9:52:59.193 AM [0x0-0x916916].org.lilypond.lilypond:   File
> > "/Users/ericschissel/donotbackup/chromedownloads/LilyPond
> > 3.app/Contents/Resources/__boot__.py", line 31, in <module>
> > 3/3/12 9:52:59.193 AM [0x0-0x916916].org.lilypond.lilypond:
> > _run('LilyPond.py')
> > 3/3/12 9:52:59.193 AM [0x0-0x916916].org.lilypond.lilypond:   File
> > "/Users/ericschissel/donotbackup/chromedownloads/LilyPond
> > 3.app/Contents/Resources/__boot__.py", line 28, in _run
> > 3/3/12 9:52:59.193 AM [0x0-0x916916].org.lilypond.lilypond:
> > execfile(path, globals(), globals())
> > 3/3/12 9:52:59.193 AM [0x0-0x916916].org.lilypond.lilypond:   File
> > "/Users/ericschissel/donotbackup/chromedownloads/LilyPond
> > 3.app/Contents/Resources/LilyPond.py", line 3, in <module>
> > 3/3/12 9:52:59.193 AM [0x0-0x916916].org.lilypond.lilypond:     from
> > PyObjCTools import AppHelper
> > 3/3/12 9:52:59.193 AM [0x0-0x916916].org.lilypond.lilypond:   File
> > "PyObjCTools/AppHelper.pyc", line 14, in <module>
> > 3/3/12 9:52:59.193 AM [0x0-0x916916].org.lilypond.lilypond:   File
> > "AppKit/__init__.pyc", line 8, in <module>
> > 3/3/12 9:52:59.193 AM [0x0-0x916916].org.lilypond.lilypond:   File
> > "objc/__init__.pyc", line 22, in <module>
> > 3/3/12 9:52:59.193 AM [0x0-0x916916].org.lilypond.lilypond:   File
> > "objc/__init__.pyc", line 19, in _update
> > 3/3/12 9:52:59.193 AM [0x0-0x916916].org.lilypond.lilypond:   File
> > "objc/_objc.pyc", line 18, in <module>
> > 3/3/12 9:52:59.193 AM [0x0-0x916916].org.lilypond.lilypond:   File
> > "objc/_objc.pyc", line 11, in __load
> > 3/3/12 9:52:59.193 AM [0x0-0x916916].org.lilypond.lilypond: ImportError:
> > dlopen(/Users/ericschissel/donotbackup/chromedownloads/LilyPond
> > 3.app/Contents/Resources/lib/python2.6/lib-dynload/objc/_objc.so, 2):
> > Symbol not found: _objc_sync_notify
> > 3/3/12 9:52:59.193 AM [0x0-0x916916].org.lilypond.lilypond:   Referenced
> > from: /Users/ericschissel/donotbackup/chromedownloads/LilyPond
> > 3.app/Contents/Resources/lib/python2.6/lib-dynload/objc/_objc.so
> > 3/3/12 9:52:59.193 AM [0x0-0x916916].org.lilypond.lilypond:   Expected in:
> > /usr/lib/libobjc.A.dylib
> > 3/3/12 9:52:59.392 AM LilyPond: LilyPond Error
> > 3/3/12 9:52:59.393 AM LilyPond: LilyPond Error
> > An unexpected error has occurred during execution of the main script
> >
> > ImportError:
> > dlopen(/Users/ericschissel/donotbackup/chromedownloads/LilyPond
> > 3.app/Contents/Resources/lib/python2.6/lib-dynload/objc/_objc.so, 2):
> > Symbol not found: _objc_sync_notify
> >   Referenced from:
> > /Users/ericschissel/donotbackup/chromedownloads/LilyPond
> > 3.app/Contents/Resources/lib/python2.6/lib-dynload/objc/_objc.so
> >   Expected in: /usr/lib/libobjc.A.dylib
> > 3/3/12 9:53:28.736 AM com.apple.launchd.peruser.501:
> > ([0x0-0x916916].org.lilypond.lilypond[24955]) Exited with code: 255
> > 3/3/12 9:54:39.134 AM LilyPond: The Info.plist file must have a
> > PyRuntimeLocations array containing string values for preferred Python
> > runtime locations.  These strings should be "otool -L" style mach ids;
> > "@executable_stub" and "~" prefixes will be translated accordingly.
> > 3/3/12 9:55:05.153 AM [0x0-0x91b91b].LilyPond: 0x9a66212b
> > 3/3/12 9:55:05.153 AM com.apple.launchd.peruser.501:
> > ([0x0-0x91b91b].LilyPond[24997]) Exited with code: 255
> >
> > Apologies for the dump but not sure what to do with that! Seemed to
> > deserve a report somewhere - if not here, again apologies, will forward to
> > if and as I can.
> > Eric
> >
> > ------------------------------
> >
> > _______________________________________________
> > lilypond-user mailing list
> > [hidden email]
> > https://lists.gnu.org/mailman/listinfo/lilypond-user
> >
> >

> _______________________________________________
> lilypond-user mailing list
> [hidden email]
> https://lists.gnu.org/mailman/listinfo/lilypond-user


--

Colin Hall

_______________________________________________
lilypond-user mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/lilypond-user
Reply | Threaded
Open this post in threaded view
|

Re: Fatal Error on Launching 2.15.31

David Kastrup
In reply to this post by Rembrandt Wolpert
Rembrandt Wolpert <[hidden email]> writes:

> Go into Lilypond.app/Contents/
>
> open info.plist with your favourite editor and
>
> change Line 56:
>
> <string>Build from Wed Feb 29 14:13:09 2012
>
> to:
>
> <string>Build from Wed Feb 29 14:13:09 2012</string>
>
> It's an error since version 2.15.30, in the bug-reports, but not acted
> upon (why? it's so easy?)

Your patch to GUB is eagerly awaited.

--
David Kastrup


_______________________________________________
lilypond-user mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/lilypond-user
Reply | Threaded
Open this post in threaded view
|

Re: Fatal Error on Launching 2.15.31

Graham Percival-3
In reply to this post by Rembrandt Wolpert
On Sat, Mar 03, 2012 at 02:34:56PM -0600, Rembrandt Wolpert wrote:
> It's an error since version 2.15.30, in the bug-reports, but not acted
> upon (why? it's so easy?)

I don't know.  Why didn't you send a patch?

- Graham

_______________________________________________
lilypond-user mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/lilypond-user
Reply | Threaded
Open this post in threaded view
|

Re: Fatal Error on Launching 2.15.31

Klaus Föhl-2
In reply to this post by Eric Schissel
Hello,

Unpacking MacOS X x86: LilyPond 2.15.31-1 on MacMini Intel Core Duo
does not run, only standard Applications icon.

Adding the missing </string> after the character sequence including
spaces to Info.plist as noted in bug 2338. After reboot the
Lilypond icon shows up.

Double-clicking on the icon gives an error popup window,
now no explaining text. Console-dump see below.

Running lilypond itself (down in ...resources..bin...) by dragging
icon and then ly-file onto a terminal window does work.

Regards
Klaus

P.S. unavailable for testing the next three weeks :-(

Mac OS X Version 10.4.11 (Build 8S2167)
2012-03-04 21:37:44 +0000
2012-03-04 21:37:44.707 SystemUIServer[78] lang is:en
Mar  4 21:37:45 klaus-foehls-computer mDNSResponder: Adding
browse domain local.
Traceback (most recent call last):
  File "/Users/kf/Desktop/testlily/LilyPond.app/Contents/Resou
rces/__boot__.py", line 31, in <module>
    _run('LilyPond.py')
  File "/Users/kf/Desktop/testlily/LilyPond.app/Contents/Resou
rces/__boot__.py", line 28, in _run
    execfile(path, globals(), globals())
  File "/Users/kf/Desktop/testlily/LilyPond.app/Contents/Resou
rces/LilyPond.py", line 3, in <module>
    from PyObjCTools import AppHelper
  File "PyObjCTools/AppHelper.pyc", line 14, in <module>
  File "AppKit/__init__.pyc", line 9, in <module>
  File "Foundation/__init__.pyc", line 10, in <module>
  File "CoreFoundation/__init__.pyc", line 21, in <module>
  File "CoreFoundation/_CoreFoundation.pyc", line 18, in <module>
  File "CoreFoundation/_CoreFoundation.pyc", line 11, in __load
ImportError:
dlopen(/Users/kf/Desktop/testlily/LilyPond.app/Contents/Resou
rces/lib/python2.6/lib-dynload/CoreFoundation/_CoreFoundation.so,
2): Symbol not found: _CFFileDescriptorCreate
  Referenced from:
/Users/kf/Desktop/testlily/LilyPond.app/Contents/Resources/lib/py
thon2.6/lib-dynload/CoreFoundation/_CoreFoundation.so
  Expected in: /System/Library/Frameworks/CoreFoundation.frame
work/CoreFoundation

2012-03-04 21:38:00.639 LilyPond[131] LilyPond Error



_______________________________________________
lilypond-user mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/lilypond-user
Reply | Threaded
Open this post in threaded view
|

Re: Fatal Error on Launching 2.15.31

Colin Hall-3
In reply to this post by Hans Aikema-2

Hi Hans,

On Sat, Mar 03, 2012 at 06:33:49PM +0100, Hans Aikema wrote:

> On 3-3-2012 16:01, Eric wrote:
> >This may belong on the developer list- apologies.
> >Immediately after downloading and expanding 2.15.31 in the version
> >appropriate for my Macintosh (10.7.3 Intel Duo) I got a crash
> >reflected in my console with these message:
> >
> >...
> >Apologies for the dump but not sure what to do with that! Seemed
> >to deserve a report somewhere - if not here, again apologies, will
> >forward to if and as I can.
> >Eric
>
> It is a known bug presumed to be solved by the yet-to-be-released
> 2.15.32, which previously featured this list as "Mac info.plist
> problem":
>
> http://code.google.com/p/lilypond/issues/detail?id=2338
>
> You can solve it locally by adding the missing </string> in
> info.plist

I saw this post from you, a few days ago, in which you report seeing Issue 2338 with Lilypond on your MacOS X machine.

I encourage you to check out the new development release 2.15.32 which contains a candidate fix for Issue 2338.

Would be great to hear that the new release works ok for you.

Cheers,
Colin.

--

Colin Hall

_______________________________________________
lilypond-user mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/lilypond-user
Reply | Threaded
Open this post in threaded view
|

Re: Fatal Error on Launching 2.15.31

Colin Hall-3
In reply to this post by Rembrandt Wolpert

Hi Rembrandt,

On Sat, Mar 03, 2012 at 02:34:56PM -0600, Rembrandt Wolpert wrote:

> Go into Lilypond.app/Contents/
>
> open info.plist with your favourite editor and
>
> change Line 56:
>
> <string>Build from Wed Feb 29 14:13:09 2012
>
> to:
>
> <string>Build from Wed Feb 29 14:13:09 2012</string>
>
> It's an error since version 2.15.30, in the bug-reports, but not acted
> upon (why? it's so easy?)

The new development release contains a fix for this issue. Would you like to help us test it?

Just download 2.15.32, try it out, and let us know if it does or does not work for you.

Cheers,
Colin.

--

Colin Hall

_______________________________________________
lilypond-user mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/lilypond-user
Reply | Threaded
Open this post in threaded view
|

Re: Fatal Error on Launching 2.15.31

Hans Aikema-2
In reply to this post by Colin Hall-3
On 5-3-2012 23:50, Colin Hall wrote:

> Hi Hans,
>
> On Sat, Mar 03, 2012 at 06:33:49PM +0100, Hans Aikema wrote:
>> On 3-3-2012 16:01, Eric wrote:
>>> This may belong on the developer list- apologies.
>>> Immediately after downloading and expanding 2.15.31 in the version
>>> appropriate for my Macintosh (10.7.3 Intel Duo) I got a crash
>>> reflected in my console with these message:
>>>
>>> ...
>>> Apologies for the dump but not sure what to do with that! Seemed
>>> to deserve a report somewhere - if not here, again apologies, will
>>> forward to if and as I can.
>>> Eric
>> It is a known bug presumed to be solved by the yet-to-be-released
>> 2.15.32, which previously featured this list as "Mac info.plist
>> problem":
>>
>> http://code.google.com/p/lilypond/issues/detail?id=2338
>>
>> You can solve it locally by adding the missing</string>  in
>> info.plist
> I saw this post from you, a few days ago, in which you report seeing Issue 2338 with Lilypond on your MacOS X machine.
>
> I encourage you to check out the new development release 2.15.32 which contains a candidate fix for Issue 2338.
>
> Would be great to hear that the new release works ok for you.
>
> Cheers,
> Colin.
>
Colin,

Already noticed Graham Percival's 'news item' release-commit in git and
was eagerly awaiting the finishing up by actually releasing 2.15.32.
Just downloaded, unpacked and installed and it works like a charm out of
the box (Macbook Pro early 2011; Mac OS X Lion 10.7.3 (11DF50))

If there is any kind of automated test-cases that can be run natively
(no macports) on the Mac, just let me know and I'll be happy to run
them. As a developer (Java) I'm fine with command line programs / shell
scripts, it's just that I've had some bad experiences in the past with
trashing a Mac for recovery to factory defaults (full OS re-install) by
being to eager to try some macports hacks (including a lilypond 'build
from scratch'), overwriting crucial system libraries in the process, so
I tend to avoid that course of action nowadays.
My MacBook is meant as an 'it just works' device (with lilypond as the
exception where I tend to jump the unstable bandwagon after a tag or 10
into unstable). I have other systems (VMs; Windows desktop) for the
experimental stuff.

regards,
Hans

_______________________________________________
lilypond-user mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/lilypond-user
Reply | Threaded
Open this post in threaded view
|

Re: Fatal Error on Launching 2.15.31

Colin Hall-3

On Tue, Mar 06, 2012 at 12:16:55AM +0100, Hans Aikema wrote:

> On 5-3-2012 23:50, Colin Hall wrote:
> >Hi Hans,
> >
> >On Sat, Mar 03, 2012 at 06:33:49PM +0100, Hans Aikema wrote:
> >>It is a known bug presumed to be solved by the yet-to-be-released
> >>2.15.32, which previously featured this list as "Mac info.plist
> >>problem":
> >>
> >>http://code.google.com/p/lilypond/issues/detail?id=2338
> >
> >I encourage you to check out the new development release 2.15.32 which contains a candidate fix for Issue 2338.
> >
> Just downloaded, unpacked and installed and it works like a charm
> out of the box (Macbook Pro early 2011; Mac OS X Lion 10.7.3
> (11DF50))

Glad to hear the new release is working for you.

> If there is any kind of automated test-cases that can be run
> natively (no macports) on the Mac, just let me know and I'll be
> happy to run them.

OK, thanks for the offer of help. I'm not aware of a test suite that
is specific to Lilypond for MacOS X.

I'm recruiting a small cadre of Mac OS users who can verify specific
fixes in new releases. Looks like you would be up for that, yes?

Cheers,
Colin.

--

Colin Hall

_______________________________________________
lilypond-user mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/lilypond-user