Development branch doesn't run on K6-II

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Development branch doesn't run on K6-II

Paul Scott-3
Was this received or has anything new happened.  I have several machines
I was running Lily on and now can't.

Thanks,

Paul



On Debian sid on a K6-II I get:

GNU LilyPond 2.7.37

Program received signal SIGILL, Illegal instruction.
0xb7e25423 in __gmpn_mod_1 () from
/usr/local/lilypond/usr/bin/../lib/libgmp.so.3

Paul Scott




_______________________________________________
lilypond-devel mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/lilypond-devel
Reply | Threaded
Open this post in threaded view
|

Re: Development branch doesn't run on K6-II

Han-Wen Nienhuys-2
Paul Scott wrote:

> Was this received or has anything new happened.  I have several machines
> I was running Lily on and now can't.
>
> Thanks,
>
> Paul
>
>
>
> On Debian sid on a K6-II I get:
>
> GNU LilyPond 2.7.37
>
> Program received signal SIGILL, Illegal instruction.
> 0xb7e25423 in __gmpn_mod_1 () from
> /usr/local/lilypond/usr/bin/../lib/libgmp.so.3

Hi,

I've committed a fix, but I'm not sure whether it'll work. Try the
2.7.38 (which is being uploaded as I type this.)

--

Han-Wen Nienhuys - [hidden email] - http://www.xs4all.nl/~hanwen

LilyPond Software Design
  -- Code for Music Notation
http://www.lilypond-design.com



_______________________________________________
lilypond-devel mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/lilypond-devel
Reply | Threaded
Open this post in threaded view
|

Re: Development branch doesn't run on K6-II

Paul Scott-3
Han-Wen Nienhuys wrote:

> Paul Scott wrote:
>
>> Was this received or has anything new happened.  I have several
>> machines I was running Lily on and now can't.
>>
>> Thanks,
>>
>> Paul
>>
>>
>>
>> On Debian sid on a K6-II I get:
>>
>> GNU LilyPond 2.7.37
>>
>> Program received signal SIGILL, Illegal instruction.
>> 0xb7e25423 in __gmpn_mod_1 () from
>> /usr/local/lilypond/usr/bin/../lib/libgmp.so.3
>
>
> Hi,
>
> I've committed a fix, but I'm not sure whether it'll work. Try the
> 2.7.38 (which is being uploaded as I type this.)
>
Same error in libgmp.

Thanks for trying,

If I get my K7 going again I can try modifying the make process to build
for K6.  Of course then I won't care as much because I will always run
Lily on that machine.

Am I the only one affected by this?

Paul



_______________________________________________
lilypond-devel mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/lilypond-devel