Conditional segmentation faults

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Conditional segmentation faults

Jean ABOU SAMRA

I am running Ubuntu 18.04, Lilypond 2.21.4, emacs 25.2.2

Ever since I started my current Lilypond project, I have been
getting occasional segmentation faults when compiling.  Until today I
thought it was something to do with errors or inconsistencies in my
Lilypond code, and I have been able to make changes which appeared to
solve the problem.

However, today I discovered something very odd.

I edit my files in emacs, and I compile the main file by using Ctrl_C
Ctrl_L in emacs, which issues the command 'lilypond <filename>'.  Since
earlier today, whenever I do this, the compile fails with a
segmentation fault.  Sometimes commenting out one or more instruments
in the score allows the incomplete score to compile, but there seems to
be no rhyme or reason as to which combinations of instruments allow
compilation to take place successfully.

As a result, I have spent several hours today trying to work out why
this crash has started occurring again.

But now I find that if I issue the command 'lilypond <filename>'
directly from a GNOME terminal, the file compiles faultlessly.  Yet
even if I issue 'lilypond <filename>' as a shell command within emacs
(rather than using Ctrl_C Ctrl_L) I again get a segmentation fault
reported.

I have tried rebooting the computer and then running emacs without
starting any other programs at the same time, but I still get the same
result.

As I don't really understand what "segmentation fault" actually
implies, can anybody suggest why this apparently inconsistent behaviour
might be occurring?

David
Hi David,

A problem that looks similar to this one was fixed by Dan Eble in LilyPond 2.21.5:

https://gitlab.com/lilypond/lilypond/-/merge_requests/271

Could you try out that version?

Best,
Jean Abou Samra