Build issue with fontforge version

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Build issue with fontforge version

jaja
Hi,

I’m trying to compile Lilypond-dev in Mac using MacPorts.
I’ve no idea how to get pass this version issue with FontForge.

#####
ERROR: Please install required programs:  /opt/local/bin/fontforge >= 20110222 (installed: )
#####

Any help is much appreciated.


fontforge_issue (6K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Build issue with fontforge version

Carl Sorensen-3


On 4/15/20, 1:05 PM, "lilypond-devel on behalf of Nomans name" <lilypond-devel-bounces+c_sorensen=[hidden email] on behalf of [hidden email]> wrote:

Hi,

I’m trying to compile Lilypond-dev in Mac using MacPorts.
I’ve no idea how to get pass this version issue with FontForge.

#####
ERROR: Please install required programs:  /opt/local/bin/fontforge >= 20110222 (installed: )
#####

Any help is much appreciated.


CDS->  I've never done this, but here's a link that looks promising: https://www.youtube.com/watch?v=76YF2wdB49w

HTH,

Carl
I am using a brain-dead Mac version of Microsoft Outlook that does not allow proper internet-style quoting for inline replies.
So you can see that my contributions begin with CDS->

Reply | Threaded
Open this post in threaded view
|

Re: Build issue with fontforge version

jaja
Thanks Carl and sorry for late response.
I tried but it still throws back the same result.
###
ERROR: Please install required programs:  /opt/local/bin/fontforge >= 20110222 (installed: )

Note that FontForge is indeed installed with more up-to-date version.
Jajas-MacBook-Pro:build jajaman$ port list fontforge
fontforge                      @20190801       graphics/fontforge

If I go to /opt/local/bin/fontforge and run the binary, here is the msg

####
Last login: Thu Apr 23 22:56:16 on ttys001
/opt/local/bin/fontforge ; exit;
Jajas-MacBook-Pro:~ jajaman$ /opt/local/bin/fontforge ; exit;
dyld: Symbol not found: _PyBool_Type
  Referenced from: /opt/local/lib/libfontforge.3.dylib
  Expected in: flat namespace
 in /opt/local/lib/libfontforge.3.dylib
Abort trap: 6
logout
Saving session...
...copying shared history...
...saving history...truncating history files...
...completed.
####

Thanks for the tip anyway.

Regards,
Jaja


> On Apr 16, 2020, at 2:17 AM, Carl Sorensen <[hidden email]> wrote:
>
>
>
> On 4/15/20, 1:05 PM, "lilypond-devel on behalf of Nomans name" <lilypond-devel-bounces+c_sorensen=[hidden email] on behalf of [hidden email]> wrote:
>
> Hi,
>
> I’m trying to compile Lilypond-dev in Mac using MacPorts.
> I’ve no idea how to get pass this version issue with FontForge.
>
> #####
> ERROR: Please install required programs:  /opt/local/bin/fontforge >= 20110222 (installed: )
> #####
>
> Any help is much appreciated.
>
>
> CDS->  I've never done this, but here's a link that looks promising: https://www.youtube.com/watch?v=76YF2wdB49w
>
> HTH,
>
> Carl
> I am using a brain-dead Mac version of Microsoft Outlook that does not allow proper internet-style quoting for inline replies.
> So you can see that my contributions begin with CDS->
>