Bug in Lilypond 2.6.4 parser

classic Classic list List threaded Threaded
18 messages Options
Reply | Threaded
Open this post in threaded view
|

Bug in Lilypond 2.6.4 parser

Erlend Aasland
It seems that there is a serious bug in the Lilypond 2.6.4 parser, as most
files I try to typeset results in numerous errors.

For example the following small snippet, which is typeset correctly without
errors in 2.6.3 (and even 2.7.11), generates the following errors:
GNU LilyPond 2.6.4
Processing `test.ly'
Parsing...
test.ly:3 <http://test.ly:3>:20: error: syntax error, unexpected "\\>"
a->\< b->\mf
\> c->\! d->
error: errors found, ignoring music expression
error: failed files: "test"

The snippet is: \relative { a->\< b->\mf\> c->\! d-> }

I'm running Lilypond 2.6.4-1, installed from the MacOSX disk image.

Regards,
Erlend Aasland
_______________________________________________
bug-lilypond mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/bug-lilypond
Reply | Threaded
Open this post in threaded view
|

Re: Bug in Lilypond 2.6.4 parser

Han-Wen Nienhuys
Erlend Aasland wrote:
> It seems that there is a serious bug in the Lilypond 2.6.4 parser, as most
> files I try to typeset results in numerous errors.
>
> For example the following small snippet, which is typeset correctly without
> errors in 2.6.3 (and even 2.7.11), generates the following errors:

> error: errors found, ignoring music expression
> error: failed files: "test"
>
> The snippet is: \relative { a->\< b->\mf\> c->\! d-> }

Can't duplicate.

--
  Han-Wen Nienhuys - [hidden email] - http://www.xs4all.nl/~hanwen


_______________________________________________
bug-lilypond mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/bug-lilypond
Reply | Threaded
Open this post in threaded view
|

Re: Bug in Lilypond 2.6.4 parser

Erlend Aasland
On 10/12/05, Han-Wen Nienhuys <[hidden email]> wrote:
>
> Erlend Aasland wrote:
> > The snippet is: \relative { a->\< b->\mf\> c->\! d-> }
>
> Can't duplicate.


Ok, even this simple snippet (\relative { a b c d }) does not generate
correct output (only a blank page with the standard footer). I've even tried
to download the disk image once more, reinstalled, and then run Lilypond,
but it still gives errors.


Erlend

--
> Han-Wen Nienhuys - [hidden email] - http://www.xs4all.nl/~hanwen
>
_______________________________________________
bug-lilypond mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/bug-lilypond
Reply | Threaded
Open this post in threaded view
|

Re: Bug in Lilypond 2.6.4 parser

Erlend Aasland
On 10/12/05, Erlend Aasland <[hidden email]> wrote:

>
> On 10/12/05, Han-Wen Nienhuys <[hidden email]> wrote:
> >
> > Erlend Aasland wrote:
> > > The snippet is: \relative { a->\< b->\mf\> c->\! d-> }
> >
> > Can't duplicate.
>
>
> Ok, even this simple snippet (\relative { a b c d }) does not generate
> correct output (only a blank page with the standard footer). I've even tried
> to download the disk image once more, reinstalled, and then run Lilypond,
> but it still gives errors.
>

... and BTW, this is the output from Lilypond:
GNU LilyPond 2.6.4
Processing `test.ly'
Parsing...
Interpreting music... [2]
Preprocessing graphical objects...
Calculating line breaks... [2]
programming error: system with zero extent
Calculating page breaks...
programming error: Improbable offset for stencil: inf staff space
Setting to zero.
continuing, cross fingers
Layout output to `test.ps'...
Converting to `test.pdf'...

Erlend
>
> --
> > Han-Wen Nienhuys - [hidden email] - http://www.xs4all.nl/~hanwen<http://www.xs4all.nl/%7Ehanwen>
> >
>
>
_______________________________________________
bug-lilypond mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/bug-lilypond
Reply | Threaded
Open this post in threaded view
|

Re: Bug in Lilypond 2.6.4 parser

Han-Wen Nienhuys
In reply to this post by Erlend Aasland
Erlend Aasland wrote:
> I'm running Lilypond 2.6.4-1, installed from the MacOSX disk image.
>

which MacOS version?

--
  Han-Wen Nienhuys - [hidden email] - http://www.xs4all.nl/~hanwen


_______________________________________________
bug-lilypond mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/bug-lilypond
Reply | Threaded
Open this post in threaded view
|

Re: Bug in Lilypond 2.6.4 parser

Paul Scott
In reply to this post by Erlend Aasland
Erlend Aasland wrote:

>It seems that there is a serious bug in the Lilypond 2.6.4 parser, as most
>files I try to typeset results in numerous errors.
>
>For example the following small snippet, which is typeset correctly without
>errors in 2.6.3 (and even 2.7.11), generates the following errors:
>GNU LilyPond 2.6.4
>Processing `test.ly'
>Parsing...
>test.ly:3 <http://test.ly:3>:20: error: syntax error, unexpected "\\>"
>a->\< b->\mf
>\> c->\! d->
>error: errors found, ignoring music expression
>error: failed files: "test"
>
>The snippet is: \relative { a->\< b->\mf\> c->\! d-> }
>  
>
relative to what pitch?  

\relative c' or whatever?

Pauk Scott



_______________________________________________
bug-lilypond mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/bug-lilypond
Reply | Threaded
Open this post in threaded view
|

Re: Bug in Lilypond 2.6.4 parser

Erlend Aasland
In reply to this post by Han-Wen Nienhuys
MacOX 10.4.2

On 10/12/05, Han-Wen Nienhuys <[hidden email]> wrote:

>
> Erlend Aasland wrote:
> > I'm running Lilypond 2.6.4-1, installed from the MacOSX disk image.
> >
>
> which MacOS version?
>
> --
> Han-Wen Nienhuys - [hidden email] - http://www.xs4all.nl/~hanwen
>
_______________________________________________
bug-lilypond mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/bug-lilypond
Reply | Threaded
Open this post in threaded view
|

Re: Bug in Lilypond 2.6.4 parser

Erlend Aasland
In reply to this post by Paul Scott
Relative without a given starting pitch means relative middle C (See the
user manual, section 6.2.1 (page 80)).

Erlend

On 10/12/05, Paul Scott <[hidden email]> wrote:

>
> Erlend Aasland wrote:
>
> >The snippet is: \relative { a->\< b->\mf\> c->\! d-> }
> >
> >
> relative to what pitch?
>
> \relative c' or whatever?
>
> Pauk Scott
>
>
_______________________________________________
bug-lilypond mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/bug-lilypond
Reply | Threaded
Open this post in threaded view
|

Re: Bug in Lilypond 2.6.4 parser

Mats Bengtsson-6
In reply to this post by Paul Scott


Paul Scott wrote:

>
>>
>> The snippet is: \relative { a->\< b->\mf\> c->\! d-> }
>>  
>>
> relative to what pitch?
> \relative c' or whatever?

Maybe you haven't noticed that this is permitted in LilyPond since
version 2.4. If you don't specify any pitch, then it is relative to c
(in other words, you have to specify the absolute pitch of the first
note).

   /Mats


_______________________________________________
bug-lilypond mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/bug-lilypond
Reply | Threaded
Open this post in threaded view
|

Re: Bug in Lilypond 2.6.4 parser

Paul Scott
Mats Bengtsson wrote:

>
> Paul Scott wrote:
>
>>>
>>> The snippet is: \relative { a->\< b->\mf\> c->\! d-> }
>>>
>> relative to what pitch? \relative c' or whatever?
>
>
> Maybe you haven't noticed that this is permitted in LilyPond since
> version 2.4. If you don't specify any pitch, then it is relative to c
> (in other words, you have to specify the absolute pitch of the first
> note).

Thank you both.  I hadn't noticed.

Paul



_______________________________________________
bug-lilypond mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/bug-lilypond
Reply | Threaded
Open this post in threaded view
|

Re: Bug in Lilypond 2.6.4 parser

Chris Sawer
In reply to this post by Erlend Aasland
I'm getting the same problem with Mac OS X 10.4.2. Pretty much every  
file seems to fail with errors similar to the following. Reverting  
back to LilyPond 2.6.3 makes things work again.

Chris


Chris:~/munew/src/elias_32 chris$ lilypond-2.6 elias_32.ly
GNU LilyPond 2.6.4
Processing `elias_32.ly'
Parsing...
elias_32.ly:24:9: error: syntax error, unexpected "\\<"
      c4\p
          \< c c a\! d\> c8 bes8 a2\! f4\pp( g a ) c bes2 a a4 c
\cresc c f f e8 e\noBeam f2\f
elias_32.ly:24:42: error: syntax error, unexpected '('
      c4\p\< c c a\! d\> c8 bes8 a2\! f4\pp
                                           ( g a ) c bes2 a a4 c
\cresc c f f e8 e\noBeam f2\f

(etc. etc.)


On 12 Oct 2005, at 00:24, Erlend Aasland wrote:

> MacOX 10.4.2
>
> On 10/12/05, Han-Wen Nienhuys <[hidden email]> wrote:
>
>>
>> Erlend Aasland wrote:
>>
>>> I'm running Lilypond 2.6.4-1, installed from the MacOSX disk image.
>>>
>>>
>>
>> which MacOS version?
>>
>> --
>> Han-Wen Nienhuys - [hidden email] - http://www.xs4all.nl/~hanwen
>>
>>
> _______________________________________________
> bug-lilypond mailing list
> [hidden email]
> http://lists.gnu.org/mailman/listinfo/bug-lilypond
>
>

--

Chris Sawer - [hidden email] - Mutopia team leader
Free sheet music for all at:  http://www.MutopiaProject.org/




_______________________________________________
bug-lilypond mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/bug-lilypond
Reply | Threaded
Open this post in threaded view
|

Re: Bug in Lilypond 2.6.4 parser

Han-Wen Nienhuys
Chris Sawer wrote:
> I'm getting the same problem with Mac OS X 10.4.2. Pretty much every  
> file seems to fail with errors similar to the following. Reverting  back
> to LilyPond 2.6.3 makes things work again.

It seems that macos 10.4 is the common factor. Could you guys also try
whether the latest 2.7 releases do work?

--
  Han-Wen Nienhuys - [hidden email] - http://www.xs4all.nl/~hanwen



_______________________________________________
bug-lilypond mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/bug-lilypond
Reply | Threaded
Open this post in threaded view
|

Re: Bug in Lilypond 2.6.4 parser

Erlend Aasland
Yes, the latest (2.7.12) works fine for me. I've just done a CVS build of
2.7.13 and that also works fine.

On 10/13/05, Han-Wen Nienhuys <[hidden email]> wrote:

>
> Chris Sawer wrote:
> > I'm getting the same problem with Mac OS X 10.4.2. Pretty much every
> > file seems to fail with errors similar to the following. Reverting back
> > to LilyPond 2.6.3 makes things work again.
>
> It seems that macos 10.4 is the common factor. Could you guys also try
> whether the latest 2.7 releases do work?
>
> --
> Han-Wen Nienhuys - [hidden email] - http://www.xs4all.nl/~hanwen
>
>
_______________________________________________
bug-lilypond mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/bug-lilypond
Reply | Threaded
Open this post in threaded view
|

Re: Bug in Lilypond 2.6.4 parser

Erlend Aasland
I've built 2.6.4 from CVS, and can confirm that it runs without problems
from the build directory. Perhaps it is some of the bundled libraries that
creates the problems... I'll see if I can look more into later.

On 10/13/05, Erlend Aasland <[hidden email]> wrote:

>
> Yes, the latest (2.7.12) works fine for me. I've just done a CVS build of
> 2.7.13 and that also works fine.
>
> On 10/13/05, Han-Wen Nienhuys < [hidden email]> wrote:
> >
> > Chris Sawer wrote:
> > > I'm getting the same problem with Mac OS X 10.4.2. Pretty much every
> > > file seems to fail with errors similar to the following. Reverting
> > back
> > > to LilyPond 2.6.3 makes things work again.
> >
> > It seems that macos 10.4 is the common factor. Could you guys also try
> > whether the latest 2.7 releases do work?
> >
> > --
> > Han-Wen Nienhuys - [hidden email] - http://www.xs4all.nl/~hanwen<http://www.xs4all.nl/%7Ehanwen>
> >
> >
>
_______________________________________________
bug-lilypond mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/bug-lilypond
Reply | Threaded
Open this post in threaded view
|

Re: Bug in Lilypond 2.6.4 parser

Han-Wen Nienhuys
Erlend Aasland wrote:
> I've built 2.6.4 from CVS, and can confirm that it runs without problems
> from the build directory. Perhaps it is some of the bundled libraries
> that creates the problems... I'll see if I can look more into later.

I suspect the problem is on my side. I have to resort to some dirty
tricks to make it compile here, since I'm still on MacOS 10.3

--
  Han-Wen Nienhuys - [hidden email] - http://www.xs4all.nl/~hanwen


_______________________________________________
bug-lilypond mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/bug-lilypond
Reply | Threaded
Open this post in threaded view
|

Re: Bug in Lilypond 2.6.4 parser

Han-Wen Nienhuys
In reply to this post by Erlend Aasland

Hi guys,

can you check whether

  lilypond.org/~hanwen/lilypond-2.6.4-1.dmg

does work for you?   I've built it afresh with the same compiler I used
for previous 2.6 releases.

Erlend Aasland wrote:

> For example the following small snippet, which is typeset correctly without
> errors in 2.6.3 (and even 2.7.11), generates the following errors:
> GNU LilyPond 2.6.4
> Processing `test.ly'
> Parsing...
> test.ly:3 <http://test.ly:3>:20: error: syntax error, unexpected "\\>"
> a->\< b->\mf
> \> c->\! d->
> error: errors found, ignoring music expression
> error: failed files: "test"
>
> The snippet is: \relative { a->\< b->\mf\> c->\! d-> }
>
> I'm running Lilypond 2.6.4-1, installed from the MacOSX disk image.

--
  Han-Wen Nienhuys - [hidden email] - http://www.xs4all.nl/~hanwen


_______________________________________________
bug-lilypond mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/bug-lilypond
Reply | Threaded
Open this post in threaded view
|

Re: Bug in Lilypond 2.6.4 parser

Graham Percival-2

On 2-Nov-05, at 1:33 PM, Han-Wen Nienhuys wrote:

> can you check whether
>
>  lilypond.org/~hanwen/lilypond-2.6.4-1.dmg
>
> does work for you?   I've built it afresh with the same compiler I
> used for previous 2.6 releases.

Works here, thanks.

FWIW, this is on a machine in the computer music lab; my own machine is
still 10.3.9.  :(

- Graham



_______________________________________________
bug-lilypond mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/bug-lilypond
Reply | Threaded
Open this post in threaded view
|

Re: Bug in Lilypond 2.6.4 parser

Erlend Aasland
Yes, works perfectly here too!

On 11/2/05, Graham Percival <[hidden email]> wrote:

>
>
> On 2-Nov-05, at 1:33 PM, Han-Wen Nienhuys wrote:
>
> > can you check whether
> >
> > lilypond.org/~hanwen/lilypond-2.6.4-1.dmg<http://lilypond.org/~hanwen/lilypond-2.6.4-1.dmg>
> >
> > does work for you? I've built it afresh with the same compiler I
> > used for previous 2.6 releases.
>
> Works here, thanks.
>
> FWIW, this is on a machine in the computer music lab; my own machine is
> still 10.3.9. :(
>
> - Graham
>
>
_______________________________________________
bug-lilypond mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/bug-lilypond