2.5.31 on Fedora Core 4 [WAS: LilyPond 2.5.31 RPM for FC4]

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

2.5.31 on Fedora Core 4 [WAS: LilyPond 2.5.31 RPM for FC4]

John Mandereau
> I have just installed Fedora Core 4 from scratch, and then installed
> LilyPond RPMs (compatibility libs, Ghostscript, LilyPond and
> documentation).
Precision: it runs on an i686 (AMD Athlon)

> LilyPond crashes with the same screen output, whatever the input file
> is. It even gives this output when the input file doesn't exist. Here's
> the output:
>
> $ lilypond -V foo.ly
> GNU LilyPond 2.5.31
>
> LILYPOND_DATADIR="/usr/share/lilypond/2.5.31"
> LOCALEDIR="/usr/share/locale"
>
> Effective prefix: "/usr/share/lilypond/2.5.31"
> /usr/share/guile/1.6/srfi/srfi-13.scm:159:1: In procedure dynamic-link
> in expression (load-extension "libguile-srfi-srfi-13-14-v-1"
> "scm_init_srfi_13"):
> /usr/share/guile/1.6/srfi/srfi-13.scm:159:1: file:
> "libguile-srfi-srfi-13-14-v-1", message:
> "libguile-srfi-srfi-13-14-v-1.so: cannot open shared object file: No
> such file or directory"
>
> I don't understand what I've done wrong. I can just say that package
> guile 5:1.6.7-2 is installed.
> Maybe the RPMs were corrupted during download.
> I'm going to remove Lily RPMs and try another installation method.

I removed LilyPond and LilyPond doc RPMs, but kept Ghostscript and
compatibility libs. Then I tried autopackage, the installation script
says:

        Vérification de versions de bilbiothèque C requise ...  OK
        Vérification de FreeType font library ...  OK
        Vérification de Standard C++ library ...  à échoué
        -------------------------------
        Erreur: Package 'Standard C++ library' was found but was of the
        wrong version and the correct version could not be located.
       
        [IV 3 for @gnu.org/libstdc++]
       
        Erreur: Ne peut pas préparer le paquet LilyPond.
       
libstdc++ version 4.0.0-8 is installed on my system.

After that I decided to build Lily from the source tarball... and
everything worked perfectly [after potrace, t1utils and mftrace
installation and including /sbin in PATH], including the documentation
building!
What do you think of that?
I hope Lily 2.6 RPMs will work for most users... I'm sorry I can't help
building RPMs (until I learn how to).
--
John Mandereau <[hidden email]>



_______________________________________________
lilypond-user mailing list
[hidden email]
http://lists.gnu.org/mailman/listinfo/lilypond-user